Project

General

Profile

action #25992

coordination #23886: [sle][functional][desktop][sle15][epic] initial setup

[sle][functional][sle15][desktop] The shutdown-auth is not expected in sled15

Added by qkzhu over 4 years ago. Updated over 4 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Bugs in existing tests
Target version:
-
Start date:
2017-10-12
Due date:
2017-11-08
% Done:

0%

Estimated time:
Difficulty:

Description

Observation

openQA test in scenario sle-15-Installer-DVD-x86_64-create_hdd_sled_gnome@64bit fails in
shutdown

Reproducible

Fails since (at least) Build 288.8

Further details

shutdown.pm of create_hdd_sled_gnome want to match shutdown-auth for sled15 since
we have defined SHUTDOWN_NEEDS_AUTH=1 in the medium type of sle-15-Installer-DVD.
However the shutdown authentication is not expected in SLED.

In SLE 12 there are medium types for Desktop and Server respectively, but we only have one medium type called
sle-15-Installer-DVD in SLE15.

We could fix this issues in different ways:

  1. Add SHUTDOWN_NEEDS_AUTH=0 for all testsuite of SLED, but for testsuite which is used by both Server and Desktop(eg testsuite: gnome) we have to add a new testsuite like gnome-sled or something else.

  2. Set SHUTDOWN_NEEDS_AUTH=0 in main.pm when SLE_PRODUCT=sled

  3. Add a new medium type for SLED15

Hi okurz, do you have any ideas about this?

History

#1 Updated by qkzhu over 4 years ago

  • Parent task set to #23886

#2 Updated by okurz over 4 years ago

  • Due date set to 2017-11-08

#3 Updated by okurz over 4 years ago

  • Subject changed from [sle15][functional][desktop] The shutdown-auth is not expected in sled15 to [sle15][desktop] The shutdown-auth is not expected in sled15
  • Status changed from New to In Progress
  • Assignee set to okurz

#4 Updated by okurz over 4 years ago

  • Subject changed from [sle15][desktop] The shutdown-auth is not expected in sled15 to [sle][functional][sle15][desktop] The shutdown-auth is not expected in sled15
  • Status changed from In Progress to Resolved

merged. I went with suggestion "2." here.

#5 Updated by qkzhu over 4 years ago

Since we already have:

# SLE needs auth for shutdown
if (!defined get_var('SHUTDOWN_NEEDS_AUTH') && !is_desktop) {
set_var('SHUTDOWN_NEEDS_AUTH', 1);

}

in main.pm,

we should remove SHUTDOWN_NEEDS_AUTH=1 in the medium type of sle-15-Installer-DVD.
Otherwise SLED will still uses the default value SHUTDOWN_NEEDS_AUTH=1

#6 Updated by okurz over 4 years ago

of course. I did now. Sorry I resolved the bug before checking everything but as we are stuck in a bug in https://openqa.suse.de/tests/1236647#step/first_boot/4 I did not want to wait until we finally reach further.

Also available in: Atom PDF