Project

General

Profile

action #19252

[tools] SUT is to fast for wait_boot at initial startup (SLOF on QA-Power8 related?)

Added by nicksinger over 4 years ago. Updated over 4 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Bugs in existing tests
Target version:
-
Start date:
2017-05-19
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

Observation

openQA test in scenario sle-12-SP3-Server-DVD-ppc64le-extra_tests_in_textmode_ppc@ppc64le fails in
boot_to_desktop

From what i can see on the screenshots, the system was perfectly able to boot up.
The issue here seems to be that "wait_boot" - which is used here to wait until the system boots up - "just" checks for bootloader needles.

Reproducible

I see this the first time. But maybe running this test on a fast enough machine can reproduce this :)
Fails since (at least) Build 0304

It happened 4 non-consecutive times since the last 20 previous jobs.

Expected result

wait_boot should not fail if openQA misses to catch the bootloader while the system itself is able to boot up fine.

Last good: (unknown) (or more recent)

Further details

Always latest result in this scenario: latest

Workaround

Restart the job.


Related issues

Related to openQA Project - action #19194: [tools] figure out why QA-Power8-5-kvm fails more than malbecResolved2017-05-17

History

#1 Updated by nicksinger over 4 years ago

Forgot to mention:
maybe this is somehow related to https://progress.opensuse.org/issues/15170 even though the description sounds quiet different.

#2 Updated by nicksinger over 4 years ago

  • Subject changed from [tools] SUT is to fast for wait_boot subroutine used in openQA to [functional] SUT is to fast for wait_boot subroutine used in openQA
  • Category changed from Infrastructure to Bugs in existing tests

#3 Updated by okurz over 4 years ago

  • Is duplicate of action #18924: [tools][sles][functional] test fails in grub_test - grub screen was not matched in time added

#4 Updated by okurz over 4 years ago

  • Status changed from New to Rejected
  • Assignee set to okurz

duplicate of #18924

#5 Updated by nicksinger over 4 years ago

  • Subject changed from [functional] SUT is to fast for wait_boot subroutine used in openQA to [tools] SUT is to fast for wait_boot at initial startup (SLOF on QA-Power8 related?)
  • Status changed from Rejected to Feedback
  • Assignee deleted (okurz)

Sorry okurz but this is no duplicate IMHO.
All tests linked in poo#19194 fail while the system is rebooting but openQA was at least able to see the bootloader once at the initial startup.
This case shows a test which fails instantly to recognize the bootloader which is, according to @rbrowns explanation most likely linked to the SLOF on QA-Power8.
Therefore I set this to feedback and relate it to #19194 ([tools] figure out why QA-Power8-5-kvm fails more than malbec) at least until we know that QA-Power8 is fine.

#6 Updated by nicksinger over 4 years ago

  • Is duplicate of deleted (action #18924: [tools][sles][functional] test fails in grub_test - grub screen was not matched in time)

#7 Updated by nicksinger over 4 years ago

  • Related to action #19194: [tools] figure out why QA-Power8-5-kvm fails more than malbec added

#8 Updated by okurz over 4 years ago

Hm, I'm not sure but ok. When we are not sure better keep it separate and investigate further. Thank you for your attention to detail.

#9 Updated by SLindoMansilla over 4 years ago

  • Description updated (diff)

#10 Updated by RBrownSUSE over 4 years ago

  • Status changed from Feedback to Resolved

Also available in: Atom PDF