action #19408

interactive mode: stopped live view shows current needle, needle editor shows old needle

Added by okurz over 2 years ago. Updated almost 2 years ago.

Status:ClosedStart date:29/05/2017
Priority:NormalDue date:
Assignee:coolo% Done:

0%

Category:Concrete Bugs
Target version:Done
Difficulty:
Duration:

Description

observation

I was running a test in interactive mode. In one step the test could not find a needle but I saw near matches with 80% match. After the test paused execution (interactive: yes, waiting for input: yes), I could see a needle of "yast2 dns-server" status of dns-server "stopped" as expected. Going into the needle editor showed me an old screen with status dns-server "running". Refreshing the page in either the live view or the needle editor did not change this. See the attached video for the whole impression. After "reloading & retry" the needles although they were not changed the live view still showed the same content, in the needle editor now the same, expected screen was shown

steps to reproduce

  • run a test in interactive mode with immediately stop waiting for needles where one needle change would immediately be expected after an action in the test
  • observe current needle in live view
  • go to needle editor and observe old needle is shown

problem

Probably introduced by rework of the screenshot enqueueing in 2016 or maybe also by the most recent commit 52e3055

further details

running os-autoinst on 52e3055, openQA on bc8b1c6a

GIFrecord_2017-05-29_125505.gif - video showing current needle in live view but old one in needle editor (235 KB) okurz, 29/05/2017 11:02 am

3132

Related issues

Related to openQA Project - action #19302: Needle match may work on outdated screen contents Resolved 22/05/2017
Related to openQA Project - action #15298: black screen in interactive mode when going to needle editor Resolved 05/12/2016
Duplicates openQA Project - action #17786: [tools]NFS-less mode: Interactive mode needs to resync ne... Closed 19/03/2017

History

#1 Updated by okurz over 2 years ago

  • Related to action #19302: Needle match may work on outdated screen contents added

#2 Updated by okurz over 2 years ago

  • Related to action #15298: black screen in interactive mode when going to needle editor added

#3 Updated by szarate over 2 years ago

  • Status changed from New to In Progress
  • Assignee set to szarate

This is being addressed in https://github.com/os-autoinst/openQA/pull/1381

The problem was actually very simple: The commands.pm on the worker side, was asking isotovideo to reload the needles, but it wasn't refreshing the cache itself, as the isotovideo backend is agnostic to whether there is caching enabled or not, lead to the new needle not being reloaded when they are re-initialized in isotovideo.

#4 Updated by szarate over 2 years ago

  • Duplicates action #17786: [tools]NFS-less mode: Interactive mode needs to resync needles added

#5 Updated by coolo over 2 years ago

  • Subject changed from interactive mode: stopped live view shows current needle, needle editor shows old needle to [tools] interactive mode: stopped live view shows current needle, needle editor shows old needle
  • Target version set to Milestone 9

there is a PR pending for it, which needs work

#6 Updated by szarate over 2 years ago

  • Subject changed from [tools] interactive mode: stopped live view shows current needle, needle editor shows old needle to [tools][sprint 201711.1] interactive mode: stopped live view shows current needle, needle editor shows old needle

With last PR needles are synced, but somehow the reload is not performing any actions.

#7 Updated by coolo over 2 years ago

  • Subject changed from [tools][sprint 201711.1] interactive mode: stopped live view shows current needle, needle editor shows old needle to interactive mode: stopped live view shows current needle, needle editor shows old needle
  • Assignee changed from szarate to coolo
  • Priority changed from High to Normal
  • Target version changed from Milestone 9 to Ready

As Santi is not doing any progress, I'm declaring this as part of the epic to redo the interactive mode

#8 Updated by coolo over 2 years ago

  • Status changed from In Progress to Closed

refusing to work on old interactive mode

#9 Updated by szarate almost 2 years ago

  • Target version changed from Ready to Done

Also available in: Atom PDF