Project

General

Profile

Actions

action #12966

closed

Enable iSCSI client/server test scenario for openSUSE

Added by okurz almost 8 years ago. Updated 4 months ago.

Status:
Resolved
Priority:
Low
Assignee:
-
Target version:
-
Start date:
2015-11-11
Due date:
% Done:

100%

Estimated time:
Tags:

Description

implementation done and verified for SLE in #9482, now enable for openSUSE

Acceptance criteria

  1. iSCSI test is enabled for TW (64bit only)
  2. Lubos Kocman is contacted to confirm if he wants this test suite be enabled for Leap, depending on outcome, either follow-up ticket is filed, or the scenario is enabled in the scope of this ticket
  3. yaml schedule is applied for scheduling of the test suites

Suggestions

To make it smooth, please, enable new test suite in the development job group first and if that works, then move it to the main job group.

Motivation

We would like to test iscsi client and server configuration tools on openSUSE as well.

See iscsi_client and iscsi_server scenarios on SLE.

Acceptance criteria

  1. iscsi_client and iscsi_server scenarios are enabled on o3

Tasks

Technical difficulty here is caused by workers configuration, as we don't have multimachine setup on o3.

  1. Learn o3 worker setup
  2. Configure mentioned test suites on o3

Suggestion

Enable test suite in development job group and move to TW.
Richard Brown (sysrich on irc) is a perfect contact person to ask about MM setup on o3.

So, openqaworker1 has a WORKER_CLASS tap (e.g. https://openqa.opensuse.org/admin/workers/54) which refers to MM.
https://openqa.opensuse.org/tests/latest?machine=64bit&distri=opensuse&arch=x86_64&test=wicked_basic_ref&flavor=DVD&version=Tumbleweed is wicked MM test, which can be used as a reference, but be careful, it uses WORKER_CLASS=qemu_x86_64, I believe it should be at least WORKER_CLASS=qemu_x86_64,tap and NICTYPE=tap

NOTE: no tasks related to the MM setup should be addressed here, in case it doesn't work this ticket should be blocked and resolve impediment.


Checklist

  • TW
  • Leap

Related issues 3 (0 open3 closed)

Related to qe-yam - action #37045: [opensuse][functional][y] enable iscsi server/client scenario for openSUSERejectedriafarov2018-06-11

Actions
Blocked by openQA Tests - action #30892: [opensuse][tools]multi-machine worker setupResolvedokurz2018-01-29

Actions
Copied from openQA Tests - action #9482: iSCSIResolveddzedro2015-11-11

Actions
Actions

Also available in: Atom PDF