Project

General

Profile

action #37045

[opensuse][functional][y] enable iscsi server/client scenario for openSUSE

Added by riafarov over 3 years ago. Updated about 1 year ago.

Status:
Rejected
Priority:
Normal
Assignee:
Target version:
Start date:
2018-06-11
Due date:
% Done:

0%

Estimated time:

Description

Motivation

We would like to test iscsi client and server configuration tools on openSUSE as well.

See iscsi_client and iscsi_server scenarios on SLE.

Acceptance criteria

  1. iscsi_client and iscsi_server scenarios are enabled on o3

Tasks

Technical difficulty here is caused by workers configuration, as we don't have multimachine setup on o3.

  1. Learn o3 worker setup
  2. Configure mentioned test suites on o3

Suggestion

Enable test suite in development job group and move to TW.
Richard Brown (sysrich on irc) is a perfect contact person to ask about MM setup on o3.

So, openqaworker1 has a WORKER_CLASS tap (e.g. https://openqa.opensuse.org/admin/workers/54) which refers to MM.
https://openqa.opensuse.org/tests/latest?machine=64bit&distri=opensuse&arch=x86_64&test=wicked_basic_ref&flavor=DVD&version=Tumbleweed is wicked MM test, which can be used as a reference, but be careful, it uses WORKER_CLASS=qemu_x86_64, I believe it should be at least WORKER_CLASS=qemu_x86_64,tap and NICTYPE=tap

NOTE: no tasks related to the MM setup should be addressed here, in case it doesn't work this ticket should be blocked and resolve impediment.


Related issues

Related to qe-yast - action #12966: Enable iSCSI client/server test scenario for openSUSEBlocked2015-11-11

Related to openQA Tests - action #57248: [opensuse][aarch64] iscsi_{client,server} tests are failingBlocked2019-09-24

Blocked by openQA Tests - action #30892: [opensuse][tools]multi-machine worker setupResolved2018-01-29

History

#1 Updated by riafarov over 3 years ago

  • Category set to New test

#2 Updated by okurz over 3 years ago

  • Blocked by action #30892: [opensuse][tools]multi-machine worker setup added

#3 Updated by okurz over 3 years ago

  • Target version set to future

#4 Updated by okurz over 3 years ago

  • Target version changed from future to future

#5 Updated by okurz about 3 years ago

  • Subject changed from [opensuse][functional] enable iscsi server/client scenario for openSUSE to [opensuse][functional][u] enable iscsi server/client scenario for openSUSE

#6 Updated by okurz about 3 years ago

  • Status changed from New to Blocked
  • Assignee set to okurz

#7 Updated by okurz over 2 years ago

  • Priority changed from Normal to Low

#8 Updated by okurz over 2 years ago

  • Assignee changed from okurz to mgriessmeier

Move to new QSF-u PO after I moved to the "tools"-team. I mainly checked the subject line so in individual instances you might not agree to take it over completely into QSF-u. Feel free to discuss with me or reassign to me or someone else in this case. Thanks.

#9 Updated by okurz over 2 years ago

  • Status changed from Blocked to Workable

#30892 fixed, multi-machine tests are possible on o3

#10 Updated by okurz over 2 years ago

  • Related to action #12966: Enable iSCSI client/server test scenario for openSUSE added

#11 Updated by riafarov over 2 years ago

  • Subject changed from [opensuse][functional][u] enable iscsi server/client scenario for openSUSE to [opensuse][functional][y] enable iscsi server/client scenario for openSUSE
  • Due date set to 2019-06-18
  • Assignee deleted (mgriessmeier)

I guess it's actually Y =) Taking over.

#12 Updated by riafarov over 2 years ago

  • Description updated (diff)
  • Estimated time set to 3.00 h

#13 Updated by riafarov over 2 years ago

  • Description updated (diff)

#14 Updated by riafarov over 2 years ago

  • Description updated (diff)

#15 Updated by riafarov over 2 years ago

  • Due date changed from 2019-06-18 to 2019-07-02

#16 Updated by riafarov over 2 years ago

  • Due date changed from 2019-07-02 to 2019-07-16

We find remote vnc installation more important.

#17 Updated by JERiveraMoya over 2 years ago

  • Status changed from Workable to In Progress
  • Assignee set to JERiveraMoya

#18 Updated by JERiveraMoya over 2 years ago

Test suites added to Development, they should work in the same way than wicked sample. Waiting for next build.

#19 Updated by JERiveraMoya over 2 years ago

  • Status changed from In Progress to Feedback

Same network issue seen for remote_controller: https://openqa.opensuse.org/tests/975206#step/iscsi_server/44

#20 Updated by JERiveraMoya over 2 years ago

  • Status changed from Feedback to Blocked

#21 Updated by riafarov over 2 years ago

  • Estimated time deleted (3.00 h)

So, actually problem is in the tests:
[ 101.061559] NetworkManager[953]: [1562228785.8757] device (ens4): state change: ip-config -> failed (reason 'ip-config-unavailable', sys-iface-state: 'managed')
[ 101.067915] avahi-daemon[864]: Interface ens4.IPv6 no longer relevant for mDNS

We have wicked in SLES, but in TW with gnome we have NM, so it doesn't work. We need to re-evaluate the estimation, as we have missed this point. Whereas MM setup on o3 is fine.

#22 Updated by riafarov over 2 years ago

  • Due date changed from 2019-07-16 to 2019-08-13
  • Status changed from Blocked to Workable
  • Assignee deleted (JERiveraMoya)
  • Priority changed from Low to Normal

We want to solve the problem with execution of MM tests during the development first.

#23 Updated by riafarov over 2 years ago

  • Due date changed from 2019-08-13 to 2019-08-27

#24 Updated by riafarov over 2 years ago

  • Due date changed from 2019-08-27 to 2019-09-24
  • Status changed from Workable to Blocked
  • Assignee set to riafarov

Blocked by #9900, let's estimate after it.

#25 Updated by riafarov about 2 years ago

  • Due date changed from 2019-09-24 to 2019-10-29

#26 Updated by okurz about 2 years ago

  • Related to action #57248: [opensuse][aarch64] iscsi_{client,server} tests are failing added

#27 Updated by riafarov about 2 years ago

  • Due date deleted (2019-10-29)

#28 Updated by riafarov about 1 year ago

  • Project changed from openQA Tests to qe-yast
  • Category deleted (New test)
  • Status changed from Blocked to New
  • Assignee deleted (riafarov)

#29 Updated by riafarov about 1 year ago

  • Status changed from New to Rejected
  • Assignee set to riafarov

Duplicate of #12966 moved relevant information to that ticket.

Also available in: Atom PDF