Project

General

Profile

coordination #12808

[sle][opensuse][functional][y][epic] Adapt testsuite textmode for ncurses - WAS(Update partitioning_filesystem for textmode installations)

Added by dirkmueller about 5 years ago. Updated 11 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
New test
Target version:
SUSE QA - Milestone 17
Start date:
2017-11-20
Due date:
2018-06-19
% Done:

100%

Estimated time:
(Total: 0.00 h)
Difficulty:

Description

In the Tumbleweed aarch64 case we're trying to change the filesystem in textmode ncurses, which causes a test run failure, as visible e.g. here:

https://openqa.opensuse.org/tests/226518#step/partitioning_filesystem/3

can the test be updated to also handle textmode installs?

Latest: https://openqa.opensuse.org/tests/latest?version=Tumbleweed&distri=opensuse&arch=aarch64&machine=aarch64&flavor=DVD&test=textmode


Subtasks

action #27961: [opensuse][sle][story][medium] Adapt **partitioning_filesystem** for ncursesResolvedSLindoMansilla

action #30433: [opensuse][functional][y][easy] Enable tests for module "partitioning_filesystem" for openSUSE (O3) in *textmode*ResolvedJERiveraMoya


Related issues

Related to openQA Tests - action #36844: [functional][sle][y] Schedule new filesystem test suites for SLERejected2018-06-06

History

#1 Updated by okurz about 5 years ago

sure the module can be updated. Each "assert_and_click" needs to be replaced by proper assert_screen and either send_key or type_string as clicking does not work in textmode. For anyone that would try to solve this I suggest to

  • call clone_job.pl --from http://openqa.opensuse.org 226518
  • let openQA reproduce the test failure
  • update the test module
  • crosscheck non-textmode installation, e.g. standard scenario
  • push PR

#2 Updated by maritawerner almost 5 years ago

  • Assignee set to okurz

Oli, that is fixed, right? Can we sloe that ticket?

#3 Updated by dirkmueller almost 5 years ago

.

#4 Updated by okurz almost 5 years ago

  • Assignee deleted (okurz)
  • Priority changed from Normal to Low

It's not fixed as the module partitioning_filesystem still uses assert_and_click whereas it should use hotkeys. However https://openqa.opensuse.org/tests/latest?version=Tumbleweed&distri=opensuse&arch=aarch64&machine=aarch64&flavor=DVD&test=textmode does not fail anymore because btrfs was deemed as unstable for aarch64 for some time. That is why the failing test had the setting FILESYSTEM=ext4. This was changed some time ago so it's using btrfs again and therefore does not call the module partitioning_filesystem.

This task could be a good introduction ticket for newbies.

#5 Updated by okurz almost 5 years ago

  • Category set to New test

#6 Updated by asmorodskyi over 4 years ago

  • Subject changed from Update partitioning_filesystem for textmode installations to [sles][opensuse] Update partitioning_filesystem for textmode installations

#7 Updated by okurz about 4 years ago

  • Assignee set to SLindoMansilla

hi, you had been working on updating partitioning tests. Can you take a look at this ticket please?

#8 Updated by SLindoMansilla about 4 years ago

  • Status changed from New to In Progress

#9 Updated by SLindoMansilla about 4 years ago

  • Description updated (diff)

#10 Updated by SLindoMansilla almost 4 years ago

okurz, should be this ticket assigned to a sprint?

#11 Updated by okurz almost 4 years ago

  • Target version set to Milestone 14

scheduled for M14, please make it workable and we can consider it for one of the upcoming sprints as well.

#12 Updated by SLindoMansilla almost 4 years ago

  • Subject changed from [sles][opensuse] Update partitioning_filesystem for textmode installations to [sles][opensuse][epic] Adapt testsuite textmode for ncurses - WAS(Update partitioning_filesystem for textmode installations)

#13 Updated by okurz almost 4 years ago

  • Due date set to 2018-01-03

due to changes in a related task

#14 Updated by SLindoMansilla over 3 years ago

  • Due date changed from 2018-01-03 to 2018-01-16

due to changes in a related task

#15 Updated by okurz over 3 years ago

  • Due date changed from 2018-01-16 to 2018-01-30

due to changes in a related task

#16 Updated by SLindoMansilla over 3 years ago

Dirk, the code changes are already on productive instances. Test suites for ncurses (VIDEOMODE=text) are possible now.

#17 Updated by SLindoMansilla over 3 years ago

  • Status changed from In Progress to Feedback
  • Assignee deleted (SLindoMansilla)

#18 Updated by SLindoMansilla over 3 years ago

  • Status changed from Feedback to Workable

Sub-task waiting to be planned: https://progress.opensuse.org/issues/30433

Ignore due date of epic, because it is inherited by sub-tickets.

#19 Updated by okurz over 3 years ago

  • Due date changed from 2018-01-30 to 2018-03-27

due to changes in a related task

#20 Updated by okurz over 3 years ago

  • Subject changed from [sles][opensuse][epic] Adapt testsuite textmode for ncurses - WAS(Update partitioning_filesystem for textmode installations) to [sle][opensuse][functional][epic] Adapt testsuite textmode for ncurses - WAS(Update partitioning_filesystem for textmode installations)
  • Target version changed from Milestone 14 to Milestone 15

#21 Updated by okurz over 3 years ago

  • Due date changed from 2018-03-27 to 2018-01-30

due to changes in a related task

#22 Updated by okurz over 3 years ago

  • Target version changed from Milestone 15 to Milestone 17

setting target version to same as only still open subticket -> M17

#23 Updated by okurz over 3 years ago

  • Subject changed from [sle][opensuse][functional][epic] Adapt testsuite textmode for ncurses - WAS(Update partitioning_filesystem for textmode installations) to [sle][opensuse][functional][y][epic] Adapt testsuite textmode for ncurses - WAS(Update partitioning_filesystem for textmode installations)

#24 Updated by okurz over 3 years ago

  • Due date changed from 2018-01-30 to 2018-06-19

due to changes in a related task

#25 Updated by SLindoMansilla over 3 years ago

  • Status changed from Workable to In Progress

All sub tickets resolved

#26 Updated by SLindoMansilla over 3 years ago

  • Status changed from In Progress to Resolved

#27 Updated by SLindoMansilla over 3 years ago

  • Related to action #36844: [functional][sle][y] Schedule new filesystem test suites for SLE added

#29 Updated by okurz over 3 years ago

  • Target version changed from Milestone 17 to Milestone 17

#30 Updated by szarate 11 months ago

  • Tracker changed from action to coordination

Also available in: Atom PDF