Project

General

Profile

action #12350

[tools]version of os-autoinst on malbec+overdrive2 should be same as other workers (using salt) (was: looks like old version)

Added by okurz almost 6 years ago. Updated about 5 years ago.

Status:
Resolved
Priority:
High
Assignee:
Category:
Infrastructure
Start date:
2016-09-09
Due date:
% Done:

100%

Estimated time:
(Total: 0.00 h)
Difficulty:

Description

observation

see logfile from https://openqa.suse.de/tests/445879/file/autoinst-log.txt
the warning

Subroutine main::diag redefined at /var/lib/openqa/share/tests/sle/products/sle/main.pm line 3.
    main::BEGIN() called at /var/lib/openqa/share/tests/sle/products/sle/main.pm line 3
    eval {...} called at /var/lib/openqa/share/tests/sle/products/sle/main.pm line 3
    require /var/lib/openqa/share/tests/sle/products/sle/main.pm called at /usr/bin/isotovideo line 121

should not appear unless an old version of os-autoinst is installed

problem

It might have an effect why https://openqa.suse.de/tests/445879 failed.

suggestion

  • someone with access to malbec should check if the package is on the same version as other workers
  • maybe update salt config or something.

Subtasks

action #13648: aarch64 lvm+RAID1 fails in https://openqa.suse.de/tests/551284#step/partitioning_raid/110Resolved


Related issues

Related to openQA Tests - action #15396: malbec unusable (see parent ticket)Resolved2016-12-08

Related to openQA Tests - action #15492: Upgrade ppc64le workers to QEMU 2.6.*, i.e. current Leap or "Invalid parameter 'logfile'"Resolved2016-12-14

Related to openQA Project - action #16320: Random timeouts while waiting for serial output when using the virtio backendResolved2017-01-30

History

#1 Updated by mgriessmeier almost 6 years ago

  • Subject changed from os-autoinst on malbec looks like old version to os-autoinst on malbec and overdrive2 looks like old version

https://openqa.suse.de/tests/446613 seems to not update needles and os-autoinst

#2 Updated by RBrownSUSE almost 6 years ago

  • Status changed from New to Feedback
  • % Done changed from 0 to 100

Deployed malbec and overdrive2 and rescheduled the mentioned jobs and any other job I think could have been impacted.

#3 Updated by okurz almost 6 years ago

  • Status changed from Feedback to In Progress
  • Priority changed from High to Low

works good, see https://openqa.suse.de/tests/446605.

Like to track this cause we don't have the same tools to orchestrate overdrive2 and malbec so I guess this problem will persist. Let's see if someone will provide salt for SLE12 GA ;-) or we have some "deployment checklist" where these exceptions are listed.

#4 Updated by okurz over 5 years ago

still happening (or again): overdrive still have an old version of os-autoinst causing problems: mgriessmeier assumes "Can't use string ("0") as a HASH ref while "strict refs" in use at /usr/lib/os-autoinst/testapi.pm line 943." is caused by this

#5 Updated by mgriessmeier over 5 years ago

  • Priority changed from Low to High

there are still some jobs failing because of this issue, and since they got retriggered automatically, aarch64 testing takes a lot of time

#6 Updated by coolo over 5 years ago

  • Status changed from In Progress to Resolved

I love how high prio issues are ignored for months

#7 Updated by okurz over 5 years ago

  • Status changed from Resolved to In Progress

seriously, how does it help to just set a ticket to resolved?
AFAICS neither malbec nor overdrive are part of salt recipes nor are any specific instructions mentioned on https://wiki.microfocus.net/index.php/OpenQA how to handle these so not resolved.

#8 Updated by okurz over 5 years ago

  • Project changed from openQA Project to openQA Tests
  • Category set to Infrastructure

#9 Updated by coolo over 5 years ago

you mean because leaving it open for 3 months in high priority worked so well?

#10 Updated by okurz over 5 years ago

that is not a real and honest question buuut I will answer it anyway: We will try to improve in the future and I am working on it. First step was to create a new category "Infrastructure" in "openQA tests" repo because it has nothing to do with openQA feature development but is "SUSE specific". I will regularly review progress tickets and see about their state and try to plan accordingly. Also SUSE QA is investing more in working on this backlog based on the real priority and I am also working on this one.

#11 Updated by okurz over 5 years ago

  • Subject changed from os-autoinst on malbec and overdrive2 looks like old version to version of os-autoinst on malbec+overdrive2 should be same as other workers (using salt) (was: looks like old version)

#12 Updated by okurz over 5 years ago

  • Related to action #15396: malbec unusable (see parent ticket) added

#14 Updated by okurz over 5 years ago

ping working on overdrive?

#15 Updated by okurz over 5 years ago

  • Target version set to Milestone 6

#16 Updated by okurz over 5 years ago

  • Related to action #15492: Upgrade ppc64le workers to QEMU 2.6.*, i.e. current Leap or "Invalid parameter 'logfile'" added

#17 Updated by szarate over 5 years ago

  • Related to action #16320: Random timeouts while waiting for serial output when using the virtio backend added

#18 Updated by RBrownSUSE over 5 years ago

In progress but waiting for an xgene as a proper ARM production worker - overdrive2 will then be repurposed (probably for QAM only)

#19 Updated by RBrownSUSE about 5 years ago

  • Subject changed from version of os-autoinst on malbec+overdrive2 should be same as other workers (using salt) (was: looks like old version) to [tools]version of os-autoinst on malbec+overdrive2 should be same as other workers (using salt) (was: looks like old version)

#20 Updated by RBrownSUSE about 5 years ago

Malbec done

Overdrive2 blocked, waiting for a fix for santi

#21 Updated by coolo about 5 years ago

but it's salted now - and is deployed with latest versions

#22 Updated by RBrownSUSE about 5 years ago

  • Status changed from In Progress to Resolved

Also available in: Atom PDF