Project

General

Profile

action #101879

[qe-sap] test fails in Sysctl

Added by mgrifalconi 3 months ago. Updated 10 days ago.

Status:
Resolved
Priority:
High
Assignee:
Category:
Bugs in existing tests
Target version:
-
Start date:
2021-11-03
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

Observation

openQA test in scenario sle-15-SAP-DVD-Updates-x86_64-mau-sles-sys-param-check@64bit-2gbram fails in
Sysctl

Test suite description

The base test suite is used for job templates defined in YAML documents. It has no settings of its own.

Reproducible

Fails since (at least) Build 20211103-1

Expected result

Last good: 20211102-1 (or more recent)

Further details

Always latest result in this scenario: latest

History

#1 Updated by dzedro 3 months ago

test/robot should be updated as the value of net.ipv4.ping_group_range is changing to 0 https://build.suse.de/request/show/257506

#2 Updated by dzedro 3 months ago

btw, don't know who is maintaining robot package, but maybe it should/could be part of update when kernel parameters are changed

#3 Updated by vsvecova 3 months ago

I'm just testing aaa_base where this bug https://bugzilla.suse.com/show_bug.cgi?id=1174504 explains this failure.

If I understood this correctly, this change is needed to adjust the behaviour of ping.

Here is the related commit to aaa_base: https://github.com/openSUSE/aaa_base/pull/77/files

#4 Updated by vpelcak 3 months ago

  • Assignee set to jctmichel

James. This looks like something coming from your team. Could you please help with this?

#5 Updated by rbranco 3 months ago

  • Assignee changed from jctmichel to rbranco

#6 Updated by jctmichel 3 months ago

We need to block the update until we establish what parameters have been changed. These parameters would directly affect SAP customer workloads.

Which RobotFW test is failing and what is its value and what value is expected?
A bug should be filed and the update rejected or in this case retracted.

Cheers
James

Get Outlook for Androidhttps://aka.ms/AAb9ysg


From: redmine@opensuse.org redmine@opensuse.org
Sent: Friday, November 12, 2021 6:15:42 PM
Subject: [openQA Tests - action #101879] [qe-sap] test fails in Sysctl

[openSUSE Tracker]
Issue #101879 has been updated by vpelcak.

Assignee set to jctmichel

James. This looks like something coming from your team. Could you please help with this?


action #101879: [qe-sap] test fails in Sysctl
https://progress.opensuse.org/issues/101879#change-463976

  • Author: mgrifalconi
  • Status: New
  • Priority: High
  • Assignee: jctmichel
  • Category: Bugs in existing tests
  • Target version:

* Difficulty:

Observation

openQA test in scenario sle-15-SAP-DVD-Updates-x86_64-mau-sles-sys-param-check@64bit-2gbram fails in
Sysctl

Test suite description

The base test suite is used for job templates defined in YAML documents. It has no settings of its own.

Reproducible

Fails since (at least) Build 20211103-1

Expected result

Last good: 20211102-1 (or more recent)

Further details

Always latest result in this scenario: latest

--
You have received this notification because you have either subscribed to it, or are involved in it.
To change your notification preferences, please click here: http://progress.opensuse.org/my/account

#7 Updated by jctmichel 2 months ago

https://openqa.suse.de/tests/overview?distri=sle&version=15&build=%3A21647%3Aaaa_base&groupid=159

Looks as if the update aaa_base (21647) has caused this change. If this is indeed the case, then please reject the update stating that ipv4 ping return value has changed and should be reverted.

#8 Updated by jctmichel 2 months ago

It appear that the same test is failing for:

15-sp3
15-SP2
15-SP1
15-ga

#9 Updated by vsvecova 2 months ago

This bug explains why the change was done:
https://bugzilla.suse.com/show_bug.cgi?id=1174504

The reasoning behind the change was adjusting the behavior of ping.

#10 Updated by rbranco 2 months ago

The MR to address this, if it gets approved:

https://gitlab.suse.de/qa-css/sys-param-check/-/merge_requests/28

#11 Updated by mgrifalconi 2 months ago

Hello,

an update on today's situation:

12-SP3 failing since today Nov 25:

# Test messages # Sysctl_kernel_unprivileged_bpf_disabled
# failure: 

expected: 0
returned: 2
invalid value: '2', expected '0'

15-SP1 did always fail since Nov 03:

# Test messages # Sysctl_net_ipv4_udp_mem
# failure: 

expected: 41000:47000 54000:62000 80000:91000
returned: 45642 60858   91284
invalid value: '91284', expected '80000:91000'

15-SP2 failing since Nov 24:

# Test messages # Sysctl_kernel_unprivileged_bpf_disabled
# failure: 

expected: 0
returned: 2
invalid value: '2', expected '0'

15-SP3 failing since today Nov 25:

# Test messages # Sysctl_kernel_unprivileged_bpf_disabled
# failure: 

expected: 0
returned: 2
invalid value: '2', expected '0'

#12 Updated by jctmichel 2 months ago

Thanks Michael for bringing this to our attention.

This is excellent that the SAP sys-param-checks are doing their job and detecting important changes to the default settings and none of these changes should go under the radar.

We now need to determine which updates have caused these changes and why.

It's not clear to me which update has caused the 12-SP3 failure, but I'm sure that something was missed here in the Single Incidents.

As for the issue since 4th Nov, we must have missed this, since it was hiding behind the other issue Sysctl_net_ipv4_ping_group_range.

#13 Updated by coolo 2 months ago

The Sysctl_kernel_unprivileged_bpf_disabled is a change in the kernel (e.g. incident 21969)

#14 Updated by coolo 2 months ago

I forgot to mention: a planned change: https://jira.suse.com/browse/SLE-22575

#15 Updated by dzedro about 2 months ago

There are two new failures which are not related to previous failure net.ipv4.ping_group_range caused by aaa_base, see https://suse.slack.com/archives/C02D16TCP99/p1638355107168400

#16 Updated by okurz 10 days ago

This ticket was set to "High" priority but was not updated within the SLO period for "High" tickets (30 days) as described on https://progress.opensuse.org/projects/openqatests/wiki/Wiki#SLOs-service-level-objectives. Please consider picking up this ticket within the next 30 days or just set the ticket to the next lower priority of "Normal" (SLO: updated within 365 days).

#17 Updated by rbranco 10 days ago

  • Status changed from New to Resolved

Also available in: Atom PDF