Project

General

Profile

Actions

action #97862

closed

More openQA worker hardware for OSD size:M

Added by okurz over 2 years ago. Updated 9 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
-
Target version:
Start date:
2022-05-23
Due date:
% Done:

100%

Estimated time:
(Total: 0.00 h)

Description

Motivation

See #97043 . There is still some capacity for more workers (although we should be careful to not overload the central OSD instance)

Suggestions

  • DONE: Ask eng-infra until when and how new machines for server room 1 (SRV1) can be put in place -> a QA rack SRV2 should be preferred, see #97862#note-8
  • DONE: Crosscheck if budget plans accomodate what https://progress.opensuse.org/projects/openqav3/wiki/#openQA-infrastructure-needs-o3-osd describes -> According to nsinger we have the budget although maybe timing right might be bad but better crosscheck with mgriessmeier and then runger -> the last time okurz discussed with runger and mgriessmeier it was confirmed that replacements should be ordered especially as a plan to move to an external datacenter was delayed
  • Ask nsinger to teach others how to do that (or ask him to do it himself)
  • Order two times x86_64 machines similar to openqaworker13 but newer
  • Ask eng-infra to put the two machines into SRV1 SRV2

Subtasks 4 (0 open4 closed)

action #111473: Get replacements for imagetester and openqaworker1 size:MResolvedmkittler2022-05-23

Actions
action #111986: Ensure uno.openqanet.opensuse.org is properly usedResolvedokurz

Actions
action #113477: Get replacements for o3+osd top of rack switchRejectedokurz

Actions
action #115733: bot-ng pipeline fails because of empty dictionary in data returned by smelt size:MResolvedjbaier_cz2022-05-23

Actions

Related issues 2 (0 open2 closed)

Copied from openQA Infrastructure - action #97043: job queue hitting new record 14k jobsResolvedokurz2021-08-17

Actions
Copied to openQA Infrastructure - action #104970: Add two OSD workers (openqaworker14+openqaworker15) specifically for sap-application testing size:MResolvedmkittler2022-01-17

Actions
Actions #1

Updated by okurz over 2 years ago

  • Copied from action #97043: job queue hitting new record 14k jobs added
Actions #2

Updated by okurz over 2 years ago

  • Parent task deleted (#96447)
Actions #3

Updated by okurz over 2 years ago

  • Subject changed from More workers for OSD to More workers for OSD size:M
  • Description updated (diff)
  • Status changed from New to Workable
Actions #4

Updated by livdywan over 2 years ago

  • Subject changed from More workers for OSD size:M to More workers for OSD
  • Status changed from Workable to New
Actions #5

Updated by okurz over 2 years ago

  • Subject changed from More workers for OSD to More openQA worker hardware for OSD
Actions #7

Updated by mkittler over 2 years ago

  • Subject changed from More openQA worker hardware for OSD to More openQA worker hardware for OSD size:M
  • Description updated (diff)
  • Status changed from New to Workable
Actions #8

Updated by okurz about 2 years ago

  • Due date set to 2022-02-28
  • Status changed from Workable to Feedback
  • Assignee set to okurz

QE-SAP has organized to have two rather powerful machines intended to be openQA workers, especially for SAP related workload, situated in SUSE PRG office. Let's see when we will have these machines in the pool and what's efficient use for them before we decide to invest in more hardware in SUSE NBG office.

Regardless I created https://sd.suse.com/servicedesk/customer/portal/1/SD-70967 to clarify questions how we would get new machines into NUE SRV1

Actions #9

Updated by okurz about 2 years ago

  • Description updated (diff)
  • Due date deleted (2022-02-28)
  • Status changed from Feedback to Workable
  • Assignee deleted (okurz)

gschlotter answered:

so for adding something to serverroom 1, it is not easy at the moment,
as space wise it is nearly full
the electrician already mentioned multiple times to not add anything new in there.
the AC is nearlly at its limit.
BUT if you really need it in serv1 you need to open a CAB request, that it gets officially approved, as serverroom 1 is completely audited this year for the DC move project.
other optiones, adding it in serv2 to a QA rack. or maybe Prague serverroom, but we do not have there anything for openqa at the moment.

Updated description with the current state.

Actions #10

Updated by okurz about 2 years ago

  • Copied to action #104970: Add two OSD workers (openqaworker14+openqaworker15) specifically for sap-application testing size:M added
Actions #11

Updated by okurz about 2 years ago

  • Status changed from Workable to Blocked
  • Assignee set to okurz

First #104970 before we reconsider here

Actions #12

Updated by okurz almost 2 years ago

  • Parent task set to #109743
Actions #13

Updated by okurz over 1 year ago

  • Status changed from Blocked to New
  • Assignee deleted (okurz)
  • Target version changed from Ready to future

#104970 was resolved. Currently no further tasks within the backlog of SUSE QE Tools.

Actions #14

Updated by okurz about 1 year ago

  • Status changed from New to Blocked
  • Assignee set to okurz

Blocked by #113366

Actions #15

Updated by okurz 9 months ago

  • Status changed from Blocked to Resolved
  • Target version changed from future to Ready

With #113366 we have enough and can resolve here

Actions

Also available in: Atom PDF