Project

General

Profile

action #55115

[qe-core][functional] test fails in sssd - Test fails switching to serial terminal

Added by szarate about 2 years ago. Updated 5 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Bugs in existing tests
Target version:
SUSE QA - Milestone 31
Start date:
2019-08-05
Due date:
% Done:

0%

Estimated time:
42.00 h
Difficulty:

Description

Observation

Apparently after the dracut test is done, the sssd test cannot be executed.

To support the hypotheses I've triggered an extra test: https://openqa.suse.de/tests/3209687

The log fails like this, theory could be that the wait_boot and/or power_action needs to reconnect to the SUT.

# wait_serial expected: qr/(?^ui:login:\s*$)/

# Result:
Script started, file is /tmp/serial_terminal.txt.GeGU1_eLDCKOBBPU
Connected to domain openQA-SUT-1
Escape character is ^]
error: operation failed: Active console session exists for this domain

CONSOLE_EXIT_GeGU1_eLDCKOBBPU: 1
Script done, file is /tmp/serial_terminal.txt.GeGU1_eLDCKOBBPU

openQA test in scenario sle-12-SP5-Server-DVD-s390x-extra_tests_in_textmode@s390x-kvm-sle12 fails in
sssd

Suggestions

  • Check lib/power_action_utils.pm and see if by using keep_console helps with the situation for s390
  • Consult with PO :)
  • Move dracut to a separate test suite.
  • Improve the power_action function to take into account the bakend and keep consoles.
    • Hint from kdump_and_crash: power_action('reboot', keepconsole => is_spvm);

Reproducible

Fails since (at least) Build 0170

Further details

Always latest result in this scenario: latest


Related issues

Related to openQA Tests - action #47123: [functional][u][tw] extra_tests_in_textmode fails in zbarResolved2019-02-04

Related to openQA Tests - action #57215: [functional][u] test fails in sssd - Failed to start SSSDResolved2019-09-23

Related to openQA Tests - action #57281: [sle][Migration][SLE15SP2] test fails in orphaned_packages_check - switch to tty failedResolved2019-09-24

Related to openQA Tests - action #89479: [qe-core] test fails in sssd - Fix sssd testing with openldap, remove use of python-pamResolved

Has duplicate openQA Tests - action #54956: [sle][functional][u] test fails in dracut - reboot failedRejected2019-08-01

History

#1 Updated by szarate about 2 years ago

  • Description updated (diff)
  • Status changed from New to Workable

#2 Updated by szarate about 2 years ago

  • Has duplicate action #54956: [sle][functional][u] test fails in dracut - reboot failed added

#3 Updated by zluo about 2 years ago

  • Status changed from Workable to In Progress
  • Assignee set to zluo

take over

#4 Updated by zluo about 2 years ago

after reboot I add reconnect_mgmt_console, but it is still not working yet: http://f40.suse.de/tests/4887

use base 'opensusebasetest';
use testapi;
use utils;
use strict;
use warnings;
use power_action_utils 'power_action';
use Utils::Backends 'is_remote_backend';
sub run {
my ($self) = @_;
$self->select_serial_terminal;
assert_script_run("rpm -q dracut");
validate_script_output("lsinitrd", sub { m/Image:(.*\n)+( ?)Version: dracut(-|\d+|\.|\+|\w+)+(\n( ?))+( ?)Arguments(.*\n)+( ?)dracut modules:(\w+|-|\d+|\n|( ?))+\=+\n(l|d|r|w|x|-|( ?))+\s+\d+ root\s+root(.*\n)+( ?)\=+/ });
validate_script_output("dracut -f 2>&1", sub { m/.*Executing: \/usr\/bin\/dracut -f\n|\b(?:Skipping|Including modules done|Including|Creating image|Creating initramfs)\b/ }, 180);
validate_script_output("dracut --list-modules 2>&1", sub { m/.*Executing: \/usr\/bin\/dracut --list-modules\n(\w+|\n|-|d+)+/ });
power_action('reboot', textmode => 1);
reconnect_mgmt_console(timeout => 400) if is_remote_backend;
$self->wait_boot;
}
1;

#6 Updated by pcervinka about 2 years ago

Already faced this situation in https://progress.opensuse.org/issues/54578. It has no easy solution, reconnect_mgmt_console will not help, using virsh console with force will not help too.

Another note related to dracut tests. Reboot in dracut was causing issues in the past and for this case was created extra_tests_dracut to keep it separate from other tests. See https://progress.opensuse.org/issues/47123. I suggest to run extra_tests_dracut in functional group as solo test.

#7 Updated by pcervinka about 2 years ago

  • Related to action #47123: [functional][u][tw] extra_tests_in_textmode fails in zbar added

#10 Updated by zluo about 2 years ago

since we have problem with reconnect_mgmt_console (see #46394), I think atm we cannot fix the issue directly on remote_backend.

option could be to move dracut out from extra_test, untill the issue #46394 got resolved.

See example:

http://f40.suse.de/tests/4888

#11 Updated by zluo about 2 years ago

PR created: https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/8138

I will create a job dracut test extra for remote backend later.

#12 Updated by zluo about 2 years ago

remove dracut test from extra test and dracut test now got scheduled seperatly on osd.

#13 Updated by zluo about 2 years ago

  • Status changed from In Progress to Resolved

verified on osd that dracut is not in extra test anymore, and dracut got scheduled separately:

http://openqa.suse.de/tests/3225363

#14 Updated by szarate about 2 years ago

  • Description updated (diff)
  • Status changed from Resolved to Workable

Let's set it back to workable, and groom further later.

#15 Updated by zluo about 2 years ago

  • Assignee deleted (zluo)

#16 Updated by zluo about 2 years ago

  • Priority changed from High to Normal

set as normal for now.

#17 Updated by mgriessmeier about 2 years ago

  • Status changed from Workable to New
  • Priority changed from Normal to High
  • Target version changed from Milestone 26 to Milestone 27

discuss again in grooming

#18 Updated by SLindoMansilla about 2 years ago

kdump_and_crash is also rebooting but it is not failing because it is using:

power_action('reboot', keepconsole => is_spvm);

We should use keepconsole parameter of function power_action in dracut test module.

#19 Updated by SLindoMansilla about 2 years ago

  • Description updated (diff)
  • Status changed from New to Workable
  • Priority changed from High to Normal

#20 Updated by SLindoMansilla about 2 years ago

  • Estimated time set to 42.00 h

#21 Updated by mgriessmeier about 2 years ago

  • Target version changed from Milestone 27 to Milestone 28

#22 Updated by SLindoMansilla about 2 years ago

  • Related to action #57215: [functional][u] test fails in sssd - Failed to start SSSD added

#23 Updated by mgriessmeier almost 2 years ago

  • Target version changed from Milestone 28 to Milestone 31

#24 Updated by okurz almost 2 years ago

  • Related to action #57281: [sle][Migration][SLE15SP2] test fails in orphaned_packages_check - switch to tty failed added

#25 Updated by zluo over 1 year ago

I think we stil have the issue: https://bugzilla.suse.com/show_bug.cgi?id=1151373

so this is blocked atm.

#26 Updated by zluo over 1 year ago

#27 Updated by zluo over 1 year ago

  • Status changed from Workable to Blocked

https://openqa.suse.de/tests/overview?arch=&machine=&modules=sssd&distri=sle&version=15-SP2&build=168.1&groupid=110#

aarch64, ppc64le, x86_64 are failed atm because the product issue above, s390x is not scheduled at all.

#29 Updated by tjyrinki_suse 12 months ago

  • Subject changed from [functional][u] test fails in sssd - Test fails switching to serial terminal to [qe-core][functional] test fails in sssd - Test fails switching to serial terminal

#30 Updated by tjyrinki_suse 8 months ago

  • Related to action #89479: [qe-core] test fails in sssd - Fix sssd testing with openldap, remove use of python-pam added

#31 Updated by tjyrinki_suse 5 months ago

  • Status changed from Blocked to Resolved

The sssd test was now rewritten in sssd_{openldap,389ds}_functional modules.

Also available in: Atom PDF