action #54056

[functional][u] test fails in virtman_view

Added by dimstar 9 months ago. Updated 4 months ago.

Status:ResolvedStart date:10/07/2019
Priority:HighDue date:
Assignee:zluo% Done:

0%

Category:Bugs in existing tests
Target version:-
Difficulty:
Duration:

Description

Observation

Seems the keypresses need be re-evaluated, as we end up in the 'New Virtual Machine' dialog rather than the 'view' settings menu.

Long story short, keyboard shortcuts might need to be updated for virt-manager.

openQA test in scenario opensuse-Tumbleweed-DVD-x86_64-virtualization@64bit fails in
virtman_view

Test suite description

Maintainer: okurz. Test virtualization stack using libvirt and virt-manager.

Reproducible

Fails since (at least) Build 20190705

Expected result

Last good: 20190704 (or more recent)

Further details

Always latest result in this scenario: latest


Related issues

Related to openQA Project - action #55703: send_keys() doesn't guarantee that the application will h... Resolved 15/04/2019

History

#1 Updated by SLindoMansilla 9 months ago

  • Subject changed from test fails in virtman_view to [virtualization] test fails in virtman_view

#2 Updated by okurz 9 months ago

  • Subject changed from [virtualization] test fails in virtman_view to [functional][u] test fails in virtman_view
  • Priority changed from Normal to High

Unfortunately AFAIK QSF-u is still responsible for "virtualization" on openSUSE. Might be worth to pick this discussion up once again with their PO and QA SLE PrjM

#3 Updated by okurz 8 months ago

This is an autogenerated message for openQA integration by the openqa_review script:

This bug is still referenced in a failing openQA test: virtualization
https://openqa.opensuse.org/tests/993448

#4 Updated by szarate 8 months ago

  • Description updated (diff)
  • Status changed from New to Workable

#5 Updated by zluo 8 months ago

  • Status changed from Workable to In Progress
  • Assignee set to zluo

take over and checking...

#6 Updated by zluo 8 months ago

found that it fails at:

# go to view now
wait_screen_change { send_key 'alt-v' };
wait_screen_change { send_key 'right' };
# activate everything

it closes the context menu very fast after send_key 'alt-v'.

#7 Updated by zluo 8 months ago

http://f40.suse.de/tests/4747#step/virtman_view/8 shows correct test results now.

wait_screen_change after assert_screen is a problem in the test.

#8 Updated by zluo 8 months ago

  • Status changed from In Progress to Feedback

#9 Updated by zluo 8 months ago

PR updated:

the PR #7636 breaks virtman_view.pm on x86_64 because
wait_screen_change after assert_screen causes a new problem.
Also fix the issue with go to preferences which is sometimes not
working.

see https://progress.opensuse.org/issues/54056

test verification runs:
http://f40.suse.de/tests/4912#step/virtman_view/8 (64bit)
http://f40.suse.de/tests/4910#step/virtman_view/8 (aarch64)

#10 Updated by okurz 7 months ago

This is an autogenerated message for openQA integration by the openqa_review script:

This bug is still referenced in a failing openQA test: virtualization
https://openqa.opensuse.org/tests/1015221

#11 Updated by ggardet_arm 7 months ago

aarch64 is also affected now.

#12 Updated by zluo 7 months ago

  • Status changed from Feedback to Blocked

now we have a ticket for this general issue with typing: https://progress.opensuse.org/issues/55703

set as blocked for now.

#13 Updated by zluo 7 months ago

  • Blocked by action #55703: send_keys() doesn't guarantee that the application will handle modifiers+normal_key properly added

#14 Updated by okurz 7 months ago

This is an autogenerated message for openQA integration by the openqa_review script:

This bug is still referenced in a failing openQA test: virtualization
https://openqa.opensuse.org/tests/1028234

#15 Updated by okurz 6 months ago

This is an autogenerated message for openQA integration by the openqa_review script:

This bug is still referenced in a failing openQA test: virtualization
https://openqa.opensuse.org/tests/1042041

#16 Updated by okurz 6 months ago

This is an autogenerated message for openQA integration by the openqa_review script:

This bug is still referenced in a failing openQA test: virtualization
https://openqa.opensuse.org/tests/1055445

To prevent further reminder comments one of the following options should be followed:
1. The test scenario is fixed by applying the bug fix to the tested product or the test is adjusted
2. The openQA job group is moved to "Released"
3. The label in the openQA scenario is removed

#17 Updated by okurz 5 months ago

This is an autogenerated message for openQA integration by the openqa_review script:

This bug is still referenced in a failing openQA test: virtualization
https://openqa.opensuse.org/tests/1066022

To prevent further reminder comments one of the following options should be followed:
1. The test scenario is fixed by applying the bug fix to the tested product or the test is adjusted
2. The openQA job group is moved to "Released"
3. The label in the openQA scenario is removed

#18 Updated by ggardet_arm 5 months ago

This problem is that send_key('alt-v') shows very briefly the View menu and disappear shortly after. If you send and hold alt key, send v, and release alt after a short wait, it passes properly.
PR available to implement this workaround: https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/8862

#19 Updated by coolo 5 months ago

  • Blocked by deleted (action #55703: send_keys() doesn't guarantee that the application will handle modifiers+normal_key properly)

#20 Updated by zluo 5 months ago

  • Status changed from Blocked to Feedback

Let's wait for https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/8862 for now and check this later.

#21 Updated by SLindoMansilla 5 months ago

  • Related to action #55703: send_keys() doesn't guarantee that the application will handle modifiers+normal_key properly added

#22 Updated by dimstar 5 months ago

IIRC, the explicit fix to change the alt-v key press into alt and v (instead of alt-v) was reverted, breaking the test again.

#23 Updated by SLindoMansilla 5 months ago

  • Status changed from Feedback to Workable

zluo, please try a proper value for VNC_TYPING_LIMIT
Reference to #55703 and https://github.com/os-autoinst/os-autoinst/pull/1260/files

#24 Updated by zluo 5 months ago

  • Status changed from Workable to In Progress

let me check current status at first:

https://openqa.opensuse.org/tests/1088175

failed for tumblweed as well because of CPU soft lockup issue:

CPU soft lockup detected - Serial error: [ 1010.288531] watchdog: BUG: soft lockup - CPU#0 stuck for 42s! [CPU 3/KVM:5745]
Failed

#25 Updated by zluo 5 months ago

still failed. Trying now with VNC_TYPING_LIMIT_DEFAULT=10:

http://f40.suse.de/tests/5297

this is no effect, maybe I need to set VNC_TYPING_LIMI=10 here: http://f40.suse.de/tests/5299

#26 Updated by zluo 5 months ago

the tests with VPN_TYPING_LIMIT are all failed and I think this is not related typing issue. Investigating...

#27 Updated by zluo 5 months ago

found out that send_key alt+v for open viewmenu-graph not realiable, I even have problem with this key press on my tw...

see example:
http://f40.suse.de/tests/5306#step/virtman_view/13

graph shows up already but the context menu is still there.

#28 Updated by dimstar 5 months ago

With https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/8862 the test seemed to pass fine - until this was reverted again

#29 Updated by dimstar 5 months ago

dimstar wrote:

With https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/8862 the test seemed to pass fine - until this was reverted again

i.e. https://openqa.opensuse.org/tests/1083047 - this was the only test running with this PR merged

#30 Updated by zluo 5 months ago

with some changes for replacing send_keys I got now:

http://f40.suse.de/tests/5317#step/virtman_view/13 shows now better result except closing application.

Need to handle close and quit later.

#31 Updated by zluo 5 months ago

https://github.com/os-autoinst/os-autoinst-needles-opensuse/pull/612 created for new needles.

waiting for test results on my openqa server 50 times:

http://f40.suse.de/tests/5320#next_previous

#32 Updated by zluo 5 months ago

start verification test run on o3 for my PR:

https://openqa.opensuse.org/tests/1089670

#33 Updated by zluo 5 months ago

https://openqa.opensuse.org/tests/1090395#next_previous should provide more statics for test run.
This is not working now because the installation medium got removed from o3. testing now against latest build on f40.suse.de:

http://f40.suse.de/tests/5371

#34 Updated by zluo 5 months ago

  • Status changed from In Progress to Feedback

asked for PR review.

#35 Updated by SLindoMansilla 5 months ago

Where is the PR?

#37 Updated by zluo 5 months ago

  • Status changed from Feedback to In Progress

since we need to support sles as well, I will create new needles then and run tests.

#38 Updated by zluo 4 months ago

  • Status changed from In Progress to Feedback

PR merged now, set is as feedback.

#39 Updated by zluo 4 months ago

  • Status changed from Feedback to Rejected

#40 Updated by zluo 4 months ago

  • Status changed from Rejected to New

#41 Updated by zluo 4 months ago

  • Status changed from New to Resolved

#42 Updated by okurz 4 months ago

This is an autogenerated message for openQA integration by the openqa_review script:

This bug is still referenced in a failing openQA test: virtualization
https://openqa.opensuse.org/tests/1119763

To prevent further reminder comments one of the following options should be followed:
1. The test scenario is fixed by applying the bug fix to the tested product or the test is adjusted
2. The openQA job group is moved to "Released"
3. The label in the openQA scenario is removed

Also available in: Atom PDF