Project

General

Profile

action #42446

[qe-core][functional] many opensuse tests fail in desktop_runner or gimp or other modules in what I think is boo#1105691 – can we detect this bug from the journal and track as soft-fail?

Added by okurz over 2 years ago. Updated 3 months ago.

Status:
New
Priority:
Normal
Assignee:
-
Category:
Enhancement to existing tests
Target version:
Start date:
2018-10-13
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

Observation

openQA test in scenario opensuse-Tumbleweed-NET-x86_64-zdup-Leap-42.1-kde@64bit fails in
desktop_runner
and many comparable do fail in gimp or other modules in what I think is boo#1105691 – can we detect this bug from the journal and track as soft-fail?

Reproducible

Fails since (at least) Build 20181012 (current job)

Expected result

Last good: 20181011 (or more recent)

Suggestions

  • Think about a solution which is applicable regardless of the specific test module, e.g. no fix in "tests/x11/gimp"
  • grep for the error message in the system journal in the post_fail_hook and record_soft_failure based on regex match as we already do for other errors, look for "set_expected_serial_failures" in os-autoinst-distri-opensuse

Further details

Always latest result in this scenario: latest


Related issues

Related to openQA Tests - action #39059: [sle][functional][y] detect "openSUSE sucks bug" about btrfs balance and record_soft_fail (was: yast2_gui tests modules as application could not start up)Resolved2018-08-012018-10-09

Related to openQA Project - coordination #39719: [saga][epic] Detection of "known failures" for stable tests, easy test results review and easy tracking of known issuesBlocked2017-01-232021-06-29

History

#1 Updated by okurz over 2 years ago

  • Related to action #39059: [sle][functional][y] detect "openSUSE sucks bug" about btrfs balance and record_soft_fail (was: yast2_gui tests modules as application could not start up) added

#2 Updated by okurz over 2 years ago

  • Related to coordination #39719: [saga][epic] Detection of "known failures" for stable tests, easy test results review and easy tracking of known issues added

#3 Updated by mgriessmeier over 2 years ago

  • Status changed from New to In Progress
  • Assignee set to mgriessmeier

taking a look

#4 Updated by okurz over 2 years ago

discussed with mgriessmeier, asked in bug about ETA of a potential fix which would remove the urgency of this ticket. However, the bug being present right now is a good opportunity to think for us how we can detect it

#5 Updated by mgriessmeier over 2 years ago

  • Status changed from In Progress to Workable
  • Priority changed from Urgent to High

This should remove urgency, will track until it hits the product:
https://bugzilla.suse.com/show_bug.cgi?id=1105691#c7

#6 Updated by okurz over 2 years ago

  • Priority changed from High to Normal
  • Target version set to Milestone 20

There is a SR to openSUSE Factory already: https://build.opensuse.org/request/show/642265

However, this ticket can now with less urgency focus on detecting a corresponding failure and mark as "known failure". Feel free to unassign for the time being.

#7 Updated by mgriessmeier over 2 years ago

  • Assignee deleted (mgriessmeier)

#8 Updated by okurz over 2 years ago

  • Subject changed from [functional][y][u] many opensuse tests fail in desktop_runner or gimp or other modules in what I think is boo#1105691 – can we detect this bug from the journal and track as soft-fail? to [functional][u] many opensuse tests fail in desktop_runner or gimp or other modules in what I think is boo#1105691 – can we detect this bug from the journal and track as soft-fail?
  • Description updated (diff)

#9 Updated by szarate over 2 years ago

  • Status changed from Workable to Feedback
  • Assignee set to okurz

#10 Updated by okurz over 2 years ago

  • Status changed from Feedback to Blocked
  • Target version changed from Milestone 20 to Milestone 21

blocked by -> #39719

#11 Updated by okurz over 2 years ago

  • Target version changed from Milestone 21 to future

due to blocker

#12 Updated by okurz about 2 years ago

  • Assignee changed from okurz to mgriessmeier

Move to new QSF-u PO after I moved to the "tools"-team. I mainly checked the subject line so in individual instances you might not agree to take it over completely into QSF-u. Feel free to discuss with me or reassign to me or someone else in this case. Thanks.

#13 Updated by mgriessmeier over 1 year ago

  • Assignee changed from mgriessmeier to okurz

is this still a thing? okurz?

#14 Updated by okurz over 1 year ago

  • Category changed from Bugs in existing tests to Enhancement to existing tests
  • Assignee changed from okurz to mgriessmeier

https://bugzilla.suse.com/show_bug.cgi?id=1105691 is RESOLVED FIXED but the idea is still a worthwhile enhancement. IMHO you can treat it not as blocked by #39719 as well which we basically did to serialize tasks within the team but as the epic isn't in the backlog of [u] anymore you can set this back to "New" or "Workable". Of course you can also reject it and leave the time in the "fix bug"-Hamsterwheel and never improve tests ;P

#15 Updated by SLindoMansilla about 1 year ago

  • Assignee changed from mgriessmeier to SLindoMansilla

#16 Updated by tjyrinki_suse 7 months ago

  • Subject changed from [functional][u] many opensuse tests fail in desktop_runner or gimp or other modules in what I think is boo#1105691 – can we detect this bug from the journal and track as soft-fail? to [qe-core][functional] many opensuse tests fail in desktop_runner or gimp or other modules in what I think is boo#1105691 – can we detect this bug from the journal and track as soft-fail?

#17 Updated by okurz 6 months ago

This is an autogenerated message for openQA integration by the openqa_review script:

This bug is still referenced in a failing openQA test: gnome+proxy_SCC+allmodules
https://openqa.suse.de/tests/5162922

To prevent further reminder comments one of the following options should be followed:

  1. The test scenario is fixed by applying the bug fix to the tested product or the test is adjusted
  2. The openQA job group is moved to "Released"
  3. The label in the openQA scenario is removed

#18 Updated by SLindoMansilla 3 months ago

  • Status changed from Blocked to New
  • Assignee deleted (SLindoMansilla)

No time to work on this :(

Also available in: Atom PDF