Project

General

Profile

action #18938

[tools]Enable 3 stress acceptance on aarch64

Added by yosun over 4 years ago. Updated about 4 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
New test
Target version:
-
Start date:
2017-05-04
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

Like for s390x but for aarch64 #18936


Related issues

Related to openQA Tests - action #18936: [tools][sles][functional] Enable 3 stress acceptance on s390xResolved2017-05-042017-11-08

Has duplicate openQA Tests - action #20408: [sles][functional] test fails in acceptance_fs_stress - Missing setting QA_HEAD_REPORejected2017-07-12

History

#1 Updated by okurz over 4 years ago

  • Related to action #18936: [tools][sles][functional] Enable 3 stress acceptance on s390x added

#2 Updated by okurz over 4 years ago

  • Description updated (diff)
  • Category set to New test

#3 Updated by RBrownSUSE over 4 years ago

  • Assignee set to RBrownSUSE
  • Target version set to Milestone 8

At the request of Sero, taken as a QA Tools milestone 8 task for me to keep an eye on. Dependant on #19254

#5 Updated by RBrownSUSE over 4 years ago

  • Subject changed from Enable 3 stress acceptance on aarch64 to [tools]Enable 3 stress acceptance on aarch64

#6 Updated by RBrownSUSE about 4 years ago

  • Status changed from New to In Progress

#7 Updated by RBrownSUSE about 4 years ago

  • Status changed from In Progress to Feedback

#8 Updated by okurz about 4 years ago

  • Has duplicate action #20408: [sles][functional] test fails in acceptance_fs_stress - Missing setting QA_HEAD_REPO added

#9 Updated by okurz about 4 years ago

https://openqa.suse.de/tests/1057998/modules/acceptance_fs_stress/steps/31 currently not working, Missing setting QA_HEAD_REPO

#10 Updated by yosun about 4 years ago

I add QA_HEAD_REPO in all those three stress test. And enable them in aarch64, the next run should be OK.

#11 Updated by okurz about 4 years ago

What do you mean "the next run should be ok"? I don't think there will be a next run (considering GMC and such) so I recommend you trigger one explicitly and provide the job URL here.

#12 Updated by RBrownSUSE about 4 years ago

  • Status changed from Feedback to Resolved

#13 Updated by okurz about 4 years ago

  • Status changed from Resolved to Feedback

Do you have any verification runs available? Looking at https://openqa.suse.de/tests?match=sles12_qa_acceptance_fs_stress I could not find any jobs on aarch64 that are successful.

#14 Updated by yosun about 4 years ago

I created the job in Build0472, but all ARM workers are off line.

#15 Updated by mitiao about 4 years ago

yosun wrote:

I created the job in Build0472, but all ARM workers are off line.

aarch64 is online, your jobs are in CHAINED dependency, so you have to trigger the test defined in START_AFTER_TEST, then all dependent jobs can be triggered and started after the parent job done successfully.
and if you want to trigger job without creating image again or with setting changes, please use clone_job to do that.

#16 Updated by yosun about 4 years ago

Still not work, I added create_hdd_minimal_base+sdk(coolo has changed job name to it) in job too, and they keep scheduling together.
I checked, there is some aarch64 worker online. I don't know what are they waiting for now.

#17 Updated by okurz about 4 years ago

I guess when the worker is reporting as "online" it still not really is fully online. Something broke the machines. E.g. seattle6 aarch64 workers state "Mojo::Reactor::Poll: I/O watcher failed: Can't use string ("org.freedesktop.DBus.Error.NoRep"...) as a HASH ref while …" in the journal of the worker instances. See #20544#note-4

#18 Updated by okurz about 4 years ago

  • Status changed from Feedback to In Progress
  • Assignee changed from RBrownSUSE to okurz
  • Target version deleted (Milestone 8)

https://openqa.suse.de/tests/latest?flavor=Server-DVD&arch=aarch64&version=12-SP3&machine=aarch64&distri=sle&test=create_hdd_minimal_base%2Bsdk shows the always latest image generation job. https://openqa.suse.de/tests/1067425 is the last one failing as incomplete on xgene2. Don't know what the problem is.
Triggered new one: https://openqa.suse.de/tests/1076847#live

We failed to deliver during M8, deleting milestone assignment

#19 Updated by cachen about 4 years ago

okurz wrote:

https://openqa.suse.de/tests/latest?flavor=Server-DVD&arch=aarch64&version=12-SP3&machine=aarch64&distri=sle&test=create_hdd_minimal_base%2Bsdk shows the always latest image generation job. https://openqa.suse.de/tests/1067425 is the last one failing as incomplete on xgene2. Don't know what the problem is.
Triggered new one: https://openqa.suse.de/tests/1076847#live

We failed to deliver during M8, deleting milestone assignment

Thanks a lot, appreciated so much for the supporting!

#22 Updated by okurz about 4 years ago

yosun, I don't know what you try to achieve here. Did you see #18938#note-20 ? https://openqa.suse.de/tests/1077066#live failed for the same reason as above, the image upload failed. The jobs you scheduled were all cancelled because the parent job failed, in your case https://openqa.suse.de/tests/1077199 but also for the same reason: The image upload failed -> #16430

#23 Updated by yosun about 4 years ago

OK, then will try after it fixed. Misunderstood, I was thinking the retry in #20 is intend to pass, if not, why retry it ;)

#24 Updated by okurz about 4 years ago

  • Description updated (diff)

:-D of course the intent of the job in #18938#note-20 was to pass but it did not yet.

Apparently as found out in #16430#note-29 we (probably I?) messed up in the original creation job because it specifies HDD_1==PUBLISH_HDD_1, created #20786 and #20788 accordingly.

Trying again with

$ openqa_clone_job_osd 1077199 HDD_1=

-> https://openqa.suse.de/t1077283

It passed. Because the dependency chain was lost I triggered the tests manually now:

$ openqa_clone_job_osd --skip-chained-deps --skip-deps 1077200
$ openqa_clone_job_osd --skip-chained-deps --skip-deps 1077201
$ openqa_clone_job_osd --skip-chained-deps --skip-deps 1077202

Created job #1077333: sle-12-SP3-Server-DVD-aarch64-Build0472-sles12_qa_acceptance_fs_stress@aarch64 -> https://openqa.suse.de/t1077333
Created job #1077334: sle-12-SP3-Server-DVD-aarch64-Build0472-sles12_qa_acceptance_process_stress@aarch64 -> https://openqa.suse.de/t1077334
Created job #1077335: sle-12-SP3-Server-DVD-aarch64-Build0472-sles12_qa_acceptance_sched_stress@aarch64 -> https://openqa.suse.de/t1077335

#25 Updated by okurz about 4 years ago

  • Status changed from In Progress to Resolved

two passed, one was incomplete, retrigger passed: https://openqa.suse.de/tests/1077340

The testplan for SLE12SP3 includes the four scenarios already for the sle functional group so we also have a good template for later versions.

yosun I think we are done here.

#26 Updated by yosun about 4 years ago

Thanks a lot!

Also available in: Atom PDF