Project

General

Profile

action #18828

action #18444: [sles][functional]Make partitioning_raid test compatible with UEFI

[tools][sles][functional] keystrokes are sometimes ignored on aarch64 in partitioning_raid test

Added by thehejik over 4 years ago. Updated about 4 years ago.

Status:
Resolved
Priority:
Normal
Category:
Infrastructure
Target version:
-
Start date:
2017-04-27
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

Observation

openQA test in scenario sle-12-SP3-Server-DVD-aarch64-RAID0@aarch64_raid fails in
partitioning_raid

The test fails selecting the disks for raid

I found one issue on aarch64 in setraidlevel() from partitioning_raid test. But most probably it is a general problem of aarch64, the same test is passing on x86_64 without problem.

When selecting wanted RAID level some keystrokes (eg. alt-i, Tab) are ignored and then the test is failing, see https://openqa.suse.de/tests/903726#step/partitioning_raid/132

The problem occurs on all aarch64 worker but time to time seattle6 can pass the test. I newer saw any other aarch64 worker to pass the test before.

I already changed test code to using wait_screen_change {send_key ... } but it didn't help https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/2777

Could be that virtio-gpu-pci generates some noise in video output? Otherwise I have no idea.

After solving this we should remove WORKER_CLASS=aarch64_raid from o.s.d settings.

provived by thehejik

Reproducible

Fails since Build 0348 (current job)
It also happens in ppc.
It happened 7 non-consecutive times in the previous 20 jobs.

Expected result

Last good: 0347 (or more recent)

Problem

  • H1 The product has changed

    • H1.1 product changed slightly but in an acceptable way without the need for communication with DEV+RM --> adapt test
    • H1.2 product changed slightly but in an acceptable way found after feedback from RM --> adapt test
    • H1.3 product changed significantly --> after approval by RM adapt test
  • H2 Fails because of changes in test setup

    • H2.1 Our test hardware equipment behaves different
    • H2.2 The network behaves different
  • H3 Fails because of changes in test infrastructure software, e.g. os-autoinst, openQA

  • H4 Fails because of changes in test management configuration, e.g. openQA database settings

  • H5 Fails because of changes in the test software itself (the test plan in source code as well as needles)

  • H6 Sporadic issue, i.e. the root problem is already hidden in the system for a long time but does not show symptoms every time

Further details

Always latest result in this scenario: latest

Workaround

Sporadic issue -> Restart the job


Related issues

Related to openQA Tests - action #12214: partitioning_raid is hard to debug on errorsResolved2016-06-02

Related to openQA Tests - action #20108: [sles][functional] test fails in partitioning_raid - Missing needles for qam-minimalResolved2017-06-28

Has duplicate openQA Tests - action #18830: [sles][functional] test fails in partitioning_raid - the test fails selecting the disks for raid (keystrokes are sometimes ignored on aarch64 in partitioning_raid test)Rejected2017-04-27

History

#1 Updated by SLindoMansilla over 4 years ago

  • Is duplicate of action #18830: [sles][functional] test fails in partitioning_raid - the test fails selecting the disks for raid (keystrokes are sometimes ignored on aarch64 in partitioning_raid test) added

#2 Updated by okurz over 4 years ago

  • Is duplicate of deleted (action #18830: [sles][functional] test fails in partitioning_raid - the test fails selecting the disks for raid (keystrokes are sometimes ignored on aarch64 in partitioning_raid test))

#3 Updated by okurz over 4 years ago

  • Subject changed from keystrokes are sometimes ignored on aarch64 in partitioning_raid test to [tools][sles][functional]keystrokes are sometimes ignored on aarch64 in partitioning_raid test
  • Description updated (diff)
  • Category set to Infrastructure

merged in content from #18830

#4 Updated by okurz over 4 years ago

  • Has duplicate action #18830: [sles][functional] test fails in partitioning_raid - the test fails selecting the disks for raid (keystrokes are sometimes ignored on aarch64 in partitioning_raid test) added

#5 Updated by okurz over 4 years ago

thehejik I discussed with rbrown and it seems to us that this is not a backend or infrastructure related problem. For aarch64 our run history is not long enough to say that we ever had a stable RAID test on aarch64. Also, comparing individual steps from the passed and failed jobs it is not clear why certain screens appear or not. E.g. the dialog in https://openqa.suse.de/tests/910029#step/partitioning_raid/130 from the passed job looks totally different from https://openqa.suse.de/tests/900626#step/partitioning_raid/131 in the failed job.
We recommend to add more explicit check steps in between, e.g. assert_screen and such and not use implicit key sequences where we don't have a screenshot in between. The test module test flow is already getting really long but if we don't see the intermediate steps it would be very hard to properly investigate where it fails. Also, for investigation we have some yast logs available which are even able to record key presses. Therefore one could closely look at which steps have been reached and which ones not. E.g. in https://openqa.suse.de/tests/900626/file/partitioning_raid-y2logs.tar.bz2 there is YaST2/macro_inst_initial.ycp where one can see every accepted key press and the dialogs shown (also intermediate ones).

thehejik can you take this ticket?

#6 Updated by okurz over 4 years ago

This is an autogenerated message for openQA integration by the openqa_review script:

This bug is still referenced in a failing openQA test: RAID1@
https://openqa.suse.de/tests/933864

#7 Updated by okurz over 4 years ago

https://openqa.suse.de/tests/956684#step/partitioning_raid/119 is happening on x86_64 which looks like the same issue. Maybe the same problem exists regardless of the architecture but is more prone to appear on aarch64 as it might be just slower in general?

Retriggered as https://openqa.suse.de/tests/957473, let's see later

#8 Updated by thehejik over 4 years ago

okurz wrote:

https://openqa.suse.de/tests/956684#step/partitioning_raid/119 is happening on x86_64 which looks like the same issue. Maybe the same problem exists regardless of the architecture but is more prone to appear on aarch64 as it might be just slower in general?

Retriggered as https://openqa.suse.de/tests/957473, let's see later

For me it seems like different issue, but agree, it may be similar.

#9 Updated by SLindoMansilla over 4 years ago

  • Description updated (diff)

#10 Updated by SLindoMansilla over 4 years ago

  • Subject changed from [tools][sles][functional]keystrokes are sometimes ignored on aarch64 in partitioning_raid test to [tools][sles][functional] keystrokes are sometimes ignored on aarch64 in partitioning_raid test
  • Status changed from New to In Progress
  • Assignee set to SLindoMansilla

#13 Updated by SLindoMansilla over 4 years ago

Scenario covered: sle-12-SP3-Server-DVD-x86_64-Build0409-improve_keystrokes_partitioning_raid@64bit

#15 Updated by thehejik over 4 years ago

I just found https://progress.opensuse.org/issues/18620 from szarate. Any chance to try it out here?

#16 Updated by SLindoMansilla over 4 years ago

Hello thehejik,

Yes that should be a good second step.
Bu, in my opinion we still need to improve the test module anyway.

Regards.

#18 Updated by SLindoMansilla over 4 years ago

Covering aarch64 with assert_screen, only this left.

#19 Updated by SLindoMansilla over 4 years ago

  • Related to action #12214: partitioning_raid is hard to debug on errors added

#20 Updated by szarate over 4 years ago

bsc#1044936 Should also help with this, once we get that updates into qemu from sp3

#21 Updated by SLindoMansilla over 4 years ago

  • Status changed from In Progress to Feedback

Waiting for PR review.
Moved to feedback to free my "in progress" list

#22 Updated by SLindoMansilla about 4 years ago

  • Status changed from Feedback to Resolved

#23 Updated by SLindoMansilla about 4 years ago

  • Related to action #20108: [sles][functional] test fails in partitioning_raid - Missing needles for qam-minimal added

Also available in: Atom PDF