Project

General

Profile

action #18830

[sles][functional] test fails in partitioning_raid - the test fails selecting the disks for raid (keystrokes are sometimes ignored on aarch64 in partitioning_raid test)

Added by SLindoMansilla over 4 years ago. Updated over 4 years ago.

Status:
Rejected
Priority:
Normal
Assignee:
-
Category:
Bugs in existing tests
Target version:
-
Start date:
2017-04-27
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

Observation

openQA test in scenario sle-12-SP3-Server-DVD-aarch64-RAID0@aarch64_raid fails in
partitioning_raid

The test fails selecting the disks for raid

I found one issue on aarch64 in setraidlevel() from partitioning_raid test. But most probably it is a general problem of aarch64, the same test is passing on x86_64 without problem.

When selecting wanted RAID level some keystrokes (eg. alt-i, Tab) are ignored and then the test is failing, see https://openqa.suse.de/tests/903726#step/partitioning_raid/132

The problem occurs on all aarch64 worker but time to time seattle6 can pass the test. I newer saw any other aarch64 worker to pass the test before.

I already changed test code to using wait_screen_change {send_key ... } but it didn't help https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/2777

Could be that virtio-gpu-pci generates some noise in video output? Otherwise I have no idea.

After solving this we should remove WORKER_CLASS=aarch64_raid from o.s.d settings.

provived by thehejik on poo#18828

Reproducible

Fails since Build 0348 (current job)
First time that happens.

Expected result

Last good: 0347 (or more recent)

Problem

  • H1 The product has changed

    • H1.1 product changed slightly but in an acceptable way without the need for communication with DEV+RM --> adapt test
    • H1.2 product changed slightly but in an acceptable way found after feedback from RM --> adapt test
    • H1.3 product changed significantly --> after approval by RM adapt test
  • H2 Fails because of changes in test setup

    • H2.1 Our test hardware equipment behaves different
    • H2.2 The network behaves different
  • H3 Fails because of changes in test infrastructure software, e.g. os-autoinst, openQA

  • H4 Fails because of changes in test management configuration, e.g. openQA database settings

  • H5 Fails because of changes in the test software itself (the test plan in source code as well as needles)

  • H6 Sporadic issue, i.e. the root problem is already hidden in the system for a long time but does not show symptoms every time

Further details

Always latest result in this scenario: latest


Related issues

Is duplicate of openQA Tests - action #18828: [tools][sles][functional] keystrokes are sometimes ignored on aarch64 in partitioning_raid testResolved2017-04-27

History

#2 Updated by SLindoMansilla over 4 years ago

  • Has duplicate action #18828: [tools][sles][functional] keystrokes are sometimes ignored on aarch64 in partitioning_raid test added

#3 Updated by SLindoMansilla over 4 years ago

  • Subject changed from [sles][functional] test fails in partitioning_raid - the test fails selecting the disks for raid to [sles][functional] test fails in partitioning_raid - the test fails selecting the disks for raid (keystrokes are sometimes ignored on aarch64 in partitioning_raid test)
  • Description updated (diff)

#4 Updated by okurz over 4 years ago

  • Has duplicate deleted (action #18828: [tools][sles][functional] keystrokes are sometimes ignored on aarch64 in partitioning_raid test)

#5 Updated by okurz over 4 years ago

  • Status changed from New to Rejected

merged with #18828

#6 Updated by okurz over 4 years ago

  • Is duplicate of action #18828: [tools][sles][functional] keystrokes are sometimes ignored on aarch64 in partitioning_raid test added

#7 Updated by okurz over 4 years ago

  • Project changed from SUSE QA to openQA Tests
  • Category set to Bugs in existing tests

moved the ticket to openQA tests as we reference tickets in our openQA review reports and the script fails to access tickets from the private suse qa project. We should avoid tickets in "suseqa" therefore.

Also available in: Atom PDF