Project

General

Profile

action #112691

[qe-core]test fails in systemd_rpm_macros because of missing depedencies

Added by apappas 8 months ago. Updated 3 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Bugs in existing tests
Target version:
Start date:
2022-06-17
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

Observation

openQA test in scenario sle-15-SP4-Server-DVD-Updates-x86_64-mau-extratests2@64bit fails in
systemd_rpm_macros
with the error nothing provides 'pkgconfig(cmocka)' needed by the to be installed multipath-tools-0.8.8+64+suse.f265f7e0-150400.2.4.src

The test tries to build multipath-tools but the buildtime depedencies cannot be satisfied by the modules that are included in the run.

We either need to add the necessary module to the run or make the test build something else if that is possible.

Acceptance Criteria

  • AC1: Fix the buildtime depedencies of the test.

Reproducible

Fails since (at least) Build 20220614-1

Expected result

Last good: (unknown) (or more recent)

Further details

Always latest result in this scenario: latest


Related issues

Related to openQA Tests - action #113213: [qe-core] test fails in systemd_rpm_macros - bsc#1200713Resolved2022-07-04

History

#1 Updated by apappas 8 months ago

  • Tags set to bugbusters
  • Priority changed from Normal to Immediate

#2 Updated by punkioudi 8 months ago

  • Status changed from New to Workable
  • Target version set to QE-Core: Ready

#3 Updated by dheidler 8 months ago

  • Status changed from Workable to Blocked
  • Assignee set to dheidler

The missing dependency would be provided by libcmocka-devel which should be in the PackageHub repo, that is already present in this test.
It is in the 15-SP3 PackageHub repo but missing from the 15-SP4 one.
So it looks like a product bug to me:

https://bugzilla.suse.com/show_bug.cgi?id=1200713

#4 Updated by punkioudi 8 months ago

  • Priority changed from Immediate to High

#5 Updated by cdywan 6 months ago

This ticket was set to High priority but was not updated within the SLO period. Please consider picking up this ticket or just set the ticket to the next lower priority.

#6 Updated by dheidler 6 months ago

This is still waiting on the bug to be resolved.
This should then also fix this test.
But it also seems that systemd_rpm_macros doesn't run anymore within this testsuite.

#7 Updated by slo-gin 5 months ago

This ticket was set to High priority but was not updated within the SLO period. Please consider picking up this ticket or just set the ticket to the next lower priority.

#8 Updated by dheidler 5 months ago

Asked Wolfgang Engel for status - ETA is end of next week.

#9 Updated by dheidler 5 months ago

  • Priority changed from High to Normal

lowering prio as test is not scheduled anymore

#10 Updated by dheidler 3 months ago

  • Status changed from Blocked to Workable
  • Assignee deleted (dheidler)

Unassigning, because I'm in the tools team right now.
The packages should now be available in the distro, though.
So it should be possible to re-add the test to schedule.

#11 Updated by pdostal 3 months ago

  • Assignee set to pdostal

#12 Updated by pdostal 3 months ago

  • Related to action #113213: [qe-core] test fails in systemd_rpm_macros - bsc#1200713 added

#14 Updated by pdostal 3 months ago

  • Status changed from Workable to Resolved

Also available in: Atom PDF