Project

General

Profile

Actions

coordination #95389

open

[Leap15.3][qe-core][qem][epic] test fails sporadically in updates_packagekit_gpk

Added by punkioudi over 2 years ago. Updated over 1 year ago.

Status:
Feedback
Priority:
Normal
Assignee:
-
Category:
Bugs in existing tests
Target version:
-
Start date:
2021-07-12
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

It seems that Package updater takes more time to load, than 100s that are set in match_timeout

Observation

openQA test in scenario opensuse-15.3-DVD-Backports-Incidents-x86_64-gnome@64bit-2G fails in
updates_packagekit_gpk

Test suite description

Reproducible

Fails since (at least) Build 20210712-2

Expected result

Last good: 20210712-1 (or more recent)

Further details

Always latest result in this scenario: latest

Actions #2

Updated by geor over 2 years ago

  • Assignee set to geor
Actions #3

Updated by geor over 2 years ago

  • Status changed from New to Workable
  • % Done changed from 0 to 20
Actions #4

Updated by geor over 2 years ago

  • Status changed from Workable to Resolved

After running this scenario 20 times through a period of 12+ hours, there were zero occurrences of the failures: http://angmar.suse.de/tests/3629#next_previous.

This leads me to believe that the failures observed in o3 are infrastructure related and there isn't a fix we can provide (as qe-core), not least because there is no test failure to be reproduced.

I will mark this ticket as resolved, but feel free to reopen it, if it is clear to someone else that qe-core can provide a fix for this.

Actions #5

Updated by geor over 2 years ago

  • % Done changed from 20 to 100
Actions #6

Updated by szarate over 2 years ago

  • Tracker changed from action to coordination
  • Subject changed from [Leap15.3][qe-core][qem] test fails sporadically in updates_packagekit_gpk to [Leap15.3][qe-core][qem][epic] test fails sporadically in updates_packagekit_gpk
  • Status changed from Resolved to Feedback
  • Assignee deleted (geor)
  • % Done changed from 100 to 0
  1. We found out that the test here: https://openqa.opensuse.org/tests/1835395#step/updates_packagekit_gpk/51 simply timed out. does it really make sense for this to take this long? is it a product bug?.

Next step is to collect similar failures within this ticket and analize what's going on, not all may be fixed but there might be some underlying issues hidden.

Actions #7

Updated by livdywan over 1 year ago

This ticket was set to Normal priority but was not updated within the SLO period. Please consider picking up this ticket or just set the ticket to the next lower priority.

Actions

Also available in: Atom PDF