Project

General

Profile

action #63346

[tools][sporadic] false-positive match on "screenlock-xscreensaver-20180821" when instead a console prompt is shown

Added by okurz almost 3 years ago. Updated almost 3 years ago.

Status:
Resolved
Priority:
High
Assignee:
Category:
Bugs in existing tests
Target version:
SUSE QA - Milestone 30
Start date:
2020-02-10
Due date:
% Done:

0%

Estimated time:
42.00 h
Difficulty:

Description

Observation

openQA test in scenario opensuse-Tumbleweed-NET-x86_64-zdup_tw2twnext_gnome@64bit fails in
updates_packagekit_gpk as a consequence of false-match on "screenlock-xscreensaver-20180821".

Tasks

  • The previous module uses the root console. updates_packagekit_gpk is not able to switch to x11/Wayland session (x11 console). select_console 'x11', await_console => 0;

Suggestion

  • Try an scenario that just boots to desktop and tries to select all the console in a loop several times (100?) so that we are able to reproduce the issue and improve the console switching.

Reproducible

Often, not always, different scenarios.

Expected result

There should be no match of "screenlock-xscreensaver" on a terminal screen.

Suggestions

  • Make needle more strict, e.g. increase match level or reduce size of matching boxes
  • Crosscheck where needle is used, e.g. using openqa.opensuse.org/admin/needles

Further details

Always latest result in this scenario: latest


Related issues

Related to openQA Tests - action #48899: [opensuse] kdelive/upgrade: does not handle package notificationsResolved2019-03-08

Related to openQA Tests - action #63613: [opensuse][functionality][u] test fails in updates_packagekit_gpk - no logs are availableRejected2020-02-19

Blocks openQA Tests - action #63670: [functional][u] test fails in x11 - black screenResolved2020-02-20

History

#1 Updated by okurz almost 3 years ago

  • Related to action #48899: [opensuse] kdelive/upgrade: does not handle package notifications added

#2 Updated by SLindoMansilla almost 3 years ago

  • Description updated (diff)
  • Status changed from New to Workable
  • Target version set to Milestone 30
  • Estimated time set to 42.00 h

#3 Updated by SLindoMansilla almost 3 years ago

  • Description updated (diff)

#4 Updated by zluo almost 3 years ago

  • Status changed from Workable to In Progress
  • Assignee set to zluo

take over

#5 Updated by zluo almost 3 years ago

screenlock-xscreensaver-20180821.json has 2 tags:

"tags": [
"screenlock",
"blackscreen"
],

I think, select_console 'x11' doesn't work because of poor performance.

#6 Updated by zluo almost 3 years ago

and there is no logs available so we can not check for possible X-server crash.

but we have: https://openqa.opensuse.org/tests/1151806#step/updates_packagekit_gpk/172

Please, file a bug(s) with expected error. Details:

/var/log/YaST2/y2log-1.gz:2020-01-22 13:22:30 install(3784) [zypp::exec] ExternalProgram.cc(close):466 select error: Interrupted system call

#7 Updated by zluo almost 3 years ago

We need logs anyway, the question is why no logs got uploaded to server? I can not exclude a crash atm.

#9 Updated by zluo almost 3 years ago

sub ensure_unlocked_desktop {
my $counter = 10;
while ($counter--) {
assert_screen [qw(displaymanager displaymanager-password-prompt generic-desktop screenlock screenlock-password authentication-required-user-settings)], no_wait => 1;
if (match_has_tag 'displaymanager') {
if (check_var('DESKTOP', 'minimalx')) {
type_string "$username";
save_screenshot;
}
# Always select user if DM_NEEDS_USERNAME is set
if ((!check_var('DESKTOP', 'gnome') || (is_sle('<15') || is_leap('<15.0'))) && !get_var('DM_NEEDS_USERNAME')) {
send_key 'ret';
}
# On gnome, user may not be selected and using 'ret' is not enough in this case
else {
select_user_gnome($username);
}
}

....

select_user_gnome($username) seems to be not working.

#10 Updated by okurz almost 3 years ago

  • Assignee changed from zluo to okurz

It seems you have missed to read the complete description of my ticket and got confused a bit. I thought the description would already describe enough . As you requested I have now also commented in https://bugzilla.opensuse.org/show_bug.cgi?id=1164311#c12 . I now deleted the needle causing false-positive matches myself with https://github.com/os-autoinst/os-autoinst-needles-opensuse/pull/646 .

#11 Updated by okurz almost 3 years ago

  • Related to action #63613: [opensuse][functionality][u] test fails in updates_packagekit_gpk - no logs are available added

#12 Updated by okurz almost 3 years ago

  • Blocks action #63670: [functional][u] test fails in x11 - black screen added

#13 Updated by okurz almost 3 years ago

  • Subject changed from [functional][u][sporadic] false-positive match on "screenlock-xscreensaver-20180821" when instead a console prompt is shown to [tools][sporadic] false-positive match on "screenlock-xscreensaver-20180821" when instead a console prompt is shown
  • Status changed from In Progress to Resolved

as reported above with test results false-positive matches have been prevented. With this I see the ticket as successfully resolved.

Also available in: Atom PDF