Project

General

Profile

action #60992

[qe-core][functional][sporadic] generic problem with select_console / workqueue lockup message

Added by StefanBruens over 1 year ago. Updated 8 months ago.

Status:
Resolved
Priority:
High
Assignee:
Category:
Enhancement to existing tests
Target version:
SUSE QA - Milestone 30
Start date:
2019-12-12
Due date:
% Done:

0%

Estimated time:
42.00 h
Difficulty:

Description

Observation

openQA test in scenario opensuse-Tumbleweed-NET-x86_64-upgrade_Leap_42.3_cryptlvm@uefi fails in
curl_https

select_console 'user-console' works as expected, but stumbles over the common 'workqueue lockup' kernel error message.

The message should be detected (there are already needles for it), then a send_key 'ret' should be suficient to get a prompt on a new line.

Tasks

  1. Check if the workqueue lockup message is shown with a workaround needle match, then press enter.
  2. Continue to "select console"

Reproducible

Fails since (at least) Build 20191211 (current job)

Expected result

Last good: 20191210 (or more recent)

Further details

Always latest result in this scenario: latest


Related issues

Related to openQA Tests - action #46988: [qe-core][functional] Detect known bugs from system journalNew2018-04-16

History

#1 Updated by mgriessmeier over 1 year ago

  • Category changed from Refactor/Code Improvements to Enhancement to existing tests

#2 Updated by mgriessmeier over 1 year ago

  • Subject changed from generic problem with select_console / workqueue lockup message to [functional][u] generic problem with select_console / workqueue lockup message
  • Priority changed from Normal to High

#3 Updated by SLindoMansilla over 1 year ago

  • Subject changed from [functional][u] generic problem with select_console / workqueue lockup message to [functional][u][sporadic] generic problem with select_console / workqueue lockup message
  • Description updated (diff)
  • Status changed from New to Workable
  • Target version set to Milestone 28
  • Estimated time set to 42.00 h

#4 Updated by mgriessmeier over 1 year ago

  • Target version changed from Milestone 28 to Milestone 30

moving to current Milestone

#5 Updated by zluo over 1 year ago

  • Status changed from Workable to In Progress
  • Assignee set to zluo

take over.

#7 Updated by zluo over 1 year ago

PR updated now
create also a new workaround needle with different tag than current workaround "root-console":

https://github.com/Zaoliang/os-autoinst-needles-opensuse/pull/new/workaround_lockup_message

#10 Updated by zluo over 1 year ago

  • Status changed from In Progress to Rejected

I checked this again and as okurz already pointed out that the code change is not proved. Since this issue is already covered by workaround issue. I'll close this PR and reject the ticket, thanks

#11 Updated by StefanBruens over 1 year ago

  • Status changed from Rejected to Workable

You should not close this - the issue is valid.

There is one instance where the issue is already covered, this just leaves every other instance ..

#12 Updated by okurz over 1 year ago

zluo the issue is not already covered by a needle that just detects the situation. Please read my suggestion in https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/9320#issuecomment-576528575 carefully again.

#13 Updated by SLindoMansilla over 1 year ago

  • Status changed from Workable to New
  • Assignee deleted (zluo)

It needs a team consensus.

#14 Updated by SLindoMansilla over 1 year ago

The bug is properly marked as soft-fail: https://openqa.opensuse.org/tests/1149288#step/orphaned_packages_check/3

due to

commit 941cab6d37f03bc99b890de04d0a4ad8166fb09c (dheidler/soft)
Author: Dominik Heidler <dheidler@suse.de>
Date:   Mon Mar 18 13:14:48 2019 +0100

    Consider "rogue workqueue lockup" error as soft

diff --git a/lib/known_bugs.pm b/lib/known_bugs.pm
index 07d865647..b81979e05 100644
--- a/lib/known_bugs.pm
+++ b/lib/known_bugs.pm
@@ -33,7 +33,7 @@ sub create_list_of_serial_failures {


     # Detect rogue workqueue lockup
-    push @$serial_failures, {type => 'hard', message => 'rogue workqueue lockup bsc#1126782', pattern => quotemeta 'BUG: workqueue lockup'};
+    push @$serial_failures, {type => 'soft', message => 'rogue workqueue lockup bsc#1126782', pattern => quotemeta 'BUG: workqueue lockup'};

     # Detect bsc#1093797 on aarch64
     if (is_sle('=12-SP4') && check_var('ARCH', 'aarch64')) {

But, the workaround of pressing ret key is not yet implemented.
This test worked because it typed the command before checking the console.

#15 Updated by zluo over 1 year ago

  • Status changed from New to Workable

set it as workable because we have discussed this issue already.

#16 Updated by zluo over 1 year ago

  • Blocks action #44156: [opensuse][functional][u][sporadic][ppc64le] test fails in yast2_lan because rcu message in user-console added

#17 Updated by dheidler over 1 year ago

I'm not 100% sure what should be done here.
The linked fail only happened once and didn't appear anymore in the last two months.
So I guess it would not really make sence to fix the curl_https module.

So is the idea here to change the code in select_console?

#19 Updated by jorauch 11 months ago

  • Status changed from Workable to In Progress
  • Assignee set to jorauch

Lets see if the new tasks will fix this

#20 Updated by szarate 11 months ago

  • Related to action #46988: [qe-core][functional] Detect known bugs from system journal added

#21 Updated by zluo 11 months ago

  • Blocks deleted (action #44156: [opensuse][functional][u][sporadic][ppc64le] test fails in yast2_lan because rcu message in user-console)

#22 Updated by szarate 10 months ago

  • Status changed from In Progress to Workable

#23 Updated by jorauch 10 months ago

  • Status changed from Workable to In Progress

Back at it

#24 Updated by jorauch 9 months ago

  • Status changed from In Progress to Feedback

#25 Updated by szarate 9 months ago

  • Status changed from Feedback to In Progress

#26 Updated by tjyrinki_suse 9 months ago

  • Subject changed from [functional][u][sporadic] generic problem with select_console / workqueue lockup message to [qe-core][functional][sporadic] generic problem with select_console / workqueue lockup message

#27 Updated by jorauch 8 months ago

  • Status changed from In Progress to Resolved

PR is merged and no one complained, considering this as resolved

Also available in: Atom PDF