Project

General

Profile

action #60257

[functional][u][mistyping] random typing issues on wayland

Added by dzedro 10 months ago. Updated 5 months ago.

Status:
Rejected
Priority:
Normal
Assignee:
Category:
Bugs in existing tests
Target version:
SUSE QA tests - Milestone 30
Start date:
2019-11-25
Due date:
% Done:

0%

Estimated time:
42.00 h
Difficulty:


Related issues

Related to openQA Tests - action #55445: [functional][u] On OSD get rid of workaround QEMUVGA=cirrus in machinesResolved2019-10-28

Related to openQA Tests - action #42362: [qam][virtio][sle15sp0][sle15sp1][desktop] test fails in window_system because "typing string is too fast in wayland"In Progress2018-10-12

Is duplicate of openQA Tests - action #43889: [functional][u][virtio][wayland] test fails in ooffice - openQA makes spelling mistakesBlocked2018-11-16

History

#1 Updated by dzedro 10 months ago

  • Related to action #55445: [functional][u] On OSD get rid of workaround QEMUVGA=cirrus in machines added

#2 Updated by dzedro 10 months ago

  • Related to action #44339: [functional][u][mistyping] test fails in sshxterm - character missing in tput bold 2; tput setaf 1 making the test fail due to the needle not matching the expected prompt added

#3 Updated by dzedro 10 months ago

  • Related to deleted (action #44339: [functional][u][mistyping] test fails in sshxterm - character missing in tput bold 2; tput setaf 1 making the test fail due to the needle not matching the expected prompt)

#4 Updated by dzedro 10 months ago

  • Related to action #43889: [functional][u][virtio][wayland] test fails in ooffice - openQA makes spelling mistakes added

#5 Updated by zluo 10 months ago

  • Category set to Bugs in existing tests
  • Status changed from New to Workable
  • Target version set to Milestone 28
  • Estimated time set to 42.00 h

suggestion: to use VNC_TYPING_LIMIT for try.

#6 Updated by dheidler 10 months ago

  • Status changed from Workable to In Progress
  • Assignee set to dheidler

#7 Updated by dzedro 10 months ago

I added VNC_TYPING_LIMIT=18 on 15sp1 as it passed without mistype, tired multiple values, 15 works but on 20 there was still typing problem https://openqa.suse.de/tests/3646105#step/ghostscript/24
Will see if 18 is good enough or will try even lover limit.

#8 Updated by dheidler 10 months ago

I also had misstypings for value 20: http://artemis.suse.de/tests/2104#step/libreoffice_open_specified_file/13

According to https://de.wikipedia.org/wiki/Anschl%C3%A4ge_pro_Minute the world record of fast typing is at 15.9 keys per second.

#9 Updated by dheidler 10 months ago

  • Status changed from In Progress to Feedback

Added VNC_TYPING_LIMIT=18 to all test suites on osd matching ^gnome and to alpatterns

#10 Updated by dzedro 10 months ago

ghostscript test is failing with VNC_TYPING_LIMIT=10 https://openqa.suse.de/tests/3672654#settings
At the end I will have to modify test ghostscript, as for some reason typing is getting nuts there.

#11 Updated by dzedro 9 months ago

I would say there is issue on wayland which can't be reliably solved with VNC_TYPING_LIMIT, found typing failures with VNC_TYPING_LIMIT=10 https://openqa.suse.de/tests/3684650#step/libreoffice_double_click_file/104
I'm using even lover values, but it still didn't eliminate typing issue & another problem is that such low typing limit makes the test run much longer.

#12 Updated by mgriessmeier 9 months ago

  • Target version changed from Milestone 28 to Milestone 30

let's discuss this please :)

what is still needed?

#13 Updated by dheidler 9 months ago

Ideas:

  • Crosscheck if VM is busy or test environment (around VM)
  • Check IO activity from qemu
  • Cross check system responsiveness from post fail hook and magic sysrq
  • Ensure baseclass post fail hook executes first to check system responsiveness

#14 Updated by okurz 8 months ago

This is an autogenerated message for openQA integration by the openqa_review script:

This bug is still referenced in a failing openQA test: gnome
https://openqa.suse.de/tests/3806218

To prevent further reminder comments one of the following options should be followed:

  1. The test scenario is fixed by applying the bug fix to the tested product or the test is adjusted
  2. The openQA job group is moved to "Released"
  3. The label in the openQA scenario is removed

#15 Updated by dheidler 8 months ago

  • Status changed from Feedback to Workable
  • Assignee deleted (dheidler)

#16 Updated by dheidler 8 months ago

Suggestion: use xdotool to type a lokg text into libreoffice and see if that works.

#17 Updated by okurz 8 months ago

  • Related to action #42362: [qam][virtio][sle15sp0][sle15sp1][desktop] test fails in window_system because "typing string is too fast in wayland" added

#18 Updated by okurz 8 months ago

  • Status changed from Workable to Blocked
  • Assignee set to mgriessmeier
  • Priority changed from Urgent to Normal

Actually I suggest no one invests any work specifically in this ticket unless it's module specific work arounds as the related ticket #43889 has many more related tickets and hence more information. #42362 is the ticket you should wait for.

mgriessmeier maybe as QSF-u PO you want to assign this ticket to yourself and set to "Blocked"? You know, part of "saying No" as PO as in "We will not do it, wait for desktop experts" :) Please see my ticket assignment only as a suggestion, feel free to change it any way you like.

#19 Updated by openqa_review 6 months ago

This is an autogenerated message for openQA integration by the openqa_review script:

This bug is still referenced in a failing openQA test: gnome
https://openqa.suse.de/tests/4020118

To prevent further reminder comments one of the following options should be followed:

  1. The test scenario is fixed by applying the bug fix to the tested product or the test is adjusted
  2. The openQA job group is moved to "Released"
  3. The label in the openQA scenario is removed

#20 Updated by okurz 6 months ago

This is an autogenerated message for openQA integration by the openqa_review script:

This bug is still referenced in a failing openQA test: gnome
https://openqa.suse.de/tests/4020118

To prevent further reminder comments one of the following options should be followed:

  1. The test scenario is fixed by applying the bug fix to the tested product or the test is adjusted
  2. The openQA job group is moved to "Released"
  3. The label in the openQA scenario is removed

#21 Updated by okurz 5 months ago

This is an autogenerated message for openQA integration by the openqa_review script:

This bug is still referenced in a failing openQA test: qam-allpatterns+addons@uefi
https://openqa.suse.de/tests/4091228

To prevent further reminder comments one of the following options should be followed:

  1. The test scenario is fixed by applying the bug fix to the tested product or the test is adjusted
  2. The openQA job group is moved to "Released"
  3. The label in the openQA scenario is removed

#22 Updated by SLindoMansilla 5 months ago

  • Related to deleted (action #43889: [functional][u][virtio][wayland] test fails in ooffice - openQA makes spelling mistakes)

#23 Updated by SLindoMansilla 5 months ago

  • Is duplicate of action #43889: [functional][u][virtio][wayland] test fails in ooffice - openQA makes spelling mistakes added

#24 Updated by SLindoMansilla 5 months ago

  • Status changed from Blocked to Rejected

As duplicate of #43889

Also available in: Atom PDF