Project

General

Profile

action #51767

[functional][u] test fails in rebootmgr - No logs uploaded

Added by ggardet_arm over 2 years ago. Updated over 2 years ago.

Status:
Resolved
Priority:
High
Assignee:
Category:
Bugs in existing tests
Target version:
SUSE QA - Milestone 25
Start date:
2019-05-21
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

Observation

rebootmgr does not upload journalctl logs, so it is difficult to debug the failure. post_fail_hook should be updated to upload more logs.
It should be enough to use consoletest as base.

openQA test in scenario opensuse-Tumbleweed-DVD-aarch64-transactional_server@aarch64 fails in
rebootmgr

Suggestions

Properly implement a post fail hook that is calling the export_logs and export_logs_locale methods.

Reproducible

Fails since (at least) Build 20190508

Expected result

Last good from Tumbleweed x86_64: 20190521

Further details

Always latest result in this scenario: latest


Related issues

Related to openQA Tests - action #51296: [functional][u][aarch64][ppc64le][s390x] test fails in transactional_update - missing file utt-sle-aarch64.tgzResolved2019-05-08

History

#1 Updated by SLindoMansilla over 2 years ago

  • Subject changed from test fails in rebootmgr - No logs uploaded to [functional][u] test fails in rebootmgr - No logs uploaded
  • Description updated (diff)
  • Assignee set to SLindoMansilla
  • Priority changed from Normal to High

It should be enough to use consoletest as base. Checking...

#2 Updated by SLindoMansilla over 2 years ago

  • Related to action #51296: [functional][u][aarch64][ppc64le][s390x] test fails in transactional_update - missing file utt-sle-aarch64.tgz added

#3 Updated by SLindoMansilla over 2 years ago

  • Description updated (diff)

#4 Updated by ggardet_arm over 2 years ago

Any update on this?
The problem seems to be with console selection.

#5 Updated by szarate over 2 years ago

  • Description updated (diff)
  • Status changed from New to Workable
  • Assignee deleted (SLindoMansilla)

#6 Updated by mgriessmeier over 2 years ago

  • Target version set to Milestone 25

#8 Updated by dheidler over 2 years ago

The PR is merged. Is this ticket already resolved then?

#9 Updated by ggardet_arm over 2 years ago

  • Status changed from Workable to Resolved
  • Assignee set to ggardet_arm

Yes, PR is merged, so it is done.

Also available in: Atom PDF