Project

General

Profile

action #51296

[functional][u][aarch64][ppc64le][s390x] test fails in transactional_update - missing file utt-sle-aarch64.tgz

Added by dheidler over 2 years ago. Updated over 2 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Bugs in existing tests
Target version:
SUSE QA - Milestone 24
Start date:
2019-05-08
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

Observation

This is an install only scenario. Tests modules after first_boot shouldn't be there. They are not yet adapted for non-kubic/non-microos systems.

Caused by changes in: https://github.com/os-autoinst/os-autoinst-distri-opensuse/commit/ef2d574187a68243cf7a810493ace5857f74e82e#diff-d3e0a6c7df772cff7741832a6250d5af

Acceptance criteria

  • AC1: It is possible to use the setting INSTALLONLY=1 to perform an install only installation on test suite transactional_server.
  • AC2: It is possible to schedule the test suite transactional_server without the setting INSTALLONLY to perform the expected transactional server behavior only.
  • AC3: There is at least one passed job per architecture in the development job group.
  • AC4: The test suite for an architecture is moved to the main job group when there is a passed job in the development job group.

Reproducible

Fails since Build 225.1

Expected result

Last good from x86_64 Build(223.2): https://openqa.suse.de/tests/2859478#step/first_boot/1

Further details

Always latest result in this scenario: latest


Related issues

Related to openQA Tests - action #51767: [functional][u] test fails in rebootmgr - No logs uploadedResolved2019-05-21

Has duplicate openQA Tests - action #51314: [sle][functional][u] test fails in transactional_update - never worked beforeRejected2019-05-09

History

#1 Updated by SLindoMansilla over 2 years ago

  • Priority changed from Normal to High

#2 Updated by SLindoMansilla over 2 years ago

  • Description updated (diff)

#3 Updated by SLindoMansilla over 2 years ago

  • Assignee set to SLindoMansilla

#4 Updated by SLindoMansilla over 2 years ago

  • Related to action #51314: [sle][functional][u] test fails in transactional_update - never worked before added

#5 Updated by SLindoMansilla over 2 years ago

  • Subject changed from [functional][u] test fails in transactional_update to [functional][u] test fails in transactional_update - wrong test module schedule
  • Description updated (diff)

#6 Updated by SLindoMansilla over 2 years ago

  • Related to deleted (action #51314: [sle][functional][u] test fails in transactional_update - never worked before)

#7 Updated by SLindoMansilla over 2 years ago

  • Has duplicate action #51314: [sle][functional][u] test fails in transactional_update - never worked before added

#8 Updated by SLindoMansilla over 2 years ago

  • Status changed from New to Feedback

PR: https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/7414

Merged.
Waiting for verification run on OSD.

#9 Updated by SLindoMansilla over 2 years ago

  • Target version set to Milestone 24

#10 Updated by SLindoMansilla over 2 years ago

  • Status changed from Feedback to Resolved

#11 Updated by szarate over 2 years ago

  • Subject changed from [functional][u] test fails in transactional_update - wrong test module schedule to [functional][u][aarch64] test fails in transactional_update - missing file utt-sle-aarch64.tgz
  • Status changed from Resolved to Workable
  • Assignee changed from SLindoMansilla to mkravec
  • Priority changed from High to Normal

#12 Updated by szarate over 2 years ago

  • Subject changed from [functional][u][aarch64] test fails in transactional_update - missing file utt-sle-aarch64.tgz to [functional][u][aarch64][ppc64le][s390x] test fails in transactional_update - missing file utt-sle-aarch64.tgz

Also happens on ppc64le and I guess on s390 too if that architecture is also meant to support transactional updates https://openqa.suse.de/tests/2874294#step/transactional_update/9

#13 Updated by SLindoMansilla over 2 years ago

Setting INSTALLONLY=1 removed from test suite transactional_server on https://openqa.suse.de/admin/test_suites

#14 Updated by SLindoMansilla over 2 years ago

  • Description updated (diff)

Tests suite transactional_server moved from main job group to development job group for all architectures until we have a passed test that matches the acceptance criteria.

please, no dirty hacks ;)

#15 Updated by SLindoMansilla over 2 years ago

  • Description updated (diff)

#16 Updated by SLindoMansilla over 2 years ago

  • Description updated (diff)

#17 Updated by mkravec over 2 years ago

  • Status changed from Workable to Resolved

All tests are green in SLE 15 / Functional group.
What do you mean by "not passing"? Where can I see acceptance criteria you mentioned?

https://openqa.suse.de/tests/2880076 - x86_64
https://openqa.suse.de/tests/2880075 - aarch64
https://openqa.suse.de/tests/2877291 - ppc64le
https://openqa.suse.de/tests/2876886 - s390x

I added INSTALLONLY=1 variable again. Please stop breaking them by removing this variable!
If you want to remove it please provide PR that keeps them green without INSTALLONLY var.

Resolved by PR https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/7427

#18 Updated by SLindoMansilla over 2 years ago

  • Status changed from Resolved to Workable
  • Assignee changed from mkravec to SLindoMansilla

AC's are in the description.
Since the test suite are again using the setting INSTALLONLY, this ticket is not resolved.

As spoken I will take over.

#19 Updated by mkravec over 2 years ago

Ah, I see :)

AC 3,4 should be met.
About AC 1,2 - we don't need INSTALLONLY for HDD export, we run 1 scenario per platform.
It seems like nice-to-have feature, not hard requirement. Just my 2c - feel free to fix that :)

Can we move jobs back to functional group? I don't think INSTALLONLY variable should be reason for devel group.

#20 Updated by SLindoMansilla over 2 years ago

  • Parent task set to #51362

Should actually be "new", but is not available. Waiting for parent task to be refined.

#21 Updated by szarate over 2 years ago

  • Description updated (diff)
  • Status changed from Workable to Resolved
  • Assignee changed from SLindoMansilla to mkravec

As discussed with Sergio, setting the ticket to resolved, as we now have an poo#51362 as epic to target AC 1 and 2, since it's part of a bigger discussion.

#22 Updated by SLindoMansilla over 2 years ago

  • Parent task deleted (#51362)

#23 Updated by SLindoMansilla over 2 years ago

  • Related to action #51767: [functional][u] test fails in rebootmgr - No logs uploaded added

Also available in: Atom PDF