Project

General

Profile

action #44141

[functional][u][leap] test fails in sssd in junit test step "Start SSSD"

Added by mlin7442 over 3 years ago. Updated about 3 years ago.

Status:
Rejected
Priority:
Normal
Assignee:
Category:
Bugs in existing tests
Target version:
SUSE QA - Milestone 24
Start date:
2019-02-15
Due date:
% Done:

100%

Estimated time:
(Total: 0.00 h)
Difficulty:

Description

Observation

openQA test in scenario opensuse-15.1-DVD-x86_64-extra_tests_in_textmode@64bit fails in
sssd

looks similar to #43586 but ssd version in 15.1 is under 2.0

A recent test https://openqa.opensuse.org/tests/844196 shows that the junit based tests fail in the early step of "Start SSSD".

Reproducible

Fails reproducibly

Expected result

Last good: Build 301.2

Also openSUSE Tumbleweed still works, e.g. see https://openqa.opensuse.org/tests/849606#step/sssd/18

Suggestions

  • Make the test upload proper junit based logs on failure
  • Investigate manually and compare to Tumbleweed or Leap 15.0
  • Make sure the product problem is obvious with a reference to a proper bugreport or fix the test issue if it is any

Further details

Always latest result in this scenario: latest


Subtasks

action #47939: [opensuse][functional][u] provide test data as logs for sssd test moduleRejectedzluo


Related issues

Related to openQA Tests - action #33082: [sle][functional][u] sysauth/sssd is not scheduled on osdResolved2019-04-17

Related to openQA Tests - action #13168: [qe-core][opensuse][sle][functional] Sudo and LDAP/SSSD for sudoersWorkable5000-01-01

Related to openQA Tests - action #43586: [functional][u] test fails in sssd - needs to adapt to recent sssd updateResolved2018-11-08

Has duplicate openQA Tests - action #44321: test fails in sssdClosed2018-11-24

History

#1 Updated by okurz over 3 years ago

  • Related to action #33082: [sle][functional][u] sysauth/sssd is not scheduled on osd added

#2 Updated by okurz over 3 years ago

  • Related to action #13168: [qe-core][opensuse][sle][functional] Sudo and LDAP/SSSD for sudoers added

#3 Updated by okurz over 3 years ago

  • Subject changed from test fails in sssd to [functional][u] test fails in sssd
  • Target version set to Milestone 22

#4 Updated by okurz over 3 years ago

  • Related to action #43586: [functional][u] test fails in sssd - needs to adapt to recent sssd update added

#5 Updated by lnussel over 3 years ago

#6 Updated by lnussel over 3 years ago

the test needs to be improved to collect logs on failure

#7 Updated by okurz over 3 years ago

This is an autogenerated message for openQA integration by the openqa_review script:

This bug is still referenced in a failing openQA test: extra_tests_in_textmode
https://openqa.opensuse.org/tests/812365

#8 Updated by okurz over 3 years ago

This is an autogenerated message for openQA integration by the openqa_review script:

This bug is still referenced in a failing openQA test: extra_tests_in_textmode
https://openqa.opensuse.org/tests/816180

#9 Updated by okurz over 3 years ago

This is an autogenerated message for openQA integration by the openqa_review script:

This bug is still referenced in a failing openQA test: extra_tests_in_textmode
https://openqa.opensuse.org/tests/825202

#10 Updated by okurz over 3 years ago

  • Priority changed from Normal to High

linked in currently failing tests. However, with this level of detail and no "last good" reference there will be not much motivation by many to pick it up.

#11 Updated by okurz over 3 years ago

This is an autogenerated message for openQA integration by the openqa_review script:

This bug is still referenced in a failing openQA test: extra_tests_in_textmode
https://openqa.opensuse.org/tests/842023

#12 Updated by okurz over 3 years ago

  • Description updated (diff)

#13 Updated by okurz over 3 years ago

  • Subject changed from [functional][u] test fails in sssd to [functional][u][leap] test fails in sssd
  • Priority changed from High to Normal
  • Target version changed from Milestone 22 to Milestone 23

Shortly discussed in the QSF-u planning meeting. The according openSUSE Tumbleweed test case does not fail, e.g. see https://openqa.opensuse.org/tests/841664#step/sssd/44 so this seems to be a Leap specific problem.

mlin7442 lnussel Please take care to provide the necessary details for this to be workable.

#14 Updated by lnussel over 3 years ago

Huh? As I wrote two months(!) ago the test doesn't provide any logs. The test is just bad. Fix the test and then you have the data to actually debug it.

#15 Updated by lnussel over 3 years ago

  • Due date set to 2019-02-15
  • Priority changed from Normal to High

#16 Updated by okurz over 3 years ago

  • Subject changed from [functional][u][leap] test fails in sssd to [functional][u][leap] test fails in sssd in junit test step "Start SSSD"
  • Description updated (diff)
  • Status changed from New to Workable

lnussel wrote:

Huh? As I wrote two months(!) ago the test doesn't provide any logs. The test is just bad.

I was not asking for any logs but what I meant in #44141#note-10 . The original test author does not work for SUSE anymore, was not in QA, no one from our team has ever touched it. I don't think your comments are helpful but rather counter-productive.

I invested the time now and made the ticket "Workable".

#17 Updated by zluo over 3 years ago

  • Assignee set to zluo

checking this at first.

#18 Updated by zluo over 3 years ago

  • Status changed from Workable to Blocked

filed a bug and request for help from developer who might take a look at this problem and give comment or feedback so that we can go further with solution or workaround, fix on sssd.

https://bugzilla.opensuse.org/show_bug.cgi?id=1125277

#19 Updated by okurz over 3 years ago

  • Status changed from Blocked to Workable

As discussed today in the planning meeting and over IRC: Please set the bug to "Blocker" and set the bug to the bugowner of the package based on what osc bugowner -e sssd tells you

#20 Updated by zluo over 3 years ago

  • Status changed from Workable to Blocked

#21 Updated by zluo over 3 years ago

  • Status changed from Blocked to Resolved

https://openqa.opensuse.org/tests/856186 shows that sssd works now.

#22 Updated by okurz over 3 years ago

  • Status changed from Resolved to In Progress

Sorry but I do not see that. https://openqa.opensuse.org/tests/856186#step/sssd/20 sill fails what looks like the same error?!? confused

#23 Updated by zluo over 3 years ago

  • Status changed from In Progress to Feedback

will check this right now, thanks

#24 Updated by zluo over 3 years ago

  • Status changed from Feedback to Blocked

I overlooked this before:

new test run shows that we still have this issue and will check this for next build then
https://openqa.opensuse.org/tests/857468#

#25 Updated by lnussel over 3 years ago

The test still fails on 15.1:
https://openqa.opensuse.org/tests/865134#step/sssd/20

If we can't fix this can we please get rid of the test then? I am tired of overriding it.

#26 Updated by okurz over 3 years ago

lnussel wrote:

The test still fails on 15.1:
https://openqa.opensuse.org/tests/865134#step/sssd/20

If we can't fix this can we please get rid of the test then? I am tired of overriding it.

lnussel You can set EXCLUDE_MODULES=sssd on the medium :)

#27 Updated by mgriessmeier over 3 years ago

  • Target version changed from Milestone 23 to Milestone 24

moving to M24

#28 Updated by SLindoMansilla over 3 years ago

  • Status changed from Blocked to Workable

Hi zluo, please, only change the status to blocked when we have a link to a valid bug or progress ticket.

#29 Updated by zluo over 3 years ago

  • Status changed from Workable to Blocked

#30 Updated by zluo about 3 years ago

  • Status changed from Blocked to Rejected

https://openqa.opensuse.org/tests/801701#next_previous shows now stable and successful test runs.

So we can reject this for now.

Also available in: Atom PDF