Project

General

Profile

Actions

coordination #40979

closed

[sle][functional][y][epic] New test strategy for autoyast profiles from ay-tests repo

Added by riafarov almost 6 years ago. Updated 5 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Target version:
Start date:
2018-09-13
Due date:
% Done:

100%

Estimated time:
(Total: 8.00 h)

Description

Motivation

ay-tests package was designed to run profiles which were used both for openQA and CI YaST team has. Unfortunately now YaST team doesn't have enough resources to properly maintain all these tests.
Therefore we can reuse all the profiles which are working and extend coverage.
On top there are issues with building package, therefore, we could either simply check out them from the repo instead of installing the package

Acceptance criteria

  1. All working profiles from ay-tests are used in openQA Autoyast job group

For SLE 12 all profiles should work hypothetically. For SLE 15, not so many are adjusted, here is the list of working ones:
aytests/sles.rb
aytests/sles15.rb
aytests/sles15_firewalld.rb
aytests/sles_minimal.rb
aytests/sles_minimal_network.rb
aytests/sles_network.rb
aytests/sles_network_without_hosts.rb
aytests/sles_mini_network.rb
aytests/sles_insserv.rb
aytests/storage_ng_automated_lvm.rb
aytests/storage_ng_automated_partitioning.rb
aytests/storage_ng_lvm.rb
aytests/storage_ng_minimal.rb
aytests/storage_ng_plain_partitions.rb
aytests/storage_ng_raid.rb


Subtasks 4 (0 open4 closed)

action #40982: [sle][functional][y][fast] use git repo for autoyast_lvm and autoyast_tftp instead of relying on ay-tests packageResolvedriafarov2018-09-13

Actions
action #40988: [sle][functional][y][timeboxed:16h] Establish pipeline for autoyast testingRejected2018-09-13

Actions
action #42347: [functional][y] autoyast staging test?Resolvedriafarov2018-10-11

Actions
action #42356: [functional][y] Test pipeline using openQA for autoyast related changes before they hit the productRejected2018-10-11

Actions

Related issues 1 (0 open1 closed)

Related to qe-yam - coordination #23606: Integrate classes autoyast profile test in openQAResolvedJERiveraMoya2021-07-12

Actions
Actions #1

Updated by riafarov almost 6 years ago

Actions #2

Updated by okurz almost 6 years ago

  • Category set to Enhancement to existing tests
  • Target version set to future
Actions #3

Updated by riafarov almost 6 years ago

  • Due date set to 2018-10-23

due to changes in a related task

Actions #4

Updated by riafarov almost 6 years ago

  • Due date changed from 2018-10-23 to 2018-09-13

due to changes in a related task

Actions #5

Updated by riafarov almost 6 years ago

  • Due date set to 2018-10-23

due to changes in a related task

Actions #6

Updated by riafarov almost 6 years ago

  • Due date changed from 2018-10-23 to 2018-11-06

due to changes in a related task

Actions #7

Updated by riafarov almost 6 years ago

  • Subject changed from [sle][functional][y][epic] Move working autoyast profiles from ay-tests repo to os-autoinst-distri-opensuse to [sle][functional][y][epic] New test strategy for autoyast profiles from ay-tests repo
Actions #8

Updated by riafarov almost 6 years ago

  • Due date changed from 2018-11-06 to 2018-10-23

due to changes in a related task

Actions #9

Updated by riafarov over 5 years ago

  • Due date changed from 2018-10-23 to 2018-12-04

due to changes in a related task

Actions #10

Updated by riafarov over 5 years ago

  • Due date changed from 2018-12-04 to 2018-12-18

due to changes in a related task

Actions #11

Updated by riafarov over 5 years ago

  • Due date changed from 2018-12-18 to 2019-01-15

due to changes in a related task

Actions #12

Updated by riafarov over 5 years ago

  • Due date changed from 2019-01-15 to 2019-01-29

due to changes in a related task

Actions #13

Updated by riafarov over 5 years ago

  • Due date changed from 2019-01-29 to 2019-02-26

due to changes in a related task

Actions #14

Updated by riafarov over 5 years ago

  • Due date changed from 2019-02-26 to 2018-10-23

due to changes in a related task

Actions #15

Updated by riafarov about 5 years ago

  • Due date changed from 2018-10-23 to 2019-08-13

due to changes in a related task

Actions #16

Updated by JERiveraMoya almost 5 years ago

  • Due date changed from 2019-08-13 to 2019-08-27

due to changes in a related task

Actions #17

Updated by riafarov almost 5 years ago

  • Due date changed from 2019-08-27 to 2019-10-22

due to changes in a related task

Actions #18

Updated by riafarov almost 5 years ago

  • Due date changed from 2019-10-22 to 2018-10-23

due to changes in a related task

Actions #19

Updated by riafarov almost 5 years ago

  • Due date changed from 2018-10-23 to 2020-12-15

due to changes in a related task

Actions #20

Updated by szarate almost 4 years ago

  • Tracker changed from action to coordination
Actions #22

Updated by riafarov over 3 years ago

  • Project changed from openQA Tests to qe-yam
  • Category deleted (Enhancement to existing tests)
Actions #23

Updated by okurz almost 3 years ago

This ticket had a due set but exceeded it already by more than 14 days. We would like to take the due date seriously so please update the ticket accordingly (resolve the ticket or update the due-date or remove the due-date). See https://progress.opensuse.org/projects/openqatests/wiki/Wiki#SLOs-service-level-objectives for details. This update was done as agreed within the SUSE QE Sync call 2021-09-01

Actions #24

Updated by slo-gin almost 2 years ago

This ticket was set to Normal priority but was not updated within the SLO period. Please consider picking up this ticket or just set the ticket to the next lower priority.

Actions #25

Updated by JERiveraMoya 7 months ago

  • Target version deleted (future)
Actions #26

Updated by JERiveraMoya 7 months ago

  • Target version set to future
Actions #27

Updated by JERiveraMoya 5 months ago

  • Status changed from New to Resolved
Actions

Also available in: Atom PDF