Project

General

Profile

action #36304

[opensuse][functional]sporadic][u] chromium test is unstable

Added by coolo about 4 years ago. Updated almost 4 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Bugs in existing tests
Target version:
SUSE QA - Milestone 19
Start date:
2018-05-17
Due date:
2018-09-25
% Done:

0%

Estimated time:
2.00 h
Difficulty:
easy

Description

https://openqa.opensuse.org/tests/677588#step/chromium/17 accepts incomplete chromium startup (slow loading of home page) and then types about: blindly - resulting in a good for 'out:'

pop up dialog about translation breaks needle match, suggest to workaround this issue.
low performance issue sometimes should be handled as well, suggest to increase timeout for needle match.

Further details

link to latest


Related issues

Related to openQA Tests - coordination #35302: [qe-core][opensuse][functional][epic][sporadic] Various unstable tests on o3Resolved2018-04-26

Related to openQA Tests - action #31351: [functional][u][medium] force_cron_run does not actually run any crons (occasionally)Resolved2018-02-032018-07-03

Related to openQA Tests - action #63334: [functional][u][sporadic] test fails in chromium to go to "about/version" page in adress barResolved2020-02-10

Blocked by openQA Tests - action #38702: [functional][u] apply workaround for bsc#1096401 "snapper terminates with core dump"Resolved2018-05-172018-08-14

History

#1 Updated by JERiveraMoya about 4 years ago

  • Related to coordination #35302: [qe-core][opensuse][functional][epic][sporadic] Various unstable tests on o3 added

#2 Updated by JERiveraMoya about 4 years ago

  • Subject changed from [opensuse] chromium test is unsable to [opensuse] chromium test is unstable

#3 Updated by okurz about 4 years ago

  • Subject changed from [opensuse] chromium test is unstable to [opensuse][functional][u][fast] chromium test is unstable
  • Due date set to 2018-07-03
  • Category changed from Enhancement to existing tests to Bugs in existing tests
  • Status changed from New to In Progress
  • Assignee set to okurz
  • Target version set to Milestone 17

#4 Updated by okurz about 4 years ago

  • Status changed from In Progress to Feedback

https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/5280 merged. I should recheck at EOS if there are further chromium-related unstabilities.

#5 Updated by okurz about 4 years ago

  • Related to action #31351: [functional][u][medium] force_cron_run does not actually run any crons (occasionally) added

#6 Updated by okurz about 4 years ago

  • Status changed from Feedback to Blocked

Checked the linked scenario from latest and back from there, around 30/30 jobs did not fail in chromium: https://openqa.opensuse.org/tests/697882

https://openqa.opensuse.org/tests/697619#step/chromium/19 is the latest "chromium" test failure on current openSUSE Tumbleweed.

I am wondering about remaining "random chromium failures" in openQA tests, e.g. https://openqa.opensuse.org/tests/697619#step/chromium/19 shows that the test fails to type in the adress bar however the journal states a core dump about snapper. That sounds related to system is slowed down and chromium is just slow to react. We should not work around this in tests but detect the errors and report these, at best automatically from tests. I wonder if we can turn a fail into a soft-fail from a post_fail_hook, hm…

For now test labeled with https://bugzilla.suse.com/show_bug.cgi?id=1079877

I guess also here it would make sense to solve #31351 first to ensure that the maintenance tasks have been completed in the background.

#7 Updated by mgriessmeier almost 4 years ago

  • Due date changed from 2018-07-03 to 2018-07-17

#8 Updated by okurz almost 4 years ago

  • Due date changed from 2018-07-17 to 2018-07-31
  • Status changed from Blocked to Feedback
  • Target version changed from Milestone 17 to Milestone 18

Seems we covered this now properly with #35685 -> cromium stable but I will monitor

#9 Updated by okurz almost 4 years ago

Could not reproduce any problems locally but maybe we have some on production still …

#10 Updated by okurz almost 4 years ago

  • Copied to action #38702: [functional][u] apply workaround for bsc#1096401 "snapper terminates with core dump" added

#11 Updated by okurz almost 4 years ago

  • Copied to deleted (action #38702: [functional][u] apply workaround for bsc#1096401 "snapper terminates with core dump")

#12 Updated by okurz almost 4 years ago

  • Blocked by action #38702: [functional][u] apply workaround for bsc#1096401 "snapper terminates with core dump" added

#13 Updated by okurz almost 4 years ago

  • Description updated (diff)
  • Due date changed from 2018-07-31 to 2018-08-14

We had an update in html5test.opensuse.org which is also causing fails in chromium. I guess it's better to revisit this with better statistics in the next sprint.

#14 Updated by okurz almost 4 years ago

  • Status changed from Feedback to Workable
  • Assignee deleted (okurz)

stability of chromium test can be re-evaluated now

#15 Updated by okurz almost 4 years ago

  • Due date changed from 2018-08-14 to 2018-08-28

bulk move to next sprint as could not be discussed in SR

#16 Updated by okurz almost 4 years ago

  • Due date changed from 2018-08-28 to 2018-09-25
  • Target version changed from Milestone 18 to Milestone 19

#17 Updated by okurz almost 4 years ago

  • Subject changed from [opensuse][functional][u][fast] chromium test is unstable to [opensuse][functional][u] chromium test is unstable

#18 Updated by zluo almost 4 years ago

  • Subject changed from [opensuse][functional][u] chromium test is unstable to [opensuse][functional][u] chromium test i
  • Estimated time set to 2.00 h

#19 Updated by zluo almost 4 years ago

  • Difficulty set to easy

#20 Updated by mgriessmeier almost 4 years ago

  • Subject changed from [opensuse][functional][u] chromium test i to [opensuse][functional][u] chromium test is unstable

#21 Updated by zluo almost 4 years ago

  • Description updated (diff)

#22 Updated by zluo almost 4 years ago

  • Description updated (diff)

#23 Updated by zluo almost 4 years ago

  • Status changed from Workable to In Progress
  • Assignee set to zluo

take over

#24 Updated by zluo almost 4 years ago

atm update tests are not stable and got failed sometimes:

http://e13.suse.de/tests/8020#step/check_system_is_updated/9

#25 Updated by zluo almost 4 years ago

fixed one needle issue however:

http://e13.suse.de/tests/8021#step/chromium/17

failed for needle match of html tests:
http://e13.suse.de/tests/8021#step/chromium/21

#26 Updated by zluo almost 4 years ago

  • Subject changed from [opensuse][functional][u] chromium test is unstable to [opensuse][functional]sporadic][u] chromium test is unstable

started over 50 test runs and 99% are just passed. but I can still see failed test run like:

http://e13.suse.de/tests/8063#

it shows html test failed because the page is not loaded at all. It could be a network issue or performance issue. I need more test runs...

Anyway this becomes sporadic issue, the initial issue with translate dialog is gone.

#27 Updated by zluo almost 4 years ago

http://e13.suse.de/tests/8106#step/zypper_add_repos/16 shows problem with zypper_add_repos:

can't find a valid repository at given location

#28 Updated by zluo almost 4 years ago

http://e13.suse.de/tests/8463#next_previous

shows very stable test results.

#31 Updated by okurz over 2 years ago

  • Related to action #63334: [functional][u][sporadic] test fails in chromium to go to "about/version" page in adress bar added

Also available in: Atom PDF