Project

General

Profile

action #34405

[functional][y][bsc#1083398][medium] yast_virtualization needs to catch up

Added by dimstar about 2 years ago. Updated almost 2 years ago.

Status:
Resolved
Priority:
High
Assignee:
Category:
Bugs in existing tests
Start date:
2018-04-06
Due date:
2018-06-05
% Done:

0%

Estimated time:
Difficulty:
Duration: 43

Description

Observation

openQA test in scenario opensuse-Tumbleweed-DVD-x86_64-virtualization@64bit fails in
yast_virtualization

Reproducible

Fails since (at least) Build 20180318

Expected result

Last good: 20180316 (or more recent)

Further details

Always latest result in this scenario: latest

This entire test suite is very fragile, and deteriorated over time even more.

I know of at least those issues:

  • yast2-vm is no longer part of the patterns and thus not preinstalled: it needs to be installed by the test
  • The launch of vncviewer (I think that's the next one in the test suite) often fails, likely due to timing issues when virt-install is not yet ready.

Related issues

Has duplicate openQA Tests - action #34720: test fails in yast2_control_center - no yast virtualization module be installed by defaultRejected2018-04-11

History

#1 Updated by okurz about 2 years ago

  • Subject changed from yast_virtualization needs to catch up to [functional][y]yast_virtualization needs to catch up
  • Due date set to 2018-05-08
  • Status changed from New to Workable
  • Priority changed from Normal to High
  • Target version set to Milestone 15

#2 Updated by okurz about 2 years ago

  • Description updated (diff)
  • Target version changed from Milestone 15 to Milestone 16

#3 Updated by okurz about 2 years ago

  • Status changed from Workable to Feedback
  • Assignee set to okurz

dimstar wrote:

This entire test suite is very fragile, and deteriorated over time even more.

Sorry, but that seems to be your own fault. I checked the previous failures and there was always the label bsc#0 so most likely the only person knowing about the issues was you (or maxlin maybe).

  • yast2-vm is no longer part of the patterns and thus not preinstalled: it needs to be installed by the test

Why is that? The yast modules are designed in a way that the configuration parts do not hard-depend on the underlying services. The idea as I understood is that there is e.g. a "http server configuration" icon but it does not mean that apache2 is pre-installed. If you start that module it is asking to install apache2, same for yast2-vm. So why not keep yast2-vm as part of patterns?

#4 Updated by okurz about 2 years ago

I checked https://build.opensuse.org/package/view_file/openSUSE:Factory/yast2-vm/yast2-vm.spec?expand=1 and I don't see any tricky dependencies which should not be provided already by other parts which are most likely still there on a default openSUSE Tumbleweed installation.

#5 Updated by okurz about 2 years ago

  • Has duplicate action #34720: test fails in yast2_control_center - no yast virtualization module be installed by default added

#6 Updated by dimstar about 2 years ago

okurz wrote:

dimstar wrote:

This entire test suite is very fragile, and deteriorated over time even more.

Sorry, but that seems to be your own fault.

Fair point; bsc#0 was used to tag a random stuff, which later turned into a generic issue.

  • yast2-vm is no longer part of the patterns and thus not preinstalled: it needs to be installed by the test

Why is that? The yast modules are designed in a way that the configuration parts do not hard-depend on the underlying services. The idea as I understood is that there is e.g. a "http server configuration" icon but it does not mean that apache2 is pre-installed. If you start that module it is asking to install apache2, same for yast2-vm. So why not keep yast2-vm as part of patterns?

The changelog entry in patterns-yast was:

  • remove yast2-vm from Recommends as it will be only install if this this is a sles-release (BSC#1083398)

(so in fact this is inherited from SLE)

#7 Updated by okurz about 2 years ago

  • Subject changed from [functional][y]yast_virtualization needs to catch up to [functional][y][bsc#1083398] yast_virtualization needs to catch up
  • Status changed from Feedback to Blocked

hm, ok. I asked in the bug bsc#1083398. Thanks for the information. Let's set this to blocked and see if we can resolve it properly for SLE+openSUSE.

#8 Updated by okurz about 2 years ago

This is an autogenerated message for openQA integration by the openqa_review script:

This bug is still referenced in a failing openQA test: virtualization
https://openqa.opensuse.org/tests/668335

#9 Updated by mgriessmeier about 2 years ago

  • Due date changed from 2018-05-08 to 2018-05-22

bug seems to be still valid - moving over to next Sprint

#10 Updated by riafarov about 2 years ago

  • Due date changed from 2018-05-22 to 2018-06-05
  • Status changed from Blocked to Workable
  • Assignee deleted (okurz)

Bug does seem to get fixed soon, so need a workaround with soft-failure.

#11 Updated by SLindoMansilla about 2 years ago

  • Subject changed from [functional][y][bsc#1083398] yast_virtualization needs to catch up to [functional][y][bsc#1083398][medium] yast_virtualization needs to catch up

#12 Updated by JERiveraMoya almost 2 years ago

  • Status changed from Workable to In Progress
  • Assignee set to JERiveraMoya

#13 Updated by JERiveraMoya almost 2 years ago

  • Status changed from In Progress to Feedback

#14 Updated by JERiveraMoya almost 2 years ago

  • Status changed from Feedback to In Progress

Regarding virt_install the problem seems to happen when there is a previous TigerVNC Viewer dialog warning about "unable connect to socket: Connection refused(111): https://openqa.opensuse.org/tests/683854#step/virt_install/23 but it seems sporadic according to these verification runs: https://openqa.opensuse.org/tests/overview?distri=opensuse&version=Tumbleweed&build=20180527%40tests_jeriveramoya&groupid=38

#16 Updated by JERiveraMoya almost 2 years ago

  • Status changed from In Progress to Feedback

#17 Updated by JERiveraMoya almost 2 years ago

  • Status changed from Feedback to Resolved

#18 Updated by okurz almost 2 years ago

  • Status changed from Resolved to In Progress

Ok, thanks for your work so far but well, I just checked the latest job in this scenario and it failed in https://openqa.opensuse.org/tests/684688#step/yast_virtualization/30 so we should use this ticket to make sure that we have a stable test. Please check if this is related to your changes.

#19 Updated by JERiveraMoya almost 2 years ago

The test cannot be stable at the moment because of btrfs issues. It is always failing in different ways getting stuck, in this case is not launching the dialog for entering a command.
I proposed a workaround in https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/5147.
On the other hand for the two issues that are well identified in this test there were two fixes with two pull requests.
For the stability in my workaround I linked other PR where was detected the btrfs problem https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/5097. I think it makes more sense to deal with that in another ticket in case it does not exist as it is much more general.

What I realized is that we also need to stop pkon with this PR

#20 Updated by JERiveraMoya almost 2 years ago

  • Status changed from In Progress to Feedback

#21 Updated by JERiveraMoya almost 2 years ago

  • Status changed from Feedback to In Progress

#22 Updated by JERiveraMoya almost 2 years ago

  • Checklist set to [x] yast2-vm is no longer part of the patterns and thus not preinstalled: it needs to be installed by the test, [x] The launch of vncviewer (I think that's the next one in the test suite) often fails, likely due to timing issues when virt-install is not yet ready.

#23 Updated by JERiveraMoya almost 2 years ago

  • Checklist set to [ ] yast2-vm is no longer part of the patterns and thus not preinstalled: it needs to be installed by the test

#24 Updated by JERiveraMoya almost 2 years ago

  • Checklist set to [x] yast2-vm is no longer part of the patterns and thus not preinstalled: it needs to be installed by the test

#25 Updated by JERiveraMoya almost 2 years ago

  • Checklist set to [ ] yast2-vm is no longer part of the patterns and thus not preinstalled: it needs to be installed by the test

#26 Updated by JERiveraMoya almost 2 years ago

  • Checklist set to [x] yast2-vm is no longer part of the patterns and thus not preinstalled: it needs to be installed by the test

#27 Updated by JERiveraMoya almost 2 years ago

  • Status changed from In Progress to Resolved

#28 Updated by okurz almost 2 years ago

  • Checklist deleted ([x] yast2-vm is no longer part of the patterns and thus not preinstalled: it needs to be installed by the test, [x] The launch of vncviewer (I think that's the next one in the test suite) often fails, likely due to timing issues when virt-install is not yet ready.)

This is an autogenerated message for openQA integration by the openqa_review script:

This bug is still referenced in a failing openQA test: virtualization
https://openqa.opensuse.org/tests/693900

Also available in: Atom PDF