Project

General

Profile

action #34351

[qam] test fails in wireshark - adjustments needed in SLE15 due to new UI

Added by vsvecova about 4 years ago. Updated almost 4 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Bugs in existing tests
Target version:
SUSE QA - Milestone 17
Start date:
2018-04-05
Due date:
% Done:

100%

Estimated time:
Difficulty:

Description

Observation

openQA test in scenario sle-15-Installer-DVD-x86_64-we-module@64bit-virtio-vga fails in
wireshark

The ~2.4 version of wireshark, which is in SLE 15, has a massively changed user interface, thus requiring changes to the test code to accommodate new ways of navigating it.

Reproducible

Fails since (at least) Build 324.2

Expected result

Last good: (unknown) (or more recent)

Further details

Always latest result in this scenario: latest


Related issues

Related to openQA Tests - action #33646: [sle][functional][u][medium] test fails in wireshark - gnome_sled and we-module need adaptionResolved2018-03-222018-09-11

History

#1 Updated by vsvecova about 4 years ago

  • Status changed from New to In Progress
  • % Done changed from 0 to 20

#2 Updated by nicksinger about 4 years ago

I think this is a duplicate of https://progress.opensuse.org/issues/33646 but didn't want to close this one here blindly since you already recorded some progress in here. Would you mind closing this ticket here and work on poo#33646 instead?

#3 Updated by nicksinger about 4 years ago

  • Related to action #33646: [sle][functional][u][medium] test fails in wireshark - gnome_sled and we-module need adaption added

#4 Updated by okurz about 4 years ago

  • Subject changed from test fails in wireshark - adjustments needed in SLE15 due to new UI to [functional][u] test fails in wireshark - adjustments needed in SLE15 due to new UI
  • Due date set to 2018-06-19
  • Target version set to Milestone 17

#5 Updated by maritawerner about 4 years ago

Stefan Behlert told me that he would like to see a fix of that Testcasea asap and he pointed that out already to QA some time ago (I am not sure to whom). So could we please raise the priority here?

#6 Updated by vsvecova about 4 years ago

I am working on this issue; the ETA is next week.

I have verified the differences between the old and new GUI; the main difference in terms of functionality is that there is no longer the same list of interfaces as in the old one, so a condition needs to be added where SLE 15 selects the interfaces (or rather confirms selection) in a different way.

Apart from that, new needles are required for SLE 15, since the new UI also has graphical changes that do not affect the functionality.

#7 Updated by okurz about 4 years ago

This is an autogenerated message for openQA integration by the openqa_review script:

This bug is still referenced in a failing openQA test: media_upgrade_sled12sp3
https://openqa.suse.de/tests/1673360

#8 Updated by okurz about 4 years ago

This is an autogenerated message for openQA integration by the openqa_review script:

This bug is still referenced in a failing openQA test: scc_upgrade_sled12sp3
https://openqa.suse.de/tests/1673374

#9 Updated by mgriessmeier about 4 years ago

  • Subject changed from [functional][u] test fails in wireshark - adjustments needed in SLE15 due to new UI to [qam] test fails in wireshark - adjustments needed in SLE15 due to new UI
  • Due date deleted (2018-06-19)

#10 Updated by coolo about 4 years ago

you wrote 4 weeks ago you would be done in a week - what happened?

#11 Updated by okurz about 4 years ago

  • Target version changed from Milestone 17 to Milestone 17

#12 Updated by okurz almost 4 years ago

This is an autogenerated message for openQA integration by the openqa_review script:

This bug is still referenced in a failing openQA test: qam-allpatterns+addons
https://openqa.suse.de/tests/1802198

#13 Updated by vsvecova almost 4 years ago

  • % Done changed from 20 to 90

The wireshark test code has been adjusted due to changes to the UI in terms of menu structure, as some of the menu items have been changed, moved and/or removed due to massive redesign of the GUI.

Some changes in new UI include:

  • Button with list of interfaces removed
  • Interfaces can no longer be selected, deselected and managed via dedicated menu item
  • Settings can no longer be confirmed by the "Apply" button; changes are saved using the "OK" button

Currently, we have wireshark v~2.4 in SLE15 and v~2.2 in <SLE12-SP3. The newer version in SLE15 has a reworked QT-based GUI with changes in menu structure, while in SLE12 we still have the legacy GTK-based GUI.

According to wireshark release notes, the new QT-based user interface is set to become the default. Also, the legacy GTK-based interface is expected to be completely removed and unsupported in the near future. That's why I opted for checking the GUI version first, rather than using the SLE product version as a condition.

Test code PR: https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/5376
Needles: https://gitlab.suse.de/openqa/os-autoinst-needles-sles/merge_requests/886

Verification run:
SLE12-SP3: http://dreamyhamster.suse.cz/tests/140#step/wireshark/15
SLE15-GA: http://dreamyhamster.suse.cz/tests/145#step/wireshark/15

#14 Updated by okurz almost 4 years ago

This is an autogenerated message for openQA integration by the openqa_review script:

This bug is still referenced in a failing openQA test: gnome@64bit-smp
https://openqa.suse.de/tests/1850061

#16 Updated by vsvecova almost 4 years ago

  • Status changed from In Progress to Resolved
  • % Done changed from 90 to 100

Now that the fixes have been merged, the wireshark tests are passing nicely on both SLE15 and SLE12-SP3.
So far no failures in the last ~5 builds => marking the ticket as resolved.

SLE15: https://openqa.suse.de/tests/1857507#step/wireshark/42
SLE12-SP3: https://openqa.suse.de/tests/1857674#step/wireshark/53

Also available in: Atom PDF