Project

General

Profile

Actions

action #34015

closed

[functional][y][easy] yast2/vnc doesn't have rules for firewalld -> workaround for bsc#1088647

Added by dimstar almost 6 years ago. Updated almost 6 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Bugs in existing tests
Start date:
2018-03-29
Due date:
2018-05-08
% Done:

0%

Estimated time:
Difficulty:
easy

Description

Observation

openQA test in scenario opensuse-Tumbleweed-DVD-x86_64-yast2_ncurses@64bit fails in
yast2_vnc

Reproducible

Fails since (at least) Build 20171029

Expected result

SLE 15

Further details

Always latest result in this scenario: latest

The VNC test module records a softfailure, and then seems to expect a cleared screen. This needs to be evaluated if the test has wrong assumptions - or if yast would be supposed to clear the screen to black.


Related issues 2 (0 open2 closed)

Related to openQA Tests - action #30106: [sle][functional][sle15][yast][y][easy] yast2_vnc failed - update to current behaviourResolvedJERiveraMoya2018-01-102018-04-10

Actions
Related to openQA Tests - action #31375: [sle][functional][ipmi][u][hard] test fails in first_boot - VNC installation on SLE 15 failed because of various issues (ipmi worker, first_boot, boot_from_pxe, await_install)RejectedSLindoMansilla2018-02-05

Actions
Actions #1

Updated by okurz almost 6 years ago

  • Related to action #30106: [sle][functional][sle15][yast][y][easy] yast2_vnc failed - update to current behaviour added
Actions #2

Updated by okurz almost 6 years ago

  • Subject changed from yast2/vnc expects 'cleared screen' to [functional][y]yast2/vnc expects 'cleared screen'
  • Target version set to Milestone 16
Actions #3

Updated by okurz almost 6 years ago

  • Due date set to 2018-05-08
Actions #4

Updated by riafarov almost 6 years ago

  • Subject changed from [functional][y]yast2/vnc expects 'cleared screen' to [functional][y] yast2/vnc doesn't have rules for firewalld
  • Description updated (diff)
  • Status changed from New to Workable
Actions #5

Updated by riafarov almost 6 years ago

It looks like a bug actually, as tigervnc should contain service definition for firewalld and works fine for Leap15.

Actions #6

Updated by JERiveraMoya almost 6 years ago

  • Assignee set to JERiveraMoya

Checking if the issue for TW is part of https://bugzilla.suse.com/show_bug.cgi?id=1088647.

Actions #7

Updated by okurz almost 6 years ago

  • Subject changed from [functional][y] yast2/vnc doesn't have rules for firewalld to [functional][y][easy] yast2/vnc doesn't have rules for firewalld -> workaround for bsc#1088647
  • Difficulty set to easy
Actions #8

Updated by riafarov almost 6 years ago

Check how we do it for tests/console/yast2_nis.pm

Actions #9

Updated by JERiveraMoya almost 6 years ago

  • Status changed from Workable to In Progress

According with developer, it is just wait a little bit for the fix appears in next builds. The reason why we only see this in TW is because we are really installing xorg-x11 by code and this package installs dependency xorg-x11-Xvnc which is in charge to provide definition for service tigervnc and tigervnc-https in the firewall but there is a request about to reload firewall rules when the package is installed that is not present at the moment. In other product we don't see this because xorg-x11 is installed in installation time not in our test, so after rebooting the system and booting again the reload is not required. For instance, Leap recommends xorg-x11-Xvnc https://build.opensuse.org/package/view_file/openSUSE:Leap:15.0/patterns-base/patterns-base.spec?expand=1 but Tw not https://build.opensuse.org/package/view_file/system:install:head/patterns-base/patterns-base.spec?expand=1. Developer wants to create a bug about more specific information related with these control files.
Workaround is easy, I tested and in tw the problem dissapears if we reload the firewall after installing the package (just firewall-cmd --reload after doing the zypper in xorg-x11), but it is better to wait for the fix as it should arrive really soon.

Actions #10

Updated by SLindoMansilla almost 6 years ago

  • Related to action #31375: [sle][functional][ipmi][u][hard] test fails in first_boot - VNC installation on SLE 15 failed because of various issues (ipmi worker, first_boot, boot_from_pxe, await_install) added
Actions #11

Updated by JERiveraMoya almost 6 years ago

  • Status changed from In Progress to Feedback

Fixed by developers in OSD and O3 as expected. We still need to correct this workaround: https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/4963 to avoid this soft-failure to appear.

Actions #12

Updated by JERiveraMoya almost 6 years ago

  • Status changed from Feedback to In Progress

Verification runs in OSD/O3:
SLE 15
openSUSE Tumbleweed
openSUSE Leap 15.0

Actions #13

Updated by JERiveraMoya almost 6 years ago

  • Status changed from In Progress to Resolved
Actions

Also available in: Atom PDF