Project

General

Profile

action #32614

[opensuse][functional][u][systemd] systemd_testsuite fails, as it does not cope with the split of systemd-container

Added by dimstar almost 4 years ago. Updated over 3 years ago.

Status:
Resolved
Priority:
Normal
Category:
Bugs in existing tests
Start date:
2018-03-01
Due date:
2018-04-24
% Done:

0%

Estimated time:
Difficulty:

Description

Observation

systemd has split out the various container parts into systemd=container, which is an optional, by default not-installed package.
The test suite started by openQA though expects it to be present.
Seems like we should ensure to have it installed before running the test suite.

  • openQA test in scenario opensuse-Tumbleweed-DVD-x86_64-suse_patches-systemd_testsuite@64bit fails in systemd_testsuite

Reproducible

Acceptance criteria

  • AC: The test module systemd_testsuite passes or fail on a proper product bug.

Tasks

  1. Adapt the testsuite to require/install the systemd-container component DONE
  2. or fix the test module systemd_testsuite to install the package systemd-container for tumbleweed, Leap15 and SLE15. Canceled
  3. Handle the different urls for openSUSE Tumbleweed y openSUSE Leap
  4. Create a link of https://build.opensuse.org/package/show/devel:openSUSE:QA:Leap:15/systemd-v234-testsuite into https://build.suse.de/project/show/QA:SLE15

Further details

About using a proper project/repository to use, there is a discussion here: https://progress.opensuse.org/issues/32215


Related issues

Related to openQA Tests - coordination #34996: [qe-core][functional][opensuse][epic] test fails in systemd_testsuite - TEST-16-EXTEND-TIMEOUT works only when executed against systemd built in the same specfileRejected2018-06-25

Related to openQA Tests - action #35035: [functional][opensuse][u][fast] test fails in systemd_testsuite - syntax error reported by rule-checkerResolved2018-04-162018-05-08

Related to openQA Tests - action #35080: [qe-core][functional][qem] Enable the test suite for systemd on SLE12-SP4/5New2018-04-17

Related to openQA Tests - action #35143: [functional][sle][u][bsc#1090454] test fails in systemd_testsuite - The test suite tries to install missing x86 on aarch64, ppc64le and s390xResolved2018-04-182018-05-22

History

#1 Updated by dimstar almost 4 years ago

An alternative solution, instead of adjusting the openQA test code, would be for the -testsuite package to require systemd-container; this might be even cleaner (but since nothing of that is in the product, I can't call this a product bug, thus stays here).

Please coordinate with Thomas Blume about the solution, and about the project on OBS where those test suites shall live. Currently they are in a home: space

#2 Updated by SLindoMansilla almost 4 years ago

  • Description updated (diff)
  • Status changed from New to Workable

#4 Updated by SLindoMansilla almost 4 years ago

  • Subject changed from systemd_testsuite fails, as it does not cope with the split of systemd-container to [opensuse][functional][systemd] systemd_testsuite fails, as it does not cope with the split of systemd-container

#5 Updated by dimstar almost 4 years ago

Sergio,

We now have a project called devel:openSUSE:QA - where we can collect such things together. I can assign you maintainer rights on this prj if you want (imho, this should be owned by QA)

#6 Updated by SLindoMansilla almost 4 years ago

tblume fixes the systemd-testsuite to install the systemd-container package: https://build.opensuse.org/package/rdiff/home:tsaupe:testsuites/systemd-v234-testsuite?linkrev=base&rev=11

#10 Updated by okurz almost 4 years ago

  • Due date set to 2018-04-10
  • Target version set to Milestone 15

#11 Updated by okurz almost 4 years ago

  • Subject changed from [opensuse][functional][systemd] systemd_testsuite fails, as it does not cope with the split of systemd-container to [opensuse][functional][u][systemd] systemd_testsuite fails, as it does not cope with the split of systemd-container

#12 Updated by okurz almost 4 years ago

This is an autogenerated message for openQA integration by the openqa_review script:

This bug is still referenced in a failing openQA test: suse_patches-systemd_testsuite
https://openqa.opensuse.org/tests/644096

#13 Updated by SLindoMansilla almost 4 years ago

  • Description updated (diff)

The split of the systemd-nspawn module was also done for SLE 15: https://build.suse.de/package/view_file/SUSE:SLE-15:GA/systemd/systemd.spec?expand=1

#15 Updated by SLindoMansilla almost 4 years ago

  • Status changed from Workable to In Progress

#17 Updated by SLindoMansilla almost 4 years ago

Pending tasks:

#19 Updated by okurz almost 4 years ago

  • Due date changed from 2018-04-10 to 2018-04-24

#20 Updated by okurz almost 4 years ago

SLindoMansilla wrote:

  • Fix missing dependency systemd-container
    • For some reason the dependency is ignored, causing the test to fail trying to execute nspawn.

Found your flaw. You added the "Require" to the base package, that is systemd itself. systemd-v234-testsuite is a subpackage so you have to put the Require there. Patch:

$ osc diff
Index: systemd-v234-testsuite.spec
===================================================================
--- systemd-v234-testsuite.spec (revision 45efb95fc34b593ec7ed380437a085bd)
+++ systemd-v234-testsuite.spec (working copy)
@@ -120,7 +120,6 @@
 Requires:       udev = %{version}-%{release}
 Requires:       util-linux >= 2.27.1
 Requires:       group(lock)
-Requires:       systemd-container
 Recommends:     %{name}-bash-completion
 Requires(post): coreutils
 Requires(post): findutils
@@ -419,6 +418,7 @@
 Summary:        Test suite for QA
 License:        LGPL-2.1+
 Group:          System/Benchmark
+Requires:       systemd-container

 %description v%{version}-testsuite
 This provides the system testsuite scripts and binaries for QA

-> https://build.suse.de/request/show/161525

I will leave the synchronisation with openSUSE to you but I strongly suggest to come up with an automatic approach. Also I think it's a good idea to disable the build on all unsupported repositories.

#21 Updated by SLindoMansilla almost 4 years ago

I applied your patch. Now I have a versioning problem due to the _service file. Fixing it.

#22 Updated by okurz almost 4 years ago

what is a "versioning problem"?

#23 Updated by SLindoMansilla almost 4 years ago

The hash of the build was included in the namespace of the package, so instead of systemd-v238-testsuite, it was systemd-v238.suse.20180328.g14b3e00c3-3.1.x86_64.rpm.

I had problems trying to remove the hash, set on _service, so I decided to make the package name version independent: https://build.opensuse.org/request/show/595918

#26 Updated by SLindoMansilla almost 4 years ago

  • Related to coordination #34996: [qe-core][functional][opensuse][epic] test fails in systemd_testsuite - TEST-16-EXTEND-TIMEOUT works only when executed against systemd built in the same specfile added

#29 Updated by SLindoMansilla almost 4 years ago

  • Related to action #35035: [functional][opensuse][u][fast] test fails in systemd_testsuite - syntax error reported by rule-checker added

#30 Updated by SLindoMansilla almost 4 years ago

Fix for systemd-container on Leap15 verified on O3: https://openqa.opensuse.org/tests/657011#step/systemd_testsuite/20

#31 Updated by SLindoMansilla almost 4 years ago

  • Related to action #35080: [qe-core][functional][qem] Enable the test suite for systemd on SLE12-SP4/5 added

#32 Updated by SLindoMansilla almost 4 years ago

  • Description updated (diff)

Next steps in description.

#34 Updated by SLindoMansilla almost 4 years ago

  • Status changed from In Progress to Resolved

#36 Updated by oorlov almost 4 years ago

  • Related to action #35143: [functional][sle][u][bsc#1090454] test fails in systemd_testsuite - The test suite tries to install missing x86 on aarch64, ppc64le and s390x added

#37 Updated by lnussel over 3 years ago

any update in this? it keeps failing in leap 15

#38 Updated by SLindoMansilla over 3 years ago

Yes, this problem is solved. Now, it was failing because a bug on the syntax rule checker.
I have tried to updated the package on OBS, but it fails building, I am working to fix it on: https://progress.opensuse.org/issues/35035#note-7

Also available in: Atom PDF