Project

General

Profile

Actions

action #29986

closed

[functional][u][opensuse][hard]test fails in multi_users_dm

Added by lnussel over 6 years ago. Updated about 6 years ago.

Status:
Resolved
Priority:
High
Assignee:
Category:
Bugs in existing tests
Start date:
2018-01-04
Due date:
2018-04-24
% Done:

0%

Estimated time:
Difficulty:
hard

Description

Observation

openQA test in scenario opensuse-15.0-DVD-x86_64-extra_tests_on_gnome@64bit fails in
multi_users_dm

Looks like it doesn't actually log in user1 but rather tries to log in bernhard.

Reproducible

Fails since (at least) Build 57.1

Expected result

Last good: We can not find any (best we ever saw was with gnome: https://openqa.opensuse.org/tests/488943#step/multi_users_dm/14)

It must have been working at least once locally on dheidler's workstation.

Suggestions

Bug is still open and will not be fixed within that timeframe so make sure that the test passes or soft-fails with workaround.

Further details

Always latest result in this scenario: latest


Related issues 4 (0 open4 closed)

Related to qe-yam - coordination #9536: Test all DMs for working encrypted home supportResolvedJERiveraMoya2020-05-05

Actions
Related to openQA Tests - action #9694: Many users dm testingResolveddheidler2015-11-26

Actions
Related to openQA Tests - action #36088: [opensuse][functional][u] test fails in multi_users_dm - user1 does not loginResolveddheidler2018-05-11

Actions
Has duplicate openQA Tests - action #34306: test fails in multi_users_dmRejectedokurz2018-04-052018-04-12

Actions
Actions #1

Updated by okurz about 6 years ago

  • Subject changed from test fails in multi_users_dm to [functional][opensuse]test fails in multi_users_dm
  • Due date set to 2018-04-10
  • Target version set to Milestone 15
Actions #2

Updated by riafarov about 6 years ago

Check if blocked by https://bugzilla.opensuse.org/show_bug.cgi?id=1063060 in latest run we still have systemctl isolate command running.

Actions #3

Updated by okurz about 6 years ago

Actions #4

Updated by okurz about 6 years ago

Actions #5

Updated by okurz about 6 years ago

  • Subject changed from [functional][opensuse]test fails in multi_users_dm to [functional][u][opensuse]test fails in multi_users_dm
  • Description updated (diff)
  • Status changed from New to Workable

Bug is still open and will not be fixed within that timeframe so make sure that the test passes or soft-fails with workaround.

Actions #6

Updated by riafarov about 6 years ago

  • Description updated (diff)
Actions #7

Updated by okurz about 6 years ago

  • Subject changed from [functional][u][opensuse]test fails in multi_users_dm to [functional][u][opensuse][hard]test fails in multi_users_dm
  • Due date changed from 2018-04-10 to 2018-04-24
  • Priority changed from Normal to High
  • Difficulty set to hard
Actions #8

Updated by okurz about 6 years ago

  • Has duplicate action #34306: test fails in multi_users_dm added
Actions #9

Updated by okurz about 6 years ago

Comment from lnussel in duplicate #34306:

openQA test in scenario opensuse-15.0-DVD-x86_64-extra_tests_on_gnome@64bit fails in
multi_users_dm

This test is broken since forever with reference to bug 1063060

We need some other solution as the test is important. Maybe just reboot?

Actions #10

Updated by dheidler about 6 years ago

This will help a bit, but it will still fail later:

See http://artemis.suse.de/tests/148

diff --git a/tests/x11/multi_users_dm.pm b/tests/x11/multi_users_dm.pm
index 6a0ae8a6..e0f5b28c 100644
--- a/tests/x11/multi_users_dm.pm
+++ b/tests/x11/multi_users_dm.pm

@@ -21,6 +21,9 @@ use utils;
 sub ensure_multi_user_target {
     type_string "systemctl isolate multi-user.target\n";
+    wait_still_screen 5;
+    send_key "ctrl-alt-f".get_root_console_tty;
+    send_key "ctrl-c";
 reset_consoles;
 wait_still_screen 10;
 # isolating multi-user.target logs us out
Actions #11

Updated by dheidler about 6 years ago

  • Status changed from Workable to In Progress
  • Assignee set to dheidler
Actions #16

Updated by zluo about 6 years ago

I found there is an issue for Leap, opensuse-15.0-DVD-x86_64-Build241.1-extra_tests_on_kde@64bit failed:

https://openqa.opensuse.org/tests/672245#step/multi_users_dm

Actions #17

Updated by zluo about 6 years ago

  • Status changed from Resolved to Feedback
  • Target version changed from Milestone 15 to Milestone 16

@dheidler can you check if this is same issue? I'm not sure about this, thanks!

Actions #18

Updated by mloviska about 6 years ago

  • Related to action #36088: [opensuse][functional][u] test fails in multi_users_dm - user1 does not login added
Actions #19

Updated by dheidler about 6 years ago

  • Status changed from Feedback to Resolved

The new bug will be tracked in the new issue

Actions

Also available in: Atom PDF