Project

General

Profile

action #25722

[migration] a simple installation with SMT

Added by maritawerner over 2 years ago. Updated about 2 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
New test
Start date:
2017-10-02
Due date:
% Done:

100%

Estimated time:
Difficulty:
Duration:

Description

Installations are tested with SCC/proxySCC. To make sure that SMT also works fine we have to do 1 simple installation with an SMT.


Related issues

Related to openQA Tests - action #23564: [sle][functional][smt][y][medium] smt test for SLE15 does not do anything with SMT (was: fails in addon_products_sle - need to adapt workflow for SMT scenario)Workable2017-08-23

Related to openQA Tests - action #26966: [sle][functional][smt][sle15] test suite "smt" hardcodes SCC_REGURL pointing to Server -> need to adaptResolved2017-10-23

History

#1 Updated by maritawerner over 2 years ago

  • Description updated (diff)

#2 Updated by okurz over 2 years ago

  • Category set to New test

#3 Updated by okurz over 2 years ago

  • Assignee set to maritawerner
  • Target version set to Milestone 14

maritawerner can you help to answer some questions:

  1. are there any existing automated tests next to the openQA smt scenario testing SMT within QA SLE?
  2. How is this related to RMT testing?
  3. Where can we find more written documentation?
  4. Who can provide more help on demand if necessary?
  5. Is there a written specification what we should expect?

#4 Updated by maritawerner over 2 years ago

Q1: No. In Testopia there are very very old manual tests for the SMT itself but they are obsolete. Besides that only registration/migration against SMT was tested manually for SLE 12 SP 1/2/3.
Q2: The existing SMT will exist in parallel with the new RMT. RMT will come end of the year and will be tested by the SCC team together with QA APACI.
Q3: About SMT? Maybe in the documentation for SLES.
Q3: Jiri Srain. He used to be the PJM for SMT. For the new RMT it is Artem. And Sunny is already in close contact with him.
Q4: as far as I know only the PRD. I will check Fate as well.

#5 Updated by maritawerner over 2 years ago

Update: there are no relevant features for instalaltion with SMT in Fate.

#6 Updated by maritawerner over 2 years ago

Team APACI has added a manual Testcase about SMT to Testopia:
https://bugzilla.suse.com/tr_show_case.cgi?case_id=1621542
Let me double check what they plan here.

#7 Updated by okurz over 2 years ago

  • Related to action #23564: [sle][functional][smt][y][medium] smt test for SLE15 does not do anything with SMT (was: fails in addon_products_sle - need to adapt workflow for SMT scenario) added

#8 Updated by okurz over 2 years ago

  • Related to action #26966: [sle][functional][smt][sle15] test suite "smt" hardcodes SCC_REGURL pointing to Server -> need to adapt added

#9 Updated by okurz over 2 years ago

More questions:

  1. Is it supported to install and run the application "SMT" on SLE15 or only for SLE15?

#10 Updated by sebchlad over 2 years ago

maritawerner: OK, so it is the item which you have mentioned to me today (24.10.2017).

What I understood today from our conversation is that you are planning to talk to Sunny in order to see if this is the job for QA SLE Functional team, or perhaps Sunny's team is planning to do it. Correct?

#11 Updated by maritawerner over 2 years ago

Yes

#12 Updated by JWSun over 2 years ago

maritawerner wrote:

Team APACI has added a manual Testcase about SMT to Testopia:
https://bugzilla.suse.com/tr_show_case.cgi?case_id=1621542
Let me double check what they plan here.

Hi maritawerner,
This case is wirrten by me, I would like explain it. We are focus on testing the function of SMT server, "Register SLE Product via SMT" it means install SMT pattern on the latest SLE 15 product and use it as SMT server. And then register SLE product (SLES15 or SLES12 SPx) via this SMT server.
I think this "a simple installation with SMT" could be tested as a part of our SMT test, and I would like to take POO and try adapt SLE installation workflow for SMT.

#13 Updated by maritawerner over 2 years ago

Hello JWSun,
thanks for the explanation. Let me explain my expectations a litle bit. SMT is atm only available on SLES 12 and that is what customers have. So whenever you test against SMT, might it be installation or migration, you have to install The SMT on SLES 12. On SLES 15 we will have the new product RMT but that is a different story.

So for SLES 15 we have to do an installation test with SMT and this Testcase has to be implemented in openQA and run with every build validation. And I think the correct area for that is the SLE functional job group. So if you want to do that task please sync with Oliver Kurz the coordinator of the SLE functional group. Let me know if you have got any questions.

#14 Updated by maritawerner over 2 years ago

  • Assignee deleted (maritawerner)

#15 Updated by JWSun over 2 years ago

Hi maritawerner, Thanks for explanation. It will great helpful to clarify our test scope.

Please double confirm follow test scenarios in case any misunderstand.
As a application or pattern

  • SMT pattern is only support for SLES12, we don't have SMT pattern for SLES15.

As a register Server (Same as SCC)

  • Install and register SLES15 product via SMT server (SLE functional job group)
  • Migration SLES12 to SLES15 via SMT server (SLE migration job group)

#16 Updated by JWSun over 2 years ago

Submit PR#3825 for installation with SMT case.

#17 Updated by mitiao over 2 years ago

  • Assignee set to JWSun

#18 Updated by JWSun over 2 years ago

  • Status changed from New to In Progress

#19 Updated by sebchlad over 2 years ago

  • Subject changed from [sle][functional]a simple installation with SMT to [migration]a simple installation with SMT

As discussed with Sunny and confirmed over an email (Date: Mon, 30 Oct 2017 08:24:23 +0800). As Sunny explains and decides:
"Register SLE15 via SMT is one of functions that we plan to cover
in SLE15 as SMT testing, so we are actively taking look at
#25722 in progress"

Therefore I removing tag "sle" and "functional" as this is not in QA SLE Functional team's backlog. Adding string "migration"

#20 Updated by sebchlad over 2 years ago

  • Subject changed from [migration]a simple installation with SMT to [migration] a simple installation with SMT

#21 Updated by JWSun over 2 years ago

  • Status changed from In Progress to Resolved

Resolved by PR#3825

#22 Updated by maritawerner over 2 years ago

  • Status changed from Resolved to In Progress

Hello Jiawi,

were can I find that test in openQA. Could you please add a link to that progress ticket? THX

#23 Updated by JWSun over 2 years ago

maritawerner wrote:

Hello Jiawi,

were can I find that test in openQA. Could you please add a link to that progress ticket? THX

Hello Marita,

Because of our SMT server in Nuremberg is down, I haven't add this case to O.S.D.
whdu have submitted an IT ticket for the SMT server, he is following up the server status. After our SMT server is back, I will add the SMT install case to OpenQA.

#24 Updated by maritawerner over 2 years ago

Thanks for the update. Just FYI we have bug

Some SLE15 Modules can't be enabled on SCC Alpha Key organisation (using SMT)
https://bugzilla.suse.com/show_bug.cgi?id=1072913

Could we cover that in the Testsuite as well?

#25 Updated by maritawerner over 2 years ago

Update from Fcrozat: bug is fixed now, installation of SLED with SMT is possible now

#26 Updated by fcrozat over 2 years ago

maritawerner wrote:

Update from Fcrozat: bug is fixed now, installation of SLED with SMT is possible now

To be more precise: it works when installing SLES or SLED.

BUT you must be running SMT >= 3.0.31, which supports SLE 15 "module tree", from https://build.suse.de/package/show/Devel:SMT:SLE-12-SMT/smt . There is a maintenance update for it in progress https://maintenance.suse.de/incident/5815 which should be release early January.

#27 Updated by JWSun over 2 years ago

  • Status changed from In Progress to Resolved
  • % Done changed from 0 to 100

SMT installation case in functional job group
https://openqa.suse.de/tests/1349037

#28 Updated by nicksinger over 2 years ago

  • Status changed from Resolved to In Progress

please make sure to run this test only against a SMT server >= 3.0.31 either by

  • using the SMT from Asia (if the speed is sufficient) OR
  • upgrade migration-smt.qa.suse.de

otherwise we cannot make use of the pre-selected modules and hit this problem: https://openqa.suse.de/tests/1404146#step/scc_registration/8

#29 Updated by okurz about 2 years ago

  • Target version changed from Milestone 14 to Milestone 16

@JWSun did you see the latest comment by nicksinger?

#30 Updated by JWSun about 2 years ago

  • Status changed from In Progress to Resolved

okurz wrote:

@JWSun did you see the latest comment by nicksinger?

Yes, this SMT server has already been updated to the latest version, I think this issue can been marked as resolved.

Verify result on OSD
https://openqa.suse.de/tests/1657058
https://openqa.suse.de/tests/1655572
https://openqa.suse.de/tests/1653669
https://openqa.suse.de/tests/1646616

Also available in: Atom PDF