Project

General

Profile

action #25676

[sle][functional][sle15][medium] test fails in yast2_lan_restart because of "SuSEfirewall2" popup, blocking next tests

Added by okurz about 4 years ago. Updated almost 4 years ago.

Status:
Resolved
Priority:
High
Assignee:
Category:
Bugs in existing tests
Start date:
2017-09-29
Due date:
2017-12-19
% Done:

0%

Estimated time:
Difficulty:

Description

Observation

openQA test in scenario sle-15-Leanos-DVD-x86_64-extra_tests_on_gnome@64bit fails in
yast2_lan_restart

Reproducible

Fails since (at least) Build 173.8

Expected result

Last good: Compare to openSUSE Tumbleweed

Further details

Always latest result in this scenario: latest


Related issues

Related to openQA Tests - action #26998: [sle][functional][sle15][medium][bsc#1072659] handle suse firewall popup as we did for ncursesResolved2018-02-082018-02-13

Related to openQA Tests - action #28501: [qam][sle][functional][sle15] yast2_lan_restart.pm - ! -s journal.log seems not workingResolved2017-11-28

Related to openQA Tests - action #28666: [sle][functional][sle15] re-work and split yast2_lan_restart.pm into smaller testsResolved2017-11-302018-01-30

Related to openQA Tests - action #25684: [opensuse][functional][tools][yast][y][sporadic]test fails in yast2_lan_restart to upload log because of mistypingResolved2017-09-292018-04-10

Blocks openQA Tests - action #28663: [sle][functional][easy] adapt yast2_lan_restart for SLE15Resolved2017-11-302018-01-16

History

#1 Updated by okurz about 4 years ago

  • Related to action #26998: [sle][functional][sle15][medium][bsc#1072659] handle suse firewall popup as we did for ncurses added

#2 Updated by okurz about 4 years ago

  • Target version set to Milestone 12

#3 Updated by sebchlad about 4 years ago

  • Due date set to 2017-12-06

#4 Updated by zluo about 4 years ago

  • Assignee set to zluo

I think actually susefirewall2 should be easily to handle as softfail. Then let's see the workflow is not going break without firwirewall2.

#5 Updated by zluo about 4 years ago

  • Status changed from New to In Progress

#6 Updated by zluo about 4 years ago

  • Subject changed from [sle][functional][sle15]test fails in yast2_lan_restart because of "SuSEfirewall2" popup, blocking next tests to [sle][functional][sle15][easy] test fails in yast2_lan_restart because of "SuSEfirewall2" popup, blocking next tests

#7 Updated by zluo about 4 years ago

checked the current test on osd:

http://openqa.suse.de/tests/1269155#step/yast2_lan_restart/16

We have a another problem now before the pop for susefirewall2.

#8 Updated by zluo about 4 years ago

  • Subject changed from [sle][functional][sle15][easy] test fails in yast2_lan_restart because of "SuSEfirewall2" popup, blocking next tests to [sle][functional][sle15][medium] test fails in yast2_lan_restart because of "SuSEfirewall2" popup, blocking next tests

at first to fix the problem before susefirewall shows up.

yast2_lan_restart-yast2_lan-20171127 created for now.

#9 Updated by zluo about 4 years ago

https://openqa.suse.de/tests/1274792/modules/yast2_lan_restart/steps/29

it shows a warning about "firewall is active, but this interface is not in any zone" which is new. This requires a change in test code...

#10 Updated by zluo almost 4 years ago

the old issue is gone and I even fix the pop up for firewall activation as well.

So this issue is resolved. but I need to work further issue remained.

#13 Updated by zluo almost 4 years ago

  • Related to action #28501: [qam][sle][functional][sle15] yast2_lan_restart.pm - ! -s journal.log seems not working added

#14 Updated by zluo almost 4 years ago

  • Related to action #28666: [sle][functional][sle15] re-work and split yast2_lan_restart.pm into smaller tests added

#15 Updated by jorauch almost 4 years ago

  • Related to action #25684: [opensuse][functional][tools][yast][y][sporadic]test fails in yast2_lan_restart to upload log because of mistyping added

#16 Updated by okurz almost 4 years ago

  • Blocks action #28663: [sle][functional][easy] adapt yast2_lan_restart for SLE15 added

#17 Updated by okurz almost 4 years ago

  • Due date changed from 2017-12-06 to 2017-12-19

SR: move to next sprint suggested

#20 Updated by zluo almost 4 years ago

  • Status changed from In Progress to Resolved

Also available in: Atom PDF