Project

General

Profile

action #19486

[qam][sle][functional][s390] test fails in install_update -> consoletest_setup types password to early

Added by pcervinka over 4 years ago. Updated over 4 years ago.

Status:
Resolved
Priority:
Urgent
Assignee:
Category:
Bugs in existing tests
Target version:
-
Start date:
2017-06-01
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

Observation

openQA test in scenario sle-12-SP2-Server-DVD-Incidents-s390x-qam-minimal@s390x-zVM-hsi-l3 fails in
install_update

Reproducible

Fails since (at least) Build :133414.nss_ldap.3124

Expected result

Last good: :133372.strongswan.4884 (or more recent)

Further details

Always latest result in this scenario: latest


Related issues

Has duplicate openQA Tests - action #19530: [s390][functional] consoletest_setup types password to earlyRejected2017-06-02

Has duplicate openQA Tests - action #19584: test fails in consoletest_setup by typing root passowrd failedRejected2017-06-05

History

#1 Updated by dzedro over 4 years ago

  • Priority changed from Normal to Urgent

#2 Updated by dzedro over 4 years ago

  • Subject changed from [qam] test fails in install_update to [qam][sle][functional] test fails in install_update

Also sle functional tests are failing on changing console e.g. https://openqa.suse.de/tests/972576#step/logpackages/3

#3 Updated by mgriessmeier over 4 years ago

  • Assignee set to mgriessmeier

I'm taking this ticket - since I already worked on some console login fixes yesterday and I am working on these fallouts right now

#4 Updated by mgriessmeier over 4 years ago

  • Status changed from New to In Progress

PR in the queue (still WIP)
probably mergeable on tuesday

https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/2997

#5 Updated by okurz over 4 years ago

  • Assignee changed from mgriessmeier to okurz

PR merged. I think it helps for zvm but still not done for zkvm. I moved the "handle_password_prompt" to before the SU, see https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/2997/files#diff-a2a433d5914343b617ae52ac0fb40524R409. But this seems to be not enough, see http://lord.arch/tests/6494#step/consoletest_setup/3 and http://lord.arch/tests/6494/file/autoinst-log.txt . The password string is sent but seems to have no effect. Maybe the original sleep is still needed here or a better way needs to be found, checking on zkvm.

#6 Updated by okurz over 4 years ago

http://lord.arch/tests/6496#step/consoletest_setup/3 shows that the password is typed twice now but it works. Investigating.

#7 Updated by okurz over 4 years ago

  • Has duplicate action #19530: [s390][functional] consoletest_setup types password to early added

#8 Updated by okurz over 4 years ago

  • Subject changed from [qam][sle][functional] test fails in install_update to [qam][sle][functional][s390] test fails in install_update -> consoletest_setup types password to early

#10 Updated by mgriessmeier over 4 years ago

  • Status changed from In Progress to Feedback

PR merged - setting to feedback until it can be verified on o.s.d

#11 Updated by asmorodskyi over 4 years ago

  • Status changed from Feedback to In Progress

#12 Updated by okurz over 4 years ago

  • Has duplicate action #19584: test fails in consoletest_setup by typing root passowrd failed added

#13 Updated by okurz over 4 years ago

  • Status changed from In Progress to Feedback

#14 Updated by okurz over 4 years ago

  • Status changed from Feedback to Resolved

considered done. I did not find any other failure in recent build 0418.

Also available in: Atom PDF