Project

General

Profile

action #19530

[s390][functional] consoletest_setup types password to early

Added by nicksinger over 4 years ago. Updated over 4 years ago.

Status:
Rejected
Priority:
High
Assignee:
Category:
Bugs in existing tests
Target version:
-
Start date:
2017-06-02
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

Observation

Several consoletest_setup modules fail because openQA is unable to login into the system.
Examples are:
http://openqa.suse.de/tests/975862#step/consoletest_setup/34
http://openqa.suse.de/tests/975843#step/consoletest_setup/34
http://openqa.suse.de/tests/975829#step/consoletest_setup/34
http://openqa.suse.de/tests/975853#step/consoletest_setup/34
http://openqa.suse.de/tests/975858#step/consoletest_setup/34

There you can always see part of the password before the actual password prompt appears.

Reproducible

Fails since (at least) Build 0406 most likely because some recent changes coolo introduced to the existing login-code.
Workaround/Fix was introduced by mgriessmeier but seems to rely too much on system performance.
Maybe an assert_screen for the PW-prompt before typing the password can fix that problem

Expected result

openQA should wait to type the password until the password prompt appears.
Last good: 0405 (or more recent)

Further details

Always latest result in this scenario: latest


Related issues

Is duplicate of openQA Tests - action #19486: [qam][sle][functional][s390] test fails in install_update -> consoletest_setup types password to earlyResolved2017-06-01

History

#1 Updated by okurz over 4 years ago

  • Is duplicate of action #19486: [qam][sle][functional][s390] test fails in install_update -> consoletest_setup types password to early added

#2 Updated by mgriessmeier over 4 years ago

  • Status changed from New to Feedback
  • Assignee set to mgriessmeier

should be fixed with https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/3019
setting to feedback

Well... If you would have commented with your PR in this ticket, I would have seen it ;)
closing mine then

-> https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/3012

#3 Updated by asmorodskyi over 4 years ago

  • Status changed from Feedback to Rejected

Also available in: Atom PDF