Project

General

Profile

action #17596

[userspace][qam] test fails to reach external mail server in evolution_meeting_pop sometimes -> use local server

Added by osukup about 5 years ago. Updated almost 5 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Enhancement to existing tests
Target version:
-
Start date:
2017-03-08
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

Observation

openQA test in scenario sle-12-SP2-Desktop-DVD-Updates-x86_64-qam-regression-message@64bit fails in
evolution_meeting_pop

Reproducible

Fails since (at least) Build 20170308-2

Expected result

Last good: 20170308-1 (or more recent), this fails very often randomly in same step

Further details

Always latest result in this scenario: latest


Related issues

Related to openQA Tests - action #15134: [sle][x11regressions][qam]test fails many times in evolution_meeting_pop/imap (unreliable)Resolved2016-11-30

Related to openQA Tests - action #18266: [qam][x11regressions] test fails in evolution_mail_*Resolved2017-04-03

Related to openQA Tests - action #19320: [qam] test fails in evolution_mail_imapResolved2017-05-23

History

#1 Updated by osukup about 5 years ago

problem is probably caused by used mail (pop) server in china

my ping to this ip addres:

40 packets transmitted, 40 received, 0% packet loss, time 39039ms
rtt min/avg/max/mdev = 308.577/318.424/544.494/38.269 ms

so -> bigger timeout before try to search delivered message, or use another server. ( maybe configure local service in sut before test ?)

#2 Updated by okurz about 5 years ago

  • Subject changed from test fails in evolution_meeting_pop to [userspace][qam] test fails to reach external mail server in evolution_meeting_pop sometimes -> use local server
  • Category changed from Bugs in existing tests to Enhancement to existing tests

a local server which is part of the openQA infrastructure itself would be preferrable. I assume a valid workaround is retriggering although this might be done from within the test module and using an email server local to the openQA test would be beneficial.

#3 Updated by okurz about 5 years ago

This is an autogenerated message for openQA integration by the openqa_review script:

This bug is still referenced in a failing openQA test: qam-regression-message
https://openqa.suse.de/tests/846726

#4 Updated by pluskalm about 5 years ago

  • Assignee set to vsvecova

#5 Updated by vsvecova almost 5 years ago

  • Related to action #15134: [sle][x11regressions][qam]test fails many times in evolution_meeting_pop/imap (unreliable) added

#6 Updated by vsvecova almost 5 years ago

  • Related to action #18266: [qam][x11regressions] test fails in evolution_mail_* added

#7 Updated by vsvecova almost 5 years ago

  • Related to action #19320: [qam] test fails in evolution_mail_imap added

#8 Updated by vsvecova almost 5 years ago

  • Status changed from New to In Progress

I have identified 3 other issues with similar or identical underlying cause and listed them as related tasks.

I also contacted qkzhu, who is assigned on two of these issues, to sync with him about our progress, in order to avoid duplicating work.

#9 Updated by vsvecova almost 5 years ago

  • Assignee changed from vsvecova to pcervinka

Reassigning to Petr Cervinka, as discussed with Martin Pluskal.

#10 Updated by pcervinka almost 5 years ago

  • Status changed from In Progress to Resolved

Resolved in #19320.

Also available in: Atom PDF