Project

General

Profile

action #17116

[tools]Needle editor displays black screen

Added by zluo over 5 years ago. Updated almost 5 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Support
Target version:
-
Start date:
2017-02-16
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

enter interactive mode and click on scissor to create a new needle.
I got in most case a black screen. Go back and click it again, then it shows correct content in most cases.

Firefox 51.0.1


Related issues

Related to openQA Project - action #17662: [tools]webUI does not load thumbnails for test details in time or at allResolved2017-03-10

Related to openQA Tests - action #20378: [tools]Too many 502 on openqaResolved2017-07-18

History

#1 Updated by okurz over 5 years ago

  • Project changed from openQA Tests to openQA Project
  • Category set to Support
  • Status changed from New to Rejected

I assume some kind of intermittent issue. should be solved by now. if not, please reopen if necessary

#2 Updated by okurz over 5 years ago

  • Status changed from Rejected to New

zluo reported that it still appears.

#3 Updated by okurz over 5 years ago

sorry, I totally misread. Somehow I assumed this would be a very old ticket but it was actually a very new one :-D

#4 Updated by michalnowak over 5 years ago

I saw this as well on my instance, all I had to do was to wait for optipng processes to finish (or at least for the one processing the image I was waiting for) and refresh the page/needle editor.

#5 Updated by zluo over 5 years ago

What I got in Firefox developer console:

GET
http://localhost/tests/1916/images/yast2_control_center-115.png [HTTP/1.1 404 Not Found 19ms]

#6 Updated by zluo over 5 years ago

localhost -> e13.suse.de

#7 Updated by michalnowak over 5 years ago

  • Related to action #17662: [tools]webUI does not load thumbnails for test details in time or at all added

#8 Updated by mkittler over 5 years ago

  • Assignee set to mkittler

#9 Updated by mkittler over 5 years ago

  • Description updated (diff)

I can reproduce two different issues:

  1. Sometimes there is a very long delay. This might lead to a timeout. In this case reloading the page helps of course.

long delay

But maybe it is just because the machine was very busy at that moment.

  1. Sometimes the generated image is just black. In this case reloading doesn't help of course. Looks like a bug in the backend. Maybe the screenshot was taken when qemu has already been stopped.

#10 Updated by RBrownSUSE over 5 years ago

  • Subject changed from Needle editor displays black screen to [tools][dashboard]Needle editor displays black screen

#11 Updated by coolo over 5 years ago

interactive mode is dashboard too? I guess you better define what dashboard is not

#12 Updated by okurz over 5 years ago

  • Subject changed from [tools][dashboard]Needle editor displays black screen to [tools]Needle editor displays black screen

well, this is not :-)

#13 Updated by mkittler about 5 years ago

  • Subject changed from [tools]Needle editor displays black screen to [tools]Needle editor displays black screen

I already stated that there are actually 2 different issues. This comment is about the 2nd one.

The black screenshot might be caused by the stall handing turning the screen black: https://github.com/os-autoinst/os-autoinst/blob/master/consoles/VNC.pm#L834

To verify this, I could try to turn the screen to another color (eg. red) in this case. If the needle editor then shows a red screen, we know where it comes from.

#14 Updated by okurz about 5 years ago

good idea. just patch zluo's machine and let him test that.

#15 Updated by okurz about 5 years ago

  • Status changed from New to In Progress

#16 Updated by mkittler about 5 years ago

I suppose changing the color isn't that easy. But the change https://github.com/os-autoinst/os-autoinst/commit/85e7ee7baef472c4771641e7d5a51da8278b0c34 by coolo might fix the 2nd issue. So you can update os-autoinst and check whether the issue still occurs.

BTW: I guess the comment # return black image - screen turned off should be removed.

EDIT: It seems like the 2nd issue actually doesn't occur anymore. Since the issue only occurred sometimes, further testing is required to be sure.

#17 Updated by mkittler about 5 years ago

The 2nd issue couldn't be reproduced anymore so I assume it is actually gone.

The first issue could be improved by reloading automatically and displaying a loading indication might be useful as well.

#18 Updated by favogt almost 5 years ago

I hit this issue all the time, it's actually worse on a test machine I've got here (16GiB RAM, Intel Xeon E5-1620 (2x4 threads)) and it takes well over a minute sometimes until the .png is available.

#19 Updated by EDiGiacinto almost 5 years ago

#20 Updated by EDiGiacinto almost 5 years ago

  • Status changed from In Progress to Resolved
  • Assignee changed from mkittler to EDiGiacinto

Closing this bug since it might be related to #20378 which is now solved. Please re-open if problem still persist - in case it is persisting and the bug had attachments (such logs, screens, ecc.) please provide new ones.

Also available in: Atom PDF