Project

General

Profile

action #17662

[tools]webUI does not load thumbnails for test details in time or at all

Added by zluo over 5 years ago. Updated almost 5 years ago.

Status:
Resolved
Priority:
Low
Assignee:
Category:
Feature requests
Target version:
-
Start date:
2017-03-10
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

observation

If one test module failed and a following test module is running I check details for failed test and I find some thumbnails do not show up correctly.
Please attached screenshot.

workaround

reload page

openqa.png (77.3 KB) openqa.png zluo, 2017-03-10 13:41
2956

Related issues

Related to openQA Project - action #17116: [tools]Needle editor displays black screenResolved2017-02-16

Related to openQA Tests - action #20378: [tools]Too many 502 on openqaResolved2017-07-18

History

#1 Updated by zluo over 5 years ago

#2 Updated by michalnowak over 5 years ago

  • Related to action #17116: [tools]Needle editor displays black screen added

#3 Updated by michalnowak over 5 years ago

zluo wrote:

in Browser Console I got following:
GET
http://localhost/tests/1999/images/thumb/yast2_control_center-10.png [HTTP/1.1 404 Not Found 15ms]

I think the images are yet to be generated by optipng. See if the optipng process is running at that time and just wait for all of those processes to finish.

#4 Updated by zluo over 5 years ago

This issue is quite annoying and bad for needle editor. If someone can be assigned for this, that will help a lot.

#5 Updated by mkittler over 5 years ago

Possible solutions:

  1. Trigger reload via JavaScript in case of 404 error.
  2. Ensure everything is available before providing the links.

I guess the second option would be better. In any case it makes sense to handle the case of a 404 error so the layout isn't messed.

#6 Updated by RBrownSUSE over 5 years ago

  • Project changed from openQA Tests to openQA Project
  • Subject changed from openQA WebUI doesn't show thumbnails for test details correctly to [tools]openQA WebUI doesn't show thumbnails for test details correctly

#7 Updated by okurz over 5 years ago

  • Category set to Concrete Bugs

#8 Updated by mkittler over 5 years ago

Solution 1. is already implemented. It just doesn't seem to work in all cases, though. For sure the current implementation will not reload the picture if it is not available within 21 seconds so such a long delay might be the reason for this issue.

I guess it would be better to implement 2. then. The only this blocking me is that I currently don't know how the screenshot upload works under the hood.

#9 Updated by okurz about 5 years ago

  • Subject changed from [tools]openQA WebUI doesn't show thumbnails for test details correctly to [tools]webUI does not load thumbnails for test details in time or at all
  • Description updated (diff)
  • Category changed from Concrete Bugs to 124
  • Status changed from New to In Progress
  • Priority changed from Normal to Low

Ensure everything is available before providing the links.

what do you mean with "everything" and "links" in this example?

I just checked by executing a long running test with many screenshots http://lord.arch/tests/6140

What I see is that my browser is quite busy when the page is open and the test is running. Especially when the job is in "uploading" cpu usage raises up. But eventually all thumbnails loaded correctly

#10 Updated by EDiGiacinto almost 5 years ago

#11 Updated by EDiGiacinto almost 5 years ago

While working on #20378 from logs we found that is also caused by 406 returned to the apache proxy while workers try to upload snapshots, that becomes 502 to the user.

#12 Updated by EDiGiacinto almost 5 years ago

  • Status changed from In Progress to Resolved
  • Assignee set to EDiGiacinto

Closing this bug since it might be related to #20378 which is now solved. Please re-open if problem still persist - in case it is persisting and the bug had attachments (such logs, screens, ecc.) please provide new ones.

Also available in: Atom PDF