Project

General

Profile

Actions

action #129883

closed

coordination #127031: [saga][epic] openQA for SUSE customers

coordination #80150: [epic] Scale out openQA: Easier openQA setup

all-in-one openQA container solution

Added by okurz about 1 year ago. Updated 12 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Feature requests
Target version:
Start date:
Due date:
% Done:

0%

Estimated time:

Description

Motivation

We already have convenient helper packages, e.g. openQA-single-instance. To provide that to more users we should feature that in a container. This should also help with #76978

Acceptance criteria

  • AC1: A complete openQA instance including at least one connected worker instance can be started from a one-line podman call

Suggestions

  • In your local openQA working copy, try out to build and run containers, e.g. podman build -t openqa-webui docker/webui and then podman run --rm -it openqa-webui
  • Look into both openQA-single-instance as well as the bootstrap script

Related issues 4 (0 open4 closed)

Related to openQA Infrastructure - action #130201: openqa_bootstrap: fetchneedles not called during openqa-bootstrap size:SResolvedjbaier_cz2023-06-01

Actions
Related to openQA Project - action #159747: Consolidate openQA related containers size:SResolvedjbaier_cz2024-04-29

Actions
Copied from openQA Project - action #76978: How to run an openQA test in 5 minutes size:MResolvedjbaier_cz2020-11-04

Actions
Copied to openQA Project - action #129958: Ensure openSUSE container best practices are followed for our container images in devel: openQA size:MResolvedjbaier_cz2023-05-28

Actions
Actions #1

Updated by okurz about 1 year ago

  • Copied from action #76978: How to run an openQA test in 5 minutes size:M added
Actions #2

Updated by okurz about 1 year ago

  • Status changed from New to Feedback
  • Assignee set to okurz
Actions #3

Updated by okurz about 1 year ago

  • Copied to action #129958: Ensure openSUSE container best practices are followed for our container images in devel: openQA size:M added
Actions #4

Updated by mkittler about 1 year ago

Looks like your PR lacks documentation. I'll try it out nevertheless and will extend the documentation by the way.

Actions #5

Updated by mkittler about 1 year ago

Looks like this isn't built on OBS yet. It doesn't even built locally, at least here I'm getting:

podman build .
STEP 1/7: FROM opensuse/tumbleweed:latest
…
.done]
All repositories have been cleaned up.
--> f6d50630e4f5
STEP 3/7: EXPOSE 80 443 9526
--> 9a2f2c53e46a
STEP 4/7: ENV skip_suse_specifics=1
--> 0b6b6d1e9580
STEP 5/7: ENV skip_suse_tests=1
--> e2980cf37662
STEP 6/7: COPY script/openqa-bootstrap /usr/share/openqa/script/
Error: building at STEP "COPY script/openqa-bootstrap /usr/share/openqa/script/": checking on sources under "/hdd/openqa-devel/repos/openQA/container/single-instance": copier: stat: "/script/openqa-bootstrap": no such file or directory

So I guess I can't add it to the documentation at this point. I've nevertheless just created a PR to improve our referencing right at the start of the documentation: https://github.com/os-autoinst/openQA/pull/5166

By the way, you can merge the two ENV commands into one to avoid the extra build step.

Actions #6

Updated by livdywan about 1 year ago

  • Related to action #130201: openqa_bootstrap: fetchneedles not called during openqa-bootstrap size:S added
Actions #8

Updated by livdywan about 1 year ago

okurz wrote:

https://github.com/os-autoinst/openQA/pull/5163

Specifically Optionally configure SUSE-specifics and tests initialization ended up leading to a regression in existing tests. And it made me wonder if the purpose was to make the new container more generic and set it up without needles - or maybe it was only about SUSE needles?

For the "How to run openQA tests in 5 minutes" story I would expect there's nothing distribution-specific and we're assuming a user who wants to test whatever it is they need to test.

Actions #9

Updated by okurz 12 months ago

  • Status changed from Feedback to In Progress
Actions #10

Updated by openqa_review 12 months ago

  • Due date set to 2023-07-04

Setting due date based on mean cycle time of SUSE QE Tools

Actions #11

Updated by okurz 12 months ago

  • Status changed from In Progress to Feedback

https://build.opensuse.org/package/show/devel:openQA/openQA-single-instance-container built fine so now podman run --pull=newer --rm -it registry.opensuse.org/devel/openqa/containers/openqa-single-instance tries to spawn openQA.

I tested the solution again and it works fine for me repeatedly so I updated the documentation accordingly with
https://github.com/os-autoinst/openQA/pull/5211

Actions #12

Updated by okurz 12 months ago

  • Due date deleted (2023-07-04)
  • Status changed from Feedback to Resolved

All done

Actions #13

Updated by jbaier_cz about 2 months ago

  • Related to action #159747: Consolidate openQA related containers size:S added
Actions

Also available in: Atom PDF