Project

General

Profile

Actions

action #115478

closed

[qe-core] test fails in zypper_log_packages - uploading logs seems to fail due to WORKER_HOSTNAME not being always available

Added by favogt almost 2 years ago. Updated over 1 year ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Bugs in existing tests
Target version:
Start date:
2022-08-18
Due date:
% Done:

0%

Estimated time:
Difficulty:
Sprint:
QE-Core: September Sprint (Aug 31 - Sep 28)

Description

The new module appears to use autoinst_url in test code, but that URL is only usable from inside the SUT.
It works (by accident?) on multimachine configured workers, as those have 10.0.2.2 assigned to br1.

Observation

openQA test in scenario opensuse-15.4-KDE-Live-aarch64-kde-live@USBboot_aarch64 fails in
zypper_log_packages

Test suite description

riafarov: I've increased RAM from 1536 to 2048

Reproducible

Fails since (at least) Build 7.10 (current job)

Expected result

Last good: 7.9 (or more recent)

Further details

Always latest result in this scenario: latest


Related issues 1 (0 open1 closed)

Related to openQA Tests - action #109789: [qe-core] generate a list of installed packages in the system at the end of a testResolveddheidler2022-04-11

Actions
Actions #1

Updated by dheidler almost 2 years ago

  • Status changed from New to In Progress
Actions #2

Updated by dheidler almost 2 years ago

Interestingly this seems to only affect aarch64 workers.
Anyway for a clean fix we need some small tweaks in the testapi of os-autoinst to force autoinst_url() to use the worker ip when requested.

Actions #4

Updated by favogt almost 2 years ago

dheidler wrote:

Interestingly this seems to only affect aarch64 workers.

It affects all workers without a multi-machine setup. i.e. it works on openqa-aarch64, but not the other "cloud" workers (ip-*).

Anyway for a clean fix we need some small tweaks in the testapi of os-autoinst to force autoinst_url() to use the worker ip when requested.

Actions #5

Updated by dimstar almost 2 years ago

dheidler wrote:

Interestingly this seems to only affect aarch64 workers.

Also seen on ppc64le: https://openqa.opensuse.org/tests/2531722#step/zypper_log_packages/10

Actions #6

Updated by maritawerner almost 2 years ago

  • Subject changed from test fails in zypper_log_packages to [qe-core] test fails in zypper_log_packages
Actions #8

Updated by favogt over 1 year ago

  • Status changed from Feedback to Workable
Actions #9

Updated by szarate over 1 year ago

Dominik, let's switch to save_ulogs to copy the contents of the file directly to the ulogs directory: save_ulog($out, $filename);

Actions #10

Updated by szarate over 1 year ago

  • Sprint set to QE-Core: September Sprint (Aug 31 - Sep 28)
  • Tags set to bugbusters
  • Target version set to QE-Core: Ready
Actions #11

Updated by szarate over 1 year ago

  • Subject changed from [qe-core] test fails in zypper_log_packages to [qe-core] test fails in zypper_log_packages - uploading logs seems to fail due to WORKER_HOSTNAME not being always available
Actions #12

Updated by mkittler over 1 year ago

When you're done, you can remove the workaround that's currently configured on the o3 worker ow19 (see #111473#note-61).

Actions #13

Updated by szarate over 1 year ago

  • Related to action #109789: [qe-core] generate a list of installed packages in the system at the end of a test added
Actions #14

Updated by dheidler over 1 year ago

  • Status changed from Workable to Feedback
Actions #15

Updated by favogt over 1 year ago

mkittler wrote:

When you're done, you can remove the workaround that's currently configured on the o3 worker ow19 (see #111473#note-61).

The PR was merged, I removed the workaround.

Actions #16

Updated by dheidler over 1 year ago

  • Status changed from Feedback to Resolved
Actions

Also available in: Atom PDF