Project

General

Profile

Actions

action #107320

closed

[qe-core] test fails in prepare_test_data - sshd[2171]: error: kex_exchange_identification: Connection closed by remote host

Added by tjyrinki_suse about 2 years ago. Updated almost 2 years ago.

Status:
Rejected
Priority:
Normal
Assignee:
Category:
Spike/Research
Target version:
Start date:
2022-02-23
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

Observation

ssh connection is consistently dropping between the SUT and openQA at prepare_test_data, preventing further tests.

openQA test in scenario sle-15-SP4-Online-s390x-extra_tests_gnome@s390x-kvm-sle12 fails in
prepare_test_data

Test suite description

Maintainer: QE Core, asmorodskyi. Extra tests which were designed to run on gnome , VNC_STALL_THRESHOLD is needed for xen svirt to don't turn off the scrreen after default 4 sec

New version of extra_tests_on_gnome for yaml scheduling

Acceptance Criteria

  • AC:0 Switch the test to use root console to remove the initial failure/urgency
  • AC:1 Investigate: sshd[2171]: error: kex_exchange_identification: Connection closed by remote host
  • AC:2 Investigate if this test can be unscheduled. Tests may be able or already are downloading the necessary test data themselves. No need to download unneeded data.
  • AC:3 Make sure that the ssh console is necessary for s390, given that we have a working serial console
  • AC:4 Investigate if it is a backend/hardware problem with grenache/s390 machine
  • AC:5 Investigate if the problem is caused by the choice of user-console

Reproducible

Fails since (at least) Build 61.1

Expected result

Last good: (unknown) (or more recent)

Further details

Always latest result in this scenario: latest

Actions #1

Updated by tjyrinki_suse about 2 years ago

  • Parent task set to #107323
Actions #2

Updated by apappas about 2 years ago

  • Description updated (diff)
Actions #3

Updated by apappas about 2 years ago

  • Status changed from New to Workable
Actions #4

Updated by tjyrinki_suse about 2 years ago

  • Priority changed from Normal to High
Actions #5

Updated by maritawerner about 2 years ago

  • Subject changed from test fails in prepare_test_data to [qe-core] test fails in prepare_test_data
Actions #6

Updated by VANASTASIADIS almost 2 years ago

  • Assignee set to VANASTASIADIS
Actions #7

Updated by VANASTASIADIS almost 2 years ago

  • Assignee deleted (VANASTASIADIS)
Actions #8

Updated by tjyrinki_suse almost 2 years ago

  • Category changed from Bugs in existing tests to Spike/Research
Actions #9

Updated by szarate almost 2 years ago

  • Subject changed from [qe-core] test fails in prepare_test_data to [qe-core] test fails in prepare_test_data - sshd[2171]: error: kex_exchange_identification: Connection closed by remote host
  • Description updated (diff)
Actions #10

Updated by punkioudi almost 2 years ago

  • Priority changed from High to Normal

The issue here is the permission denied appearing here : https://openqa.suse.de/tests/8207530#step/prepare_test_data/9
In the Build108.1, doesn't appear, so we could probably lower the priority.

Actions #11

Updated by pherranz almost 2 years ago

  • Status changed from Workable to In Progress
  • Assignee set to pherranz
Actions #12

Updated by pherranz almost 2 years ago

The failure does not happen either in builds 113.1 and 116.4. Build 117.1 fails in the previous step (boot_to_desktop).

Actions #13

Updated by pherranz almost 2 years ago

Running statistic tests to check if it still fails in Build 117.1

https://openqa.suse.de/tests/overview?build=poo107320_investigation

Actions #14

Updated by pherranz almost 2 years ago

  • Status changed from In Progress to Blocked

35% of the tests fail in boot_to_desktop, which is already being under study in #76813. Nevertheless, the prepare_test_data has not failed in any of the 65 test that run correct in build 117.1.

Actions #15

Updated by pherranz almost 2 years ago

  • Status changed from Blocked to Rejected
Actions

Also available in: Atom PDF