Project

General

Profile

action #95724

[qe-core] move vim out of installation tests

Added by mgrifalconi 10 months ago. Updated 3 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Bugs in existing tests
Target version:
-
Start date:
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

Observation

Broken screenshot (see bottom left) causes vim test to sporadically fail.
It is also painful to restart since it takes 2h each time. We could consider splitting this into installation and other test runs that boots from a disk.

openQA test in scenario sle-12-SP5-Server-DVD-Incidents-Minimal-aarch64-qam-minimal-full@aarch64 fails in
vim

Test suite description

minimal = base pattern, minimal (enhanced base) pattern are additional convenience paclkages

Reproducible

Fails since (at least) Build :20468:kernel-ec2

Expected result

Last good: :20260:dbus-1 (or more recent)

Further details

Always latest result in this scenario: latest


Related issues

Related to openQA Tests - action #56651: [functional][u][sporadic] test fails in vim - yast2-booloader left visual artifactResolved2019-09-09

Related to openQA Tests - action #95365: [qe-core] move ncurses out of installation testsResolved2021-10-12

History

#1 Updated by szarate 10 months ago

  • Related to action #56651: [functional][u][sporadic] test fails in vim - yast2-booloader left visual artifact added

#2 Updated by szarate 10 months ago

  • Related to action #95365: [qe-core] move ncurses out of installation tests added

#3 Updated by tjyrinki_suse 9 months ago

  • Subject changed from [qe-core] test fails in vim to [qe-core][sporadic] test fails in vim
  • Start date deleted (2021-07-20)

#5 Updated by zluo 4 months ago

  • Assignee set to zluo

take over and checking

#6 Updated by zluo 4 months ago

take 'vim' out of minimal_x and put it into extra-test-misc.

#7 Updated by zluo 4 months ago

extra for qam-minimal-full and qam-minimal-full+sle15:
Testsuite maintained at https://gitlab.suse.de/qa-maintenance/qam-openqa-yml

#10 Updated by zluo 3 months ago

  • Status changed from New to In Progress

#12 Updated by zluo 3 months ago

https://openqa.opensuse.org/tests/2178941#step/vim:
'vim' added to extra_test_misc for Tumbleweed as well.

#13 Updated by zluo 3 months ago

  • Subject changed from [qe-core][sporadic] test fails in vim to [qe-core] move vim out of installation tests

vim has been added to extra_test_misc, so last step to remove it from console tests. delete it from main_common.pm

#14 Updated by zluo 3 months ago

https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/14201
okurz can you see this private comment? I thought this should be the case :)

#15 Updated by okurz 3 months ago

zluo I wonder, why do you mark the comment with the pull request as private? The pull request is public itself so I don't think it makes sense to keep this ticket comment private

#16 Updated by zluo 3 months ago

Because of staging tests on O3, so my PR about remove of vim is not possible. It looks to me that YAML_SCHEDULE can solve this task, but this is much more work required.

#17 Updated by zluo 3 months ago

vim has been taken out of Maintenance incidents. vim has been added into extra_tests_misc.
However for sle functional we need same steps and this is complicated because there is no YAML_SCHEDULE for some installation tests available. I will create a related ticket for these changes.

Need to verify vim in extra_tests_misc for new build of SLE 15 SP4 later: http://openqa.suse.de/tests/8126185#next_previous

#18 Updated by zluo 3 months ago

zluo wrote:

vim has been taken out of Maintenance incidents. vim has been added into extra_tests_misc.
However for sle functional we need same steps and this is complicated because there is no YAML_SCHEDULE for some installation tests available. I will create a related ticket for these changes.

Need to verify vim in extra_tests_misc for new build of SLE 15 SP4 later: http://openqa.suse.de/tests/8126185#next_previous

At moment we have issue with create-hdd-allmodules-allpatterns-gnome@64bit which is still failed.

#19 Updated by zluo 3 months ago

#20 Updated by zluo 3 months ago

hdd created now. check now https://openqa.suse.de/tests/8244113

#21 Updated by zluo 3 months ago

  • Status changed from In Progress to Resolved

https://openqa.suse.de/tests/8244113#settings shows that vim module works fine here, set it as resolved now.

Also available in: Atom PDF