Project

General

Profile

coordination #73642

Modify allmodules+allpatterns+registration test suite

Added by syrianidou_sofia about 1 year ago. Updated 8 months ago.

Status:
Closed
Priority:
Normal
Assignee:
Target version:
SUSE QA - SLE 15 SP3
Start date:
2020-11-03
Due date:
% Done:

100%

Estimated time:
(Total: 0.00 h)

Description

Due to certification conflicts with "Tools and scripts for Common Criteria" module, we encounter failure when the standard user is attempting to run su commands :
https://openqa.suse.de/tests/4839187#step/sle15_workarounds/8
According to https://bugzilla.suse.com/show_bug.cgi?id=1177321#c1 , the test suite scenario is not optimal.

Testing manually, the issue is not reproducible if "Tools and scripts for Common Criteria" module is not included. The current test suite should be modified in order to to exclude the particular module from the installation.


Subtasks

action #76918: Redesign allmodules+allpatterns+registration to avoid installation of all patternsClosedJRivrain

action #76921: Add test which enabled custom patterns during the installationClosedJRivrain


Related issues

Related to openQA Tests - action #73645: [sle][migration][SLE15SP3] Remove common-criteria pattern for all patterns test Resolved2020-10-21

History

#1 Updated by szarate about 1 year ago

  • Related to action #73645: [sle][migration][SLE15SP3] Remove common-criteria pattern for all patterns test added

#2 Updated by riafarov 12 months ago

  • Target version set to SLE 15 SP3

#3 Updated by riafarov 12 months ago

  • Tracker changed from action to coordination
  • Description updated (diff)
  • Assignee set to riafarov

I will create sub-tickets for the epic, as we want to keep coverage for exotic backends and second part to test patterns selection functionality.

#4 Updated by riafarov 12 months ago

  • Status changed from New to Workable

#5 Updated by riafarov 8 months ago

  • Status changed from Workable to Closed

Done now, cheers!

Also available in: Atom PDF