Project

General

Profile

action #72229

Support openQA worker on SLE15-SP2 (aarch64): perl(Minion::Backend::SQLite) >= 5.0.1 missing for openQA-worker for SLE15-SP2

Added by ggardet_arm 6 months ago. Updated 6 months ago.

Status:
Resolved
Priority:
Low
Assignee:
Category:
Feature requests
Target version:
Start date:
2020-10-05
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

Observation

While trying to install openQA-worker on a SLE15-SP2 (aarch64) system, I get the following problem:

Problem: nothing provides perl(Minion::Backend::SQLite) >= 5.0.1 needed by openQA-worker-4.6.1601653074.e8470f0ab-3213.1.noarch

This is because it is unresolvable: https://build.opensuse.org/package/show/devel:openQA:SLE-15/perl-Minion-Backend-SQLite
Because:

nothing provides perl(Moo) >= 2.000001 needed by perl-SQL-Abstract

perl-Moo being unresolvable as well: https://build.opensuse.org/package/show/devel:openQA:SLE-15/perl-Moo

nothing provides perl(Role::Tiny) >= 2.001004, (got version 2.000006 provided by perl-Role-Tiny), nothing provides perl(Sub::Defer) >= 2.006006, (got version 2.004000 provided by perl-Sub-Quote), nothing provides perl(Sub::Quote) >= 2.006006, (got version 2.004000 provided by perl-Sub-Quote)

Workaround

See #72229#note-3 or run openSUSE Leap or Tumbleweed container on the SLE systems1


Related issues

Related to openQA Project - action #60029: OBS builds of os-autoinst fail for SLE12SP5 but not for SLE12SP3-4Resolved2019-11-192020-11-30

History

#1 Updated by ggardet_arm 6 months ago

  • Description updated (diff)

#2 Updated by ggardet_arm 6 months ago

  • Description updated (diff)

#3 Updated by ggardet_arm 6 months ago

Using an old openQA-worker from Backports workarounds the installation problem, but that would be much better to use an up-to-date openQA/os-autoinst code.

#4 Updated by okurz 6 months ago

  • Related to action #60029: OBS builds of os-autoinst fail for SLE12SP5 but not for SLE12SP3-4 added

#5 Updated by okurz 6 months ago

  • Project changed from openQA Tests to openQA Project
  • Subject changed from perl(Minion::Backend::SQLite) >= 5.0.1 missing for openQA-worker for SLE15-SP2 to Support openQA worker on SLE15-SP2 (aarch64): perl(Minion::Backend::SQLite) >= 5.0.1 missing for openQA-worker for SLE15-SP2
  • Description updated (diff)
  • Category set to Feature requests
  • Priority changed from High to Low
  • Target version set to future

Unfortunately we don't have the personel to support SLE packages right now. You are welcome to provide SRs if you know what fixes it or suggest us to link specfiic tickets and such. However I recommend you use openSUSE Leap or Tumbleweed. You can run a worker from containers easily on SLE though

#6 Updated by ggardet_arm 6 months ago

Could you please link perl-Sub-Quote and perl-Role-Tiny from Factory to devel:openQA:SLE-15?

#7 Updated by okurz 6 months ago

  • Status changed from New to Feedback
  • Assignee set to okurz

did for i in perl-Sub-Quote perl-Role-Tiny ; do osc linkpac openSUSE:Factory $i devel:openQA:SLE-15; done now and monitoring progress on the project.

#8 Updated by ggardet_arm 6 months ago

  • Status changed from Feedback to Resolved

It builds fine and install properly now, but I get some problems: https://progress.opensuse.org/issues/72238

Also available in: Atom PDF