Project

General

Profile

action #72229

Updated by okurz 7 months ago

## Observation

While trying to install `openQA-worker` on a SLE15-SP2 (aarch64) system, I get the following problem:
~~~
Problem: nothing provides perl(Minion::Backend::SQLite) >= 5.0.1 needed by openQA-worker-4.6.1601653074.e8470f0ab-3213.1.noarch
~~~

This is because it is unresolvable: https://build.opensuse.org/package/show/devel:openQA:SLE-15/perl-Minion-Backend-SQLite
Because:
~~~
nothing provides perl(Moo) >= 2.000001 needed by perl-SQL-Abstract
~~~

perl-Moo being unresolvable as well: https://build.opensuse.org/package/show/devel:openQA:SLE-15/perl-Moo
~~~
nothing provides perl(Role::Tiny) >= 2.001004, (got version 2.000006 provided by perl-Role-Tiny), nothing provides perl(Sub::Defer) >= 2.006006, (got version 2.004000 provided by perl-Sub-Quote), nothing provides perl(Sub::Quote) >= 2.006006, (got version 2.004000 provided by perl-Sub-Quote)
~~~

## Workaround

See #72229#note-3 or run openSUSE Leap or Tumbleweed container on the SLE systems1

Back