Project

General

Profile

action #68476

[qe-core][functional] test fails in user_gui_login - fails sporadically

Added by lkocman over 2 years ago. Updated over 1 year ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Bugs in existing tests
Target version:
SUSE QA - Milestone 30
Start date:
2020-06-26
Due date:
% Done:

0%

Estimated time:
42.00 h
Difficulty:

Description

Observation

Seems like this test is failing time to time. Can you please investigate?
See function handle_login in lib/x11utils.pm which is called by handle_relogin.

Acceptance criteria

  • AC1: The fix works on all product supported versions (Tumbleweed, SLE15-SP2, Leap 15.2, SLE12-SP4)

Suggestion

  • A first step would be to verify if the password was typed. assert_screen of hidden passwords (bullets points should match password length)
  • Later the ticket can be brought back to a grooming meeting

Reproducible


Related issues

Related to openQA Tests - action #69994: [kde] Upgrade scenarios fail to handle_login on KDE sessionsNew2020-08-13

Related to openQA Tests - action #66784: [qe-core][opensuse][desktop] xrdp_server: login sequenceResolved

History

#1 Updated by ggardet_arm about 2 years ago

Also fail on aarch64 Tumbleweed:

#2 Updated by SLindoMansilla about 2 years ago

  • Subject changed from test fails in user_gui_login - fails sporadically to [functional][u] test fails in user_gui_login - fails sporadically
  • Description updated (diff)

#3 Updated by SLindoMansilla about 2 years ago

  • Description updated (diff)
  • Status changed from New to Workable
  • Target version set to Milestone 30
  • Estimated time set to 42.00 h

#4 Updated by SLindoMansilla about 2 years ago

  • Related to action #69994: [kde] Upgrade scenarios fail to handle_login on KDE sessions added

#5 Updated by SLindoMansilla about 2 years ago

  • Related to action #66784: [qe-core][opensuse][desktop] xrdp_server: login sequence added

#6 Updated by tjyrinki_suse almost 2 years ago

  • Subject changed from [functional][u] test fails in user_gui_login - fails sporadically to [qe-core][functional] test fails in user_gui_login - fails sporadically

#7 Updated by szarate over 1 year ago

Lubos, Guillaume is this happening still?

#8 Updated by ggardet_arm over 1 year ago

It looks like it did not happen lately.

#9 Updated by tjyrinki_suse over 1 year ago

  • Status changed from Workable to Resolved

No recent problems, please reopen if the same problem persists, or file a new ticket.

Also available in: Atom PDF