Project

General

Profile

action #65058

[qe-core][functional][xen-hvm] test fails in user_defined_snapshot - Machine didn't shut down

Added by SLindoMansilla over 1 year ago. Updated 23 days ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Spike/Research
Target version:
Start date:
2021-01-19
Due date:
% Done:

100%

Estimated time:
42.00 h
Difficulty:

Description

Obvervations

record_info 'Snapshot created', 'booting the system into created snapshot';
power_action('reboot', keepconsole => 1, observe => is_remote_backend);
$self->wait_grub(bootloader_time => 250);

power_action failed to reboot.

Reproducible

  • In scenario sle-15-SP2-Online-x86_64-extra_tests_gnome@svirt-xen-hvm
  • Fails since Build [167.5]
  • Current occurrence: 168.1

Expected result

Last good: 164.1

Further details

Always latest result in this scenario: latest


Subtasks

action #87943: [qe-core] test fails in yast2_lan_restartResolvedpunkioudi

History

#1 Updated by okurz over 1 year ago

This is an autogenerated message for openQA integration by the openqa_review script:

This bug is still referenced in a failing openQA test: extra_tests_gnome@svirt-xen-hvm
https://openqa.suse.de/tests/4125589

To prevent further reminder comments one of the following options should be followed:

  1. The test scenario is fixed by applying the bug fix to the tested product or the test is adjusted
  2. The openQA job group is moved to "Released"
  3. The label in the openQA scenario is removed

#2 Updated by okurz over 1 year ago

This is an autogenerated message for openQA integration by the openqa_review script:

This bug is still referenced in a failing openQA test: extra_tests_gnome@svirt-xen-hvm
https://openqa.suse.de/tests/4125589

To prevent further reminder comments one of the following options should be followed:

  1. The test scenario is fixed by applying the bug fix to the tested product or the test is adjusted
  2. The openQA job group is moved to "Released"
  3. The label in the openQA scenario is removed

#3 Updated by okurz about 1 year ago

This is an autogenerated message for openQA integration by the openqa_review script:

This bug is still referenced in a failing openQA test: extra_tests_gnome@svirt-xen-hvm
https://openqa.suse.de/tests/4187229

To prevent further reminder comments one of the following options should be followed:

  1. The test scenario is fixed by applying the bug fix to the tested product or the test is adjusted
  2. The openQA job group is moved to "Released"
  3. The label in the openQA scenario is removed

#4 Updated by okurz about 1 year ago

This is an autogenerated message for openQA integration by the openqa_review script:

This bug is still referenced in a failing openQA test: extra_tests_gnome@svirt-xen-hvm
https://openqa.suse.de/tests/4248037

To prevent further reminder comments one of the following options should be followed:

  1. The test scenario is fixed by applying the bug fix to the tested product or the test is adjusted
  2. The openQA job group is moved to "Released"
  3. The label in the openQA scenario is removed

#5 Updated by SLindoMansilla about 1 year ago

  • Description updated (diff)
  • Category changed from Bugs in existing tests to Spike/Research
  • Status changed from New to Workable
  • Assignee set to szarate
  • Target version set to Milestone 30
  • Estimated time set to 42.00 h

#6 Updated by openqa_review 11 months ago

This is an autogenerated message for openQA integration by the openqa_review script:

This bug is still referenced in a failing openQA test: extra_tests_gnome@svirt-xen-pv
https://openqa.suse.de/tests/4576538

To prevent further reminder comments one of the following options should be followed:

  1. The test scenario is fixed by applying the bug fix to the tested product or the test is adjusted
  2. The openQA job group is moved to "Released"
  3. The label in the openQA scenario is removed

#7 Updated by okurz 10 months ago

This is an autogenerated message for openQA integration by the openqa_review script:

This bug is still referenced in a failing openQA test: extra_tests_gnome@svirt-xen-hvm
https://openqa.suse.de/tests/4757562

To prevent further reminder comments one of the following options should be followed:

  1. The test scenario is fixed by applying the bug fix to the tested product or the test is adjusted
  2. The openQA job group is moved to "Released"
  3. The label in the openQA scenario is removed

#8 Updated by szarate 10 months ago

  • Assignee deleted (szarate)
  • Priority changed from Normal to High

#9 Updated by okurz 9 months ago

This is an autogenerated message for openQA integration by the openqa_review script:

This bug is still referenced in a failing openQA test: extra_tests_gnome@svirt-xen-hvm
https://openqa.suse.de/tests/4901680

To prevent further reminder comments one of the following options should be followed:

  1. The test scenario is fixed by applying the bug fix to the tested product or the test is adjusted
  2. The openQA job group is moved to "Released"
  3. The label in the openQA scenario is removed

#10 Updated by tjyrinki_suse 9 months ago

  • Subject changed from [functional][u][xen-hvm] test fails in user_defined_snapshot - Machine didn't shut down to [qe-core][functional][xen-hvm] test fails in user_defined_snapshot - Machine didn't shut down

#11 Updated by okurz 8 months ago

This is an autogenerated message for openQA integration by the openqa_review script:

This bug is still referenced in a failing openQA test: extra_tests_gnome@svirt-xen-hvm
https://openqa.suse.de/tests/5025409

To prevent further reminder comments one of the following options should be followed:

  1. The test scenario is fixed by applying the bug fix to the tested product or the test is adjusted
  2. The openQA job group is moved to "Released"
  3. The label in the openQA scenario is removed

#12 Updated by okurz 8 months ago

This is an autogenerated message for openQA integration by the openqa_review script:

This bug is still referenced in a failing openQA test: extra_tests_gnome@svirt-xen-hvm
https://openqa.suse.de/tests/5131847

To prevent further reminder comments one of the following options should be followed:

  1. The test scenario is fixed by applying the bug fix to the tested product or the test is adjusted
  2. The openQA job group is moved to "Released"
  3. The label in the openQA scenario is removed

#13 Updated by okurz 7 months ago

This is an autogenerated message for openQA integration by the openqa_review script:

This bug is still referenced in a failing openQA test: extra_tests_gnome@svirt-xen-hvm
https://openqa.suse.de/tests/5190071

To prevent further reminder comments one of the following options should be followed:

  1. The test scenario is fixed by applying the bug fix to the tested product or the test is adjusted
  2. The openQA job group is moved to "Released"
  3. The label in the openQA scenario is removed

#14 Updated by punkioudi 7 months ago

  • Assignee set to punkioudi

#15 Updated by punkioudi 7 months ago

  • % Done changed from 0 to 20

Draft PR: https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/11736/files

By removing the observe argument(for which I don't see a significant purpose of existing), reboot works as expected and eventually the test passes.

#16 Updated by punkioudi 6 months ago

Test now fails for scenario sle-15-SP2-Online-x86_64-extra_tests_gnome@svirt-xen-pv in a different place : https://openqa.suse.de/tests/5305271#step/user_defined_snapshot/39
The function wait_grub is called during that step, which is not the case for this machine.
New PR will be prepared to cover this case too.

#18 Updated by tjyrinki_suse 6 months ago

  • Status changed from Workable to In Progress

#19 Updated by punkioudi 5 months ago

The last runs of extra_tests_gnome@svirt-xen-hvm are cancelled due to a previous failing job, so I ran again one test with git-refspec, which passes : https://openqa.suse.de/tests/5469544
We can keep though the ticket open, until the test passes consequently in osd.

#20 Updated by szarate 5 months ago

So I think that making the machine to soft-fail when it couldn't shut down, and force the shutdown via acpi or something in the backend https://openqa.suse.de/tests/5462020#step/shutdown/19

#21 Updated by punkioudi 5 months ago

szarate should we then open a new progress issue for that, as this fail happens in a different place than the current in the description?

#22 Updated by tjyrinki_suse 5 months ago

  • Target version changed from Milestone 30 to Ready

#23 Updated by tjyrinki_suse 5 months ago

  • Target version changed from Ready to QE-Core: Ready

#24 Updated by tjyrinki_suse 5 months ago

  • Target version changed from QE-Core: Ready to Ready

#25 Updated by szarate 5 months ago

  • Target version changed from Ready to QE-Core: Ready

#26 Updated by tjyrinki_suse 5 months ago

  • Target version deleted (QE-Core: Ready)

#27 Updated by punkioudi 3 months ago

Consecutive runs with git-refspec :
https://openqa.suse.de/tests/5921013
https://openqa.suse.de/tests/5921104
https://openqa.suse.de/tests/5921163

Issue still cannot be reproduced.

#28 Updated by punkioudi about 2 months ago

  • Status changed from In Progress to Resolved

#29 Updated by szarate 23 days ago

  • Target version set to QE-Core: Ready

Also available in: Atom PDF