action #63565

The extra setting is added to the new job when cloning a job

Added by Xiaojing_liu about 1 month ago. Updated 10 days ago.

Status:FeedbackStart date:19/02/2020
Priority:LowDue date:
Assignee:Xiaojing_liu% Done:

0%

Category:Concrete Bugs
Target version:-
Difficulty:
Duration:

Description

Observation

When cloning a job use clone_job.pl, the setting with + defined in Medium Types (such as +ISO=xxx.iso) will be added into the job's setting, although it does not affect the job.
Here is an example: https://openqa.suse.de/tests/3795703#settings

Steps to reproduce

  • Add a new setting (e.g +ISO=xxx ) to an exist Medium Types.
  • clone a job with above Medium Types.
  • The new settings

Problem

The settings +ISO=xxx should not be added to the job's setting.


Related issues

Related to openQA Project - action #63883: openqa-clone-job does not support removing an unuseful se... Feedback 27/02/2020
Related to openQA Project - action #64938: '+ISO=' in test suite breaks a number of tests Resolved 27/03/2020
Duplicated by openQA Project - action #63562: The extra setting is added to the new job when cloning a job Closed 19/02/2020
Copied from openQA Project - action #62219: jobs post does not support to trigger a test suite that i... Closed 17/01/2020

History

#1 Updated by Xiaojing_liu about 1 month ago

  • Copied from action #62219: jobs post does not support to trigger a test suite that is defined in YAML with a new alias added

#2 Updated by Xiaojing_liu about 1 month ago

  • Duplicated by action #63562: The extra setting is added to the new job when cloning a job added

#3 Updated by okurz about 1 month ago

Where can I find the clone source job and the cloned ones where the new setting would appear? https://openqa.suse.de/tests/3795703 doesn't tell me if it was cloned or is the source of a clone.

#4 Updated by Xiaojing_liu about 1 month ago

okurz wrote:

Where can I find the clone source job and the cloned ones where the new setting would appear? https://openqa.suse.de/tests/3795703 doesn't tell me if it was cloned or is the source of a clone.

The clone source job is https://10.160.0.207/tests/3767674#settings . job #3795703 was cloned based on job #3767674. you could see that in https://openqa.suse.de/tests/3795703#settings there is a setting '+ISO=SLE-15-SP2-Online-x86_64-Build122.1-Media1.iso'.

#5 Updated by okurz about 1 month ago

ok but wasn't that a feature you added with https://github.com/os-autoinst/openQA/pull/2083 ? The according ticket was #20464

#6 Updated by Xiaojing_liu 29 days ago

  • Related to action #63883: openqa-clone-job does not support removing an unuseful setting added

#7 Updated by Xiaojing_liu 29 days ago

okurz wrote:

ok but wasn't that a feature you added with https://github.com/os-autoinst/openQA/pull/2083 ? The according ticket was #20464

Sorry I forgot to update this ticket. Yes, I added this feature before, and I did not consider this situation when I did it.

#8 Updated by cdywan 14 days ago

Can this ticket be considered resolved now?

#9 Updated by Xiaojing_liu 13 days ago

  • Status changed from New to Resolved
  • Assignee set to Xiaojing_liu

cdywan wrote:

Can this ticket be considered resolved now?

yes, I think so.

#10 Updated by Xiaojing_liu 13 days ago

Xiaojing_liu wrote:

cdywan wrote:

Can this ticket be considered resolved now?


yes, I think so.

Related PR had been merged. https://github.com/os-autoinst/openQA/pull/2861

#11 Updated by okurz 13 days ago

Please keep in mind that it's a good practice to only resolve a ticket after verifying it works on one of our production instances, e.g. o3 after daily deployment. Maybe you did that already

#12 Updated by Xiaojing_liu 13 days ago

  • Status changed from Resolved to Feedback

okurz wrote:

Please keep in mind that it's a good practice to only resolve a ticket after verifying it works on one of our production instances, e.g. o3 after daily deployment. Maybe you did that already

I do not do that in o3. I update the status to 'Feedback'. I plan to verify it on OSD after it is deployed.

#13 Updated by okurz 13 days ago

Well that would take a week then with our current schedule of (only) weekly deployments. You can keep it at Resolved, no problem, just a reminder in general :)

#14 Updated by okurz 13 days ago

#64938 seems to have been confirmed as regression due to your PR, reverted in https://github.com/os-autoinst/openQA/pull/2874 . Please try to bring in the PR again while testing for the problem as reported in #64938

#15 Updated by okurz 10 days ago

  • Related to action #64938: '+ISO=' in test suite breaks a number of tests added

#16 Updated by okurz 10 days ago

Remotely related is your PR https://github.com/os-autoinst/openQA/pull/2877 which seems to be a fix for https://github.com/os-autoinst/openQA/pull/2870 which I merged now to fix an urgent problem in production. However I would greatly appreciate if you can ensure we have proper tests to cover the regression we encountered.

Also available in: Atom PDF