Project

General

Profile

action #56564

SQLite package seems broken in 15.1

Added by andriinikitin over 2 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
Concrete Bugs
Target version:
-
Start date:
2019-09-07
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

I get error below trying to run fullstack test after installing openQA-devel on 15.1

Bareword "DBD::SQLite::INSERT" not allowed while "strict subs" in use at /usr/lib/perl5/vendor_perl/5.26.1/Mojo/SQLite.pm line 93.
Compilation failed in require at lib/OpenQA/Worker/Cache.pm line 28.
BEGIN failed--compilation aborted at lib/OpenQA/Worker/Cache.pm line 28.
Compilation failed in require at lib/OpenQA/Worker/Cache/Client.pm line 20.
BEGIN failed--compilation aborted at lib/OpenQA/Worker/Cache/Client.pm line 20.
Compilation failed in require at t/full-stack.t line 52.
BEGIN failed--compilation aborted at t/full-stack.t line 52.

When I install perl-DBD-SQLite package before openQA-devel - this error is not shown.
Attached Dockerfile demonstrates behavior problem.log
If I uncomment install of perl-DBD-SQLite in the docker file - the tests are started properly (unrelated is shown, but is not relevant here) - preinstall.log

Workaround: install perl-DBD-SQLite, resolving conflict with perl-DBD-SQLite-Amalgamation-3.6.1.2-lp151.11.2.x86_64 (@System) (conflict.log)

problem.log (14.8 KB) problem.log andriinikitin, 2019-09-07 11:12
preinstall.log (14.4 KB) preinstall.log andriinikitin, 2019-09-07 11:13
conflict.log (1.23 KB) conflict.log andriinikitin, 2019-09-07 11:13
Dockerfile (748 Bytes) Dockerfile andriinikitin, 2019-09-07 11:25

Related issues

Related to openQA Project - action #53177: [openqa][worker] Can not start worker service after installing latest openqa tool set on leap 42.3Resolved2019-06-17

History

#2 Updated by okurz over 2 years ago

  • Category set to Concrete Bugs

when I install "openQA-devel" on Tumbleweed + devel:openQA it pulls in perl-DBD-SQLite which is also specified as runtime dependency in https://build.opensuse.org/package/view_file/openSUSE:Factory/perl-Mojo-SQLite/perl-Mojo-SQLite.spec?expand=1 so I am not sure what you think the problem is. The version of openQA-devel is 4.6.1567758511.b89f75b7e-1755.1 . Can you actually reproduce the problem? Maybe it was a problem in an intermediate version of any package?

You should not need to add devel:languages:perl. The only problem I see is that within Leap 15.1 we do not yet have all necessary dependencies, e.g. perl(Devel::Cover::Report::Codecov). If you want to replicate what we do so far then it should be Leap 42.3 or we update our existing image including travis CI first.

#3 Updated by okurz over 2 years ago

Which brings me to an idea: We could have a test trying to install openQA-devel: https://github.com/os-autoinst/openQA/pull/2319

#4 Updated by cdywan over 2 years ago

I have definitely seen this problem before. perl-DBD-SQLite-Amalgamation got installed just like above, instead of the correct package.

#5 Updated by andriinikitin over 2 years ago

okurz wrote:

Can you actually reproduce the problem?

Yes problem is specific to 15.1, just run docker build on attached dockerfile

If you want to replicate what we do so far then it should be Leap 42.3 or we update our existing image including travis CI first.

This bug is to fix the problem on 15.1 (if it is 15.1-specific)

#6 Updated by mkittler over 2 years ago

We even already had a ticket for this problem before. I guess we should ensure via our specfile that perl-DBD-SQLite is installed and not perl-DBD-SQLite-Amalgamation.

#7 Updated by andriinikitin over 2 years ago

  • Related to action #53177: [openqa][worker] Can not start worker service after installing latest openqa tool set on leap 42.3 added

#8 Updated by coolo over 2 years ago

First question: where do you get perl-DBD-SQLite-Amalgamation from? It's only available in devel:languages:perl - which shouldn't be used

#9 Updated by coolo over 2 years ago

This is the problem with this package:

```202752a9c2f5:/ # rpm -q --provides perl-DBD-SQLite-Amalgamation
perl(DBD::SQLite) = 1.14001

#11 Updated by andriinikitin over 2 years ago

  • Status changed from Workable to Closed

coolo wrote:

First question: where do you get perl-DBD-SQLite-Amalgamation from? It's only available in devel:languages:perl - which shouldn't be used

Yeah, now I understand where the problem comes from - at the same time that repo had lower priority, so I expected that such setup should work.
I think the problem is fixed now with your change on obs - will close the ticket.

#12 Updated by andriinikitin over 2 years ago

  • Copied to action #56810: "stale element reference: element is not attached to the page" during tests on 15.1 added

#13 Updated by andriinikitin over 2 years ago

  • Copied to deleted (action #56810: "stale element reference: element is not attached to the page" during tests on 15.1)

Also available in: Atom PDF