Project

General

Profile

action #53177

[openqa][worker] Can not start worker service after installing latest openqa tool set on leap 42.3

Added by xlai over 2 years ago. Updated over 2 years ago.

Status:
Resolved
Priority:
High
Assignee:
Category:
Support
Target version:
-
Start date:
2019-06-17
Due date:
% Done:

0%

Estimated time:
Difficulty:

Description

I have a leap 42.3. On it, I install the latest openqa-* and os-autoinst. The webui can be started normally. But the workers can not be started.

logs

Worker setting:

[global]
WORKER_HOSTNAME=10.67.18.220
[22]
WORKER_CLASS=multi-machine-job-dedicated-ipmi
BACKEND=ipmi
IPMI_HOSTNAME=10.67.135.2
IPMI_PASSWORD=susetesting
IPMI_USER=root
#WORKER_HOSTNAME=147.2.212.149
WORKER_HOSTNAME=10.67.18.220
TIMEOUT_SCALE=3
VNC_TYPING_LIMIT=10
SUT_IP=10.67.131.2
PVUSB_DEVICE=Seagate

Start worker failure output:

linux-gepp:/usr/share/openqa/script # /usr/share/openqa/script/worker --instance 22
Bareword "DBD::SQLite::INSERT" not allowed while "strict subs" in use at /usr/lib/perl5/vendor_perl/5.18.2/Mojo/SQLite.pm line 93.
Compilation failed in require at /usr/share/openqa/script/../lib/OpenQA/Worker/Cache.pm line 28.
BEGIN failed--compilation aborted at /usr/share/openqa/script/../lib/OpenQA/Worker/Cache.pm line 28.
Compilation failed in require at /usr/share/openqa/script/../lib/OpenQA/Worker/Engines/isotovideo.pm line 31.
BEGIN failed--compilation aborted at /usr/share/openqa/script/../lib/OpenQA/Worker/Engines/isotovideo.pm line 31.
Compilation failed in require at /usr/share/openqa/script/../lib/OpenQA/Worker/Jobs.pm line 26.
BEGIN failed--compilation aborted at /usr/share/openqa/script/../lib/OpenQA/Worker/Jobs.pm line 26.
Compilation failed in require at /usr/share/openqa/script/../lib/OpenQA/Worker/Commands.pm line 24.
BEGIN failed--compilation aborted at /usr/share/openqa/script/../lib/OpenQA/Worker/Commands.pm line 24.
Compilation failed in require at /usr/share/openqa/script/../lib/OpenQA/Worker.pm line 31.
BEGIN failed--compilation aborted at /usr/share/openqa/script/../lib/OpenQA/Worker.pm line 31.
Compilation failed in require at /usr/share/openqa/script/worker line 106.
BEGIN failed--compilation aborted at /usr/share/openqa/script/worker line 106.

All installed openqa tool set:

linux-gepp:/usr/share/openqa/script # rpm -qf /usr/share/openqa/script/../lib/OpenQA/Worker/Cache.pm
openQA-common-4.6.1560549641.c09044ae-1444.1.noarch
linux-gepp:/usr/share/openqa/script # zypper se -s openQA-common
Loading repository data...
Reading installed packages...

S  | Name          | Type    | Version                        | Arch   | Repository     
---+---------------+---------+--------------------------------+--------+----------------
i+ | openQA-common | package | 4.6.1560549641.c09044ae-1444.1 | noarch | openqa_42.3    
v  | openQA-common | package | 4.4.1497257618.89b04ed8-1.1    | noarch | dependency-repo
linux-gepp:/usr/share/openqa/script # zypper ref
Repository 'dependency-repo' is up to date.                                                                                                                             
Repository 'language-perl-42.3' is up to date.                                                                                                                          
Repository 'language_perl' is up to date.                                                                                                                               
Repository 'openqa_42.3' is up to date.                                                                                                                                 
Repository 'opensuse-42.3-install-repo' is up to date.                                                                                                                  
All repositories have been refreshed.
linux-gepp:/usr/share/openqa/script # rpm -qa | grep -i openqa            
openQA-common-4.6.1560549641.c09044ae-1444.1.noarch
openQA-4.6.1560549641.c09044ae-1444.1.noarch
openQA-worker-4.6.1560549641.c09044ae-1444.1.noarch
openQA-client-4.6.1560549641.c09044ae-1444.1.noarch
openQA-local-db-4.6.1560549641.c09044ae-1444.1.noarch
linux-gepp:/usr/share/openqa/script # rpm -qa | grep os-autoinst
os-autoinst-4.5.1560548250.151bd110-120.1.x86_64
linux-gepp:/usr/share/openqa/script # zypper se -s os-autoinst
Loading repository data...
Reading installed packages...

S  | Name                             | Type       | Version                       | Arch   | Repository     
---+----------------------------------+------------+-------------------------------+--------+----------------
i+ | os-autoinst                      | package    | 4.5.1560548250.151bd110-120.1 | x86_64 | openqa_42.3    
v  | os-autoinst                      | package    | 4.4.1493206707.df989545-1.1   | x86_64 | dependency-repo
   | os-autoinst                      | srcpackage | 4.5.1560548250.151bd110-120.1 | noarch | openqa_42.3    
   | os-autoinst-debuginfo            | package    | 4.5.1560548250.151bd110-120.1 | x86_64 | openqa_42.3    
   | os-autoinst-debugsource          | package    | 4.5.1560548250.151bd110-120.1 | x86_64 | openqa_42.3    
   | os-autoinst-distri-opensuse-deps | package    | 1.1560758996.2a5be2f7b-201.1  | noarch | openqa_42.3    
   | os-autoinst-distri-opensuse-deps | srcpackage | 1.1560758996.2a5be2f7b-201.1  | noarch | openqa_42.3    
   | os-autoinst-openvswitch          | package    | 4.5.1560548250.151bd110-120.1 | x86_64 | openqa_42.3    
   | os-autoinst-openvswitch          | package    | 4.4.1493206707.df989545-1.1   | x86_64 | dependency-repo
   | os-autoinst-test                 | srcpackage | 4.5.1560548250.151bd110-120.1 | noarch | openqa_42.3

Repo:

linux-gepp:/usr/share/openqa/script # zypper lr -u
Repository priorities are without effect. All enabled repositories share the same priority.

#  | Alias                      | Name                                    | Enabled | GPG Check | Refresh | URI                                                                                                                  
---+----------------------------+-----------------------------------------+---------+-----------+---------+----------------------------------------------------------------------------------------------------------------------
 1 | dependency-repo            | dependency-repo                         | Yes     | (r ) Yes  | No      | http://download.opensuse.org/distribution/leap/42.3/repo/oss/suse/                                                   
 2 | language-perl-42.3         | language-perl-42.3                      | Yes     | (r ) Yes  | No      | https://download.opensuse.org/repositories/devel:/languages:/perl/openSUSE_Leap_42.3/                                
 3 | language_perl              | language_perl                           | Yes     | (r ) Yes  | Yes     | http://download.opensuse.org/repositories/devel:/languages:/perl/openSUSE_Leap_42.3/                                 
 4 | latest-opensuse            | latest-opensuse                         | No      | ----      | ----    | https://download.opensuse.org/repositories/openSUSE:/Factory/images/repo/openSUSE-Factory-DVD-x86_64-Build0186-Media/
 5 | openQA                     | openQA                                  | No      | ----      | ----    | http://download.opensuse.org/repositories/devel:/openQA/openSUSE_Leap_42.2                                           
 6 | openQA-perl-modules        | openQA-perl-modules                     | No      | ----      | ----    | http://download.opensuse.org/repositories/devel:/openQA:/Leap:/42.2/openSUSE_Leap_42.2                               
 7 | openSUSE-42.2-0            | openSUSE-42.2-0                         | No      | ----      | ----    | http://mirror.bej.suse.com/dist/install/SLP/openSUSE-Leap-42.2-GM/x86_64/dvd1/                                       
 8 | openqa_42.3                | openqa_42.3                             | Yes     | (r ) Yes  | No      | https://download.opensuse.org/repositories/devel:/openQA/openSUSE_Leap_42.3/                                         
 9 | opensuse-42.3-install-repo | opensuse-42.3-install-repo              | Yes     | (r ) Yes  | No      | http://mirror.bej.suse.com/dist/install/SLP/openSUSE-Leap-42.3/x86_64/dvd1/                                          
10 | repo-debug-non-oss         | openSUSE-Leap-42.2-Debug-Non-Oss        | No      | ----      | ----    | http://download.opensuse.org/debug/distribution/leap/42.2/repo/non-oss/                                              
11 | repo-debug-update          | openSUSE-Leap-42.2-Update-Debug         | No      | ----      | ----    | http://download.opensuse.org/debug/update/leap/42.2/oss/                                                             
12 | repo-debug-update-non-oss  | openSUSE-Leap-42.2-Update-Debug-Non-Oss | No      | ----      | ----    | http://download.opensuse.org/debug/update/leap/42.2/non-oss/                                                         
13 | repo-non-oss               | openSUSE-Leap-42.2-Non-Oss              | No      | ----      | ----    | http://download.opensuse.org/distribution/leap/42.2/repo/non-oss/                                                    
14 | repo-oss                   | openSUSE-Leap-42.2-Oss                  | No      | ----      | ----    | http://download.opensuse.org/distribution/leap/42.2/repo/oss/                                                        
15 | repo-source                | openSUSE-Leap-42.2-Source               | No      | ----      | ----    | http://download.opensuse.org/source/distribution/leap/42.2/repo/oss/                                                 
16 | repo-source-non-oss        | openSUSE-Leap-42.2-Source-Non-Oss       | No      | ----      | ----    | http://download.opensuse.org/source/distribution/leap/42.2/repo/non-oss/                                             
17 | repo-update                | openSUSE-Leap-42.2-Update               | No      | ----      | ----    | http://download.opensuse.org/update/leap/42.2/oss/                                                                   
18 | repo-update-non-oss        | openSUSE-Leap-42.2-Update-Non-Oss       | No      | ----      | ----    | http://download.opensuse.org/update/leap/42.2/non-oss/                                                               
linux-gepp:/usr/share/openqa/script

Related issues

Related to openQA Project - action #56564: SQLite package seems broken in 15.1Closed2019-09-07

History

#1 Updated by mkittler over 2 years ago

  • Description updated (diff)

#2 Updated by mkittler over 2 years ago

  • Description updated (diff)

#3 Updated by mkittler over 2 years ago

If you get an error like Bareword "DBD::SQLite::INSERT" not allowed... you can usually assume that the Perl module providing that symbol is simply not installed. I suspect in this case you just need to install the package perl-DBD-SQLite to resolve the problem.

I'm wondering whether the spec file producing our worker package misses this dependency, though.

#4 Updated by mkittler over 2 years ago

Our spec file lists the dependency perl-DBD-SQLite correctly. I assume you installed perl-DBD-SQLite-Amalgamation which claims to provide perl-DBD-SQLite but it does not work with the openQA worker. Is it possible to state in the spec file that perl-DBD-SQLite-Amalgamation is not sufficient? Otherwise I propose that perl-DBD-SQLite-Amalgamation should no longer claim to provide perl-DBD-SQLite.

#5 Updated by xlai over 2 years ago

As you suspected, after upgrading to perl-DBD-SQLite-1.62-50.1.x86_64 , the problem is solved. So seems the required perl-DBD-SQLite version in the spec should be higher.

#6 Updated by mkittler over 2 years ago

  • Assignee set to mkittler

So it was not perl-DBD-SQLite-Amalgamation and really a too old version? I'm just wondering because we require >= 1.51 and this version seems to have that constant: https://github.com/DBD-SQLite/DBD-SQLite/blob/1.51_01/t/36_hooks.t

#7 Updated by mkittler over 2 years ago

  • Status changed from New to Resolved

I was curious about the cause of the issue but let's just consider this resolved.

#8 Updated by andriinikitin over 2 years ago

  • Related to action #56564: SQLite package seems broken in 15.1 added

Also available in: Atom PDF