Project

General

Profile

Actions

action #53996

closed

[functional][u][sporadic] test fails in timezone - serial console is not reliable

Added by dheidler almost 5 years ago. Updated over 4 years ago.

Status:
Rejected
Priority:
Normal
Assignee:
Category:
Bugs in existing tests
Target version:
SUSE QA - Milestone 28
Start date:
2019-07-09
Due date:
% Done:

0%

Estimated time:
42.00 h
Difficulty:

Description

Observation

openQA test in scenario sle-12-SP5-Server-DVD-aarch64-extra_tests_in_textmode@aarch64 fails in
timezone

Task

  1. Run 100 jobs to see reproducibility.
  2. Put it back to be refined.

Reproducible

Fails since (at least) Build 0161

Expected result

Last good: 0158 (or more recent)

Further details

Always latest result in this scenario: latest


Related issues 2 (0 open2 closed)

Related to openQA Tests - action #58697: [kernel][tools] test fails in install_ltpResolvedcfconrad2019-10-25

Actions
Has duplicate openQA Tests - action #55967: [tools][u] test fails in gdb - Unstable serial terminal causes failures in different partsRejected2019-08-26

Actions
Actions #1

Updated by SLindoMansilla almost 5 years ago

  • Subject changed from test fails in timezone to [functional][u] test fails in timezone
  • Priority changed from Normal to High
Actions #3

Updated by SLindoMansilla almost 5 years ago

  • Subject changed from [functional][u] test fails in timezone to [functional][u][sporadic] test fails in timezone
  • Description updated (diff)
  • Assignee set to szarate
  • Priority changed from High to Normal
  • Target version set to Milestone 26
Actions #4

Updated by szarate almost 5 years ago

  • Status changed from New to In Progress

So, It's kinda easy to reproduce:

I've started digging a bit to try to figure out what's the problem... but looks like that setting the type_string to slow would already do the trick, however I remember there was a similar issue back in the day with some tests as well... Will spend the rest of the day in this and see...

Actions #5

Updated by szarate almost 5 years ago

  • Status changed from In Progress to Feedback

I've created a pull request to switch from serial_terminal to root-console instead (which I'm not really happy about), but this would reduce the reproduceability of this problem... However in any case, I will try to investigate a bit more to try and understand why this happens on aarch64. Might be load related, but still... the test runner should be able to cope with this...

Actions #7

Updated by SLindoMansilla almost 5 years ago

Is this still waiting for someone's feedback?

Actions #8

Updated by szarate almost 5 years ago

My feedback, I'll update this later today

Actions #9

Updated by mgriessmeier almost 5 years ago

  • Target version changed from Milestone 26 to Milestone 27

szarate wrote:

My feedback, I'll update this later today

"today"? ;)

Actions #10

Updated by szarate almost 5 years ago

mgriessmeier wrote:

szarate wrote:

My feedback, I'll update this later today

"today"? ;)

Today, 24 days ago xD, https://github.com/os-autoinst/os-autoinst-distri-opensuse/pull/8027#issuecomment-516304483 long story short, these failures from time to time happen mostly due to the worker being under some load, and will happen again regardless of using serial console or a tty (Which is kinda worse on aarch64).

I guess we could add some time in the future to take a look at this kind of problems... Not sure if somebody from tools team would be interested into looking at it.

Actions #11

Updated by szarate over 4 years ago

  • Subject changed from [functional][u][sporadic] test fails in timezone to [functional][u][sporadic] test fails in timezone - serial console is not reliable
  • Status changed from Feedback to Workable
  • Assignee deleted (szarate)

One option is to actually convert this test to a bash script and run it from there, after all... there's no screen matching, and no fancy things being used...

Actions #12

Updated by SLindoMansilla over 4 years ago

  • Estimated time set to 42.00 h
Actions #13

Updated by mgriessmeier over 4 years ago

  • Target version changed from Milestone 27 to Milestone 28
Actions #14

Updated by szarate over 4 years ago

  • Related to action #55967: [tools][u] test fails in gdb - Unstable serial terminal causes failures in different parts added
Actions #15

Updated by szarate over 4 years ago

  • Related to action #58697: [kernel][tools] test fails in install_ltp added
Actions #17

Updated by szarate over 4 years ago

Now that we have that PR merged, once deployed, we can bring back the serial console, specially for aarch64

Actions #18

Updated by szarate over 4 years ago

  • Related to deleted (action #55967: [tools][u] test fails in gdb - Unstable serial terminal causes failures in different parts)
Actions #19

Updated by szarate over 4 years ago

  • Has duplicate action #55967: [tools][u] test fails in gdb - Unstable serial terminal causes failures in different parts added
Actions #20

Updated by zluo over 4 years ago

  • Status changed from Workable to Rejected
  • Assignee set to zluo

https://openqa.suse.de/tests/3575790#next_previous doesn't show any issue with serial console. Suggest to close this ticket now.

Actions

Also available in: Atom PDF